Nexus 7 (2013) Forum

Support Nexus 7 stuck in bootloop, can't reflash factory image =(

can anyone please help me on this? I've spend the last 2 days trying to figure this issue out, my nexus 7 decided to die all the sudden one day while I was using gmail....the next thing I is stuck in bootloop

I can go to bootloader screen no problem, but everytime erase data from fastboot, I get failed <command wtirte failed <No such device or address>>

I tried using fastboot -w update in attempt to wipe everything, but I get the following

archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
archive does not contain 'system.sig'
Erease successful, but not automatically formatting.
can't determind partition type.
Failed <command write failed <no such device or address>>
can't determind partition type.
Failed <command write failed <no such device or address>>

I also tried doing fastboot oem unlock in hope to try different image, but the tablet would freeze everything I select the word "Yes, unlock bootloader (may void warranty) as well as my command promt

any help or suggestion please :(


#1 davidwanj, Jun 8, 2014
one thing I need to add...I never had USB debugging mode turned there a way to turn it on through either recovery mode or fastboot mode??? since I can't access settings when the device won't boot
#2 davidwanj, Jun 8, 2014
I don't think that zip is for nexus 7 2013. But you can use a toolkit like wugs and select hard brick to flash factory img, then USB debugging won't matter.
#3 Madbat, Jun 8, 2014
Based on the file name, that file is meant for the 2012 Nexus 7 rather than the 2013 which is probably why it's failing. You'll want one of these two depending on if you have the WiFi or data enabled version:

Data Enabled
#4 jhawkkw, Jun 8, 2014
thanks for the reply....I tried using fastboot -w update, I'm getting the following error....failed <remote: bootloader is locked.> as shown in the image

I don't know how I can unlcok my bootloader....everytime I tries to run fastboot oem unlock and click yes....the tablet would freeze and my command prompt would show "erasing userdata..."

#5 davidwanj, Jun 8, 2014
this is what happen when I try to do fastboot oem unlock and clicked yes

#6 davidwanj, Jun 8, 2014
Unlocking does erase user data. It may seem to freeze, but sometimes it just takes a while.
#7 Madbat, Jun 9, 2014
I left it there overnight the other day and it wouldn't do anything, just freeze there and the tablet wouldn't response to any I press and hold the power button down till it shut down
#8 davidwanj, Jun 9, 2014
What setup are you trying to use? Are you using a USB 1.0 or 3.0 port? Have you tried using different usb ports or cables?

If you use the arrow keys to try to boot into recovery, does it do so?
#9 jhawkkw, Jun 9, 2014
I only have USB 2, and I had tried 6 different port and even another computer...

I can boot into recovery mode showing android and a red ! mark
#10 davidwanj, Jun 9, 2014
is there anyway to put the device into maybe USB debugging mode while the device can't access the OS?

I want to see if I can unlock the device somehow, everything I had done keep saying bootloader is locked....if only there is a way to unlock the bootloader somehow

any help would be great,

#11 davidwanj, Jun 10, 2014
it say bootloader is locked even if I'm trying to flash factory image, make no sense :(
#12 davidwanj, Jun 10, 2014
Have you tried different cables?

The N7 can be very finicky with cables that are cheap, loose, or even minorly damaged.
#13 WoohooGuy, Jun 10, 2014
no, I tried 2 different computer, 6 different usb port, and 4 different cables....
#14 davidwanj, Jun 11, 2014
I can't figure out why the bootloader won't unlock, but if you boot into recovery and perform a factory reset, does that complete and if so, does it allow you to get out of the bootloop?
#15 jhawkkw, Jun 11, 2014
I have the same problem. I can't unlock the bootloader. It hangs at"(bootloader) erasing userdata..." Wipe cache/data and factory reset in recovery mode also fails.

I get this in recovery mode...
E:failed to mount /cache (Invalid argument)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:failed to mount /cache (Invalid argument)
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:failed to mount /cache (Invalid argument)
E:Can't mount /cache/recovery/last_install
E:Can't open /cache/recovery/last_install
E:Failed closing /dev/block/platform/msm_sdcc.1/by-name/misc (I/O error)
E:failed to mount /cache (Invalid argument)

#16 bigfootchester, Sep 20, 2014
I too am having the same issues, however I can't even boot into recovery mode, it boots the Google logo and sits there forever.

Has anyone figured anything out? :/
#17 CarrierX, Oct 2, 2014
What have you tried? Are you rooted? Flashing Roms? Need more info.
#18 Madbat, Oct 2, 2014
I am experiencing an issue where my Nexus 7 turns on but sits at the Google logo forever, I can however access fastboot. Though when I try to boot into recovery mode it again sits at the Google logo. The tablet is running completely stock 4.4.3, is not rooted, and unfortunately I did not enable usb debugging previously.

I have tried to use Wug's Toolkit to flash stock back onto the device however it ran through and it failed, so I tried to enable "Force Flash" and now it sits at erasing 'cache' ...

I have also tried to unlock the bootloader, despite not having USB debugging and it seems to start but freezes at the erasing userdata line, like the user that started the thread.

Sorry for the lack of detail in the last post I was just wondering if anyone had gotten something to work for this particular issue.
#19 CarrierX, Oct 2, 2014
I am also having the same problem.

Has anyone found a fix to this problem?

CarrierX, have you managed to get anywhere with this?

Any help would be appreciated.
#20 cybernomad, Oct 3, 2014
Not as of yet :/
Still looking.
#21 CarrierX, Oct 3, 2014
hello there
i have a nexus 7 2013
32 g
stock 4.4.4
no root no nothing
i was using it and it froze on me
so i turn off the device
then when i turn it on i got stuck on google logo
tried every thing and as of the time of writing this post
the cmd freaze when i type "fastboot erase anything"
recovery mode freeze on google logo
unable to flash using nexus root toolkit
unable to use the command
fastboot oem unlock
got stuck on erasing user file
it's been a month since my nexus got soft bricked
and it's been a week since i put serious effort and time
and still no solution not here not on any other website
i will let u know if anything new occurs
#22 BigDaddy89, Oct 6, 2014
I called Google Nexus support and after trying the typical reset/reboot strategies, he suggested talking to Asus.

After spending 45 minutes with them trying every option again, I got a RMA #. I'm pissed because its out of warranty by two months. Repair costs could be up to $200 (plus shipping), which is just shy of a new 32 GB Nexus 7 2013 ($230).

The rep said it could be the motherboard, which makes sense to me because my audio went out before getting stuck in this loop.

Sadly this inability to erase/reset seems to point to a hardware issue.
#23 Boxxman360, Oct 8, 2014
Did you send yours in? If so, did they confirm it was a motherboard?

Reading through this thread was like looking in the mirror. I was experiencing the EXACT same issue, and got to the exact same point. I've contacted ASUS 3 times, and get the same thing. My Nexus is 20 days out of warranty, and they won't budge.
#24 danteace, Oct 24, 2014
I did send it in. I never heard from them on the diagnosis. I was getting annoyed that they had my Nexus 7 for over a week, but just as I was about to call to find out what was going on, I received my Nexus 7 back in working condition.

I know its the same from the SN.

I got lucky because mine was 2 months out of the 1 year warranty, but whatever they did to fix it must have been simple or cheap because I never had to pay for it, just the shipping to them (could have been an error on their part, but I'm not going to call and find out).
#25 Boxxman360, Oct 26, 2014