Nexus 7 (2013) Forum

Root Nexus 7 WiFi won't boot

I have in my possession my friend's Nexus 7. I'm trying to diagnose what is wrong with it.

It's a N7 2013 WiFi with Lollipop, probably 5.0.2. I don't know the capacity.

Last night, it crashed and rebooted, and then it stuck on the boot-up splash animation. It stuck on it all night, and eventually depleted the battery.

I plugged it in, and the nitification light flashed a few times, and I got the battery charging icon. I let it sit for a while, then attempted to boot it up. Same thing as last night; stuck on boot splash for ~30 minutes.

I unplugged it, then held power button until it shut off. There hasn't been a visible sign of life since.

I connected it back up to the charger with a USB in-line power meter. The tablet charged all day at 460 milliamps, and then finally stopped charging about 20 minutes ago. (actually a few hours ago, I posted on XDA too and copied here for more exposure) Still no signs of life.

I've tried all the usual tricks and button combos. Nada.

When I tried plugging it in to my PC, it chirped and recognized the device, but still nothing on the tablet itself. I got further curious and checked Windows Device Manager. I found the tablet under Ports as a Qualcomm HS-USB QDLoader 9008.

So at least the CPU is doing something... It won't start the bootloader though, I'm guessing the flash is toast or went corrupt.

Is this a recoverable state?


#1 TheAmazingDave, Mar 10, 2015
I slid this into the All Things Root subforum. Give WUGs a look. I've restored a non-booting GNex with it before. It will help set up all the drivers.
#2 Unforgiven, Mar 10, 2015
I love the toolkit, but it doesn't boot far enough to get fastboot, unfortunately.
#3 TheAmazingDave, Mar 10, 2015
:( That's the end of my knowledge.
#4 Unforgiven, Mar 10, 2015
In wugs try picking the hard brick option then flash stock maybe.
#5 Madbat, Mar 10, 2015
I'm not in front of WUGs, I forgot about that option. How does it work?
#6 Unforgiven, Mar 10, 2015
I'll let you know in a minute. I didn't try it. I figured it wouldn't work since Fastboot doesn't start.
#7 TheAmazingDave, Mar 10, 2015
I only see the softbrick option, which doesn't work since there is no Fastboot.

#8 TheAmazingDave, Mar 10, 2015
Can you press and hold vol up + vol down + power and see if you cen get into bootloader mode. If so, I think it will work.
#9 Unforgiven, Mar 10, 2015

I found and installed Qualcomm QPST tool. It detects the tablet and says it's in downloader mode.

Now I need to find the hex files for the tablet, and I think I can bring it back. Any one have a lead?

edit: are the bootloaders between LTE and WiFi the same? If so, I'll try pulling the boot files from my LTE with QPST.
#10 TheAmazingDave, Mar 10, 2015 Last edited: Mar 10, 2015
Well I can't get my N7 to be recognized by QPST. I believe I need to put it in some sort of diagnostic mode, but I don't know how.

If anyone can clue me in I would really appreciate it.

Furthermore, if anyone has an N7 and knowledge of QPST, if you can extract the software from your tablet and send it to me, there might be a bounty available... ;)
#11 TheAmazingDave, Mar 10, 2015
No bounty needed. I do have both the 2012 and 2013 N7s, both up and running 5.02. Let me know what you need and how to pull it and I will. I have the drivers, and ADB set up for both. I'd just need to know the commands.
#12 Unforgiven, Mar 10, 2015
Again, this isn't anything ADB or Fastboot can handle. This is low-level shizz at this point.

I have no idea yet how to pull the required information from QPST. If I can figure that out, I may be able to pull the data from my N7 LTE. I was hoping that someone who sees this already has QPST, and knows how to pull the data and send it over. The dead N7 shows in QPST in download mode status. I need to figure out how to switch it to diagnostic mode, which is required to pull files from a working device. As is, if I plug in my LTE, it is not seen as a COM port and is not picked up in QPST. The dead WiFi is stuck in download mode, but thankfully gets picked right up in QPST.

I greatly appreciate your offer though. I'll keep you in mind if I can figure out how to safely put a working tablet in diagnostic mode.
#13 TheAmazingDave, Mar 10, 2015
OK, what I'm saying is I have working WiFi N7's. So if you figure out what needs to be pulled and how to pull it from a working one, let me know. I'll do my best to help. Whether it is ADB or a lower level access as you have referenced.
#14 Unforgiven, Mar 10, 2015