Samsung Galaxy S4 Forum

Support No SIM card error..... SIM card removed

Hi all

Last week or 2 been getting sim card error. Randomly my phone will suddenly stop recognising the sim card, so calls etc can't be made. On rebooting all is fine. This sometimes happens six times a day, sometimes every couple of days. It's very annoying.

I'm rooted and on Dan's GPE lollipop ROM, and thought it may be related to my obsession with tweaking and flashing. But factory resets and switching back to stock firmware makes no difference.

On trawling the web, seems it's happening to lots of people, whether on lollipop, KitKat, or older; to people on all networks in all countries; and seems to happen to both rooted uses and those who have only ever stuck to stock.

There are loads of theories and solutions out there, nine of which seem to work for anyone consistently.

I've tried full wipe, sim card clean, new sim card, different APN settings, different mobile network settings. No joy.

Someone has posted about a lose sim card lead ribbon and that putting foam in side the inner workings may work, so gonna try this next.

Anyone else got the same and want to share the love? Anyone else got a solution?

Will keep searching the web for a solution. ..
 

Related:

#1 Sydney99, Feb 19, 2015
I've not come across this on Lolipop Syd.
May be worth you going back to KK for a few days just to compare.
You say you've tried a new SIM with no joy, so my money is on the actual sim card connection, so try and wedge something in there to keep the SIM as close as possible with the contacts
 
#2 Hawker, Feb 19, 2015
Cheers hawker. Apparently there is sometimes an issue with either the lead or the connection between lead and the sim card port. I haven't got a small enough screw driver to access this. So have started with some diy inserts and wedges. Let's see how that goes.....
 
#3 Sydney99, Feb 19, 2015
Just ram a bit of cardboard from the cover of your pension book, in there Syd. ;)
 
#4 ironass, Feb 19, 2015
Seriously though Syd, try a piece of sellotape on the back of your SIM card... See if it helps.
 
#5 ironass, Feb 19, 2015
That's what others seem to have done, some say it works, others not. It's basically what I've done, so time will tell over the next few days.....

Useless Samsung junk....
 
#6 Sydney99, Feb 19, 2015
Should've got an iPhone old bean.

On the plus side, unlike our American cousins, we've got a 2 year warranty on our phones. ;)
 
#7 ironass, Feb 19, 2015
This has failed. Time to get a v small screwdriver and have a look at this ribbon lead people talk about
 
#8 Sydney99, Feb 20, 2015
:eek::thinking::oops:

or use more sellotape. ;)

Galaxy S4 SIM and micro SD card reader replacement

EDIT: GCHQ and the NSA won't like yo messing around with your sim card old bean! :p
 
#9 ironass, Feb 20, 2015 Last edited: Feb 20, 2015
Solving this remains a bit of an enigma. Seems the bits of guitar pick, selotape, foam people have been using is not a permanent solution.

My observation has been that this error seems to occur very frequently after flashing something new, whether it be a kernel, ROM, or modem. Then after a day or 2 it seems to style down and stop happening (as long as I flash nothing else).

In on philz recovery still, just wondered if it's possible it may be related to this?? Any thoughts or is there no way it could be connected???
 
#10 Sydney99, Mar 20, 2015
Funny one Syd. I'm presuming you have ruled out a poorly SIM card that is has worn or dirty connections? I can't see it being Philz unless the way a modem is flashed has altered in some way and Philz, no longer updated, is out of date. In that case however I can't see it working at all.
 
#11 dynomot, Mar 21, 2015
Yeah, think I'm clutching at straws....

Got a new sim from Vodafone, makes no difference
 
#12 Sydney99, Mar 21, 2015
Talking of clutching at straws... do you have an app like Vodafone or Sim toolkit on your phone? You may well have frozen it in TB. If so, try clearing the cache and data and re-booting to see if that helps.
 
#13 ironass, Mar 21, 2015
Good suggestion.... Got sim toolkit in apps, usually I keep it frozen. Tried unfreezing and freezing but doesn't make any difference. But never tried clearing the cache/data, so will give it a go.
 
#14 Sydney99, Mar 21, 2015
Ah Vodafone, lovely wonderful Vodafone. I didn't know that wonderful network was yours too Syd. They have emailed me today...... Blah, blah, blah upgrade due in July (yes, thank you, I know) would I like to upgrade now for "free" get a new 24mth contact and pay (available for pre order) an S6 for a whopping £54 a month (minimum). No I don't. I shall go in to a Vodafone store, speak to the first bod that approaches me, then their manager, then to the renamed "customer support" ie retention team. Then wait half an hour while the manager works out how to input my contract details and the codes they supply . Then walk out with an S6 (I haven't decided if that is what I want yet) for a maximum of £35 a month, minimum 500mins - texts unconcerned, data at least 8gig. Or I walk out with my PAC code. Easy, they always cave and always argue do the store managers, anyone think they were on commission...........:rolleyes::D.

Having posted the above, at least their 4G is improving in coverage and performance all the time. I can get a 4G signal nearly everywhere in Sheffield itself and now Doncaster, Rotherham and quite alot of Barnsley too. I have also been in Chesterfield town centre today and got 4G. However all calls revert to H+ H, G or an E signal, depending in what area I'm currently in. (can't be bothered to type out what the letters stand for) not voice over LTE then Vodafone? Which begs the question is it "pretend" LTE ie H+ to the max, that US carriers blatantly call 4G (it aint) or are you just saving your limited bandwidth for data? I might ask in the Vodafone forums, and get moderated again for telling the truth.
 
#15 dynomot, Mar 21, 2015 Last edited: Mar 21, 2015
Have you tried flashing the last stock KitKat vodaphone UK firmware Syd?
If so, then try one of the LP offerings from Voda eg. the Voda Ireland OB8, or the generic BTU OB7
 
#16 Hawker, Mar 22, 2015
Bumped into this just this morning out of the blue. The contacts on my SIM card have clearly oxidized - went from bright to dull - probably from contaminants during handling. A classic solution from the old-school (worked for me) was to use an eraser to burnish the contacts on the card contacts back to a shine. I had to insert/remove the card a few times to buff the internal contacts, but after four or five cycles everything came back to life and remained that way. A single layer of cello-tape can't hurt, but it effectively jams the contacts together to do the same thing. Just don't overdo it with the tape or you can damage things.

I have a "stock" G6 - no mods, no cracks, no root - so can't speak to those...
 
#17 simfool, Feb 19, 2016
I've had this issue with an LG G4, seems the fix with polishing the SIM contacts using an eraser did the trick for me.
For now anyways...
 
#18 SviddElg, Jul 22, 2016