Samsung Galaxy Rush Forum

Root [ODIN] not working for me - just crashes (solved)

I am trying to root my Rush by following the root guide posted by Shabbypenguin. The problem I am having is that Odin crashes when I hit 'Start'. I have used 3 different PC's each with a different OS: Win7, Vista and then XP. I am not sure what I am doing wrong and would appreciate any advice.

edit: CWM can now be pushed to the Rush via Odin. Thanks Shabbypenguin for helping us root this phone!

[​IMG]
 

Related:

#1 StewieGriffin, Dec 12, 2012
are you running it as an administrator?
 
#2 Shabbypenguin, Dec 12, 2012
Yes - I am running it as administrator. Thanks.
 
#3 StewieGriffin, Dec 12, 2012
The test version in the cwm thread does the same thing for me. (The one that says don't restore unless you are willing to risk a brick)
 
#4 Lordvincent 90, Dec 12, 2012
it dont work for me eather anit that a bitch lol
 
#5 dakid27, Dec 13, 2012
Yea i just tried using odin myself, same problem :( looks like i can't pull the file yet until i get it working, will the file work with an older version of odin maybe?
 
#6 Techwolf, Dec 14, 2012
I tried older versions of odin and had the same result - odin just crashed.
 
#7 StewieGriffin, Dec 17, 2012
unofrtunatly making the tars themselves apparently has become an issue for my computer.

i had what may have been a perfectly working cwm, but i got word that it wasnt so i deleted it. then it came to light the error may not have been cwm... so now im trying to backtrack and get things situated :/
 
#8 Shabbypenguin, Dec 17, 2012
I think its important to always appreciate someone's hard work! To criticize someone work especially someone who has contributed so much to forum isn't nice.let's be nice and show our devs support.
 
#9 n4zty, Dec 19, 2012
Hello everyone, I'll be coming to this forum officially the first or second week of January, just waiting for my friend to get her new phone then I'll have the Rush that she had, but is it possible that the CWM file might work with a newer version of ODIN?? Just a question, trying to drum up some possibilities for this issue... :)
 
#10 Slayer72, Dec 22, 2012
the issue is that i updated to linux mint 14 and it seems its not playing nice with making an odin tar like 13 and earlier did :/

sadly that is all, i have teh source and a what i believe working cwm just need to package it up :p
 
#11 Shabbypenguin, Dec 22, 2012
I've got Ubuntu 12 and im willing to tar it up if need be

hell I'll even set up a ftp account for you on my server and take some of the load off your bandwidth
 
#12 Robertech, Dec 22, 2012
if you could unpack the test tar, try making it back into a tar and see if it flashes. if it does it should be fully working :)

http://www.shabbypenguin.com/OUDstuff/Samsung/Boost/Rush/CWM-Rush-M830.tar
 
#13 Shabbypenguin, Dec 22, 2012
I have re-compressed with 7-Zip (Windows)..
Temp link:

[removed link]
 
#14 Tesla5, Dec 22, 2012
dl'ing now, will try when I get home tonight ;)
 
#15 Robertech, Dec 22, 2012
I may have done wrong.. compressed file in folder.. just file?
 
#16 Tesla5, Dec 22, 2012
you mean inside the tar you have another folder with a file inside? i may be wrong, shabby correct me, but I believe it should be a file in the tar and not a folder with a file
 
#17 Robertech, Dec 22, 2012
That's what I thought.. I messed it up.. I used one utility that automatically stuffs it in a folder when uncompressed and then used 7-Zip to re-compress.. I'll redo.

Edit: Okay I fixed it.. just recovery.img.. no folder
[removed link]

Are we sure that the recovery.img file isn't corrupt?
 
#18 Tesla5, Dec 22, 2012
looking at shabby's tar I see a folder in a folder in a folder in a tar... I'll try to flash both ways when I get off and see how it goes I guess
 
#19 Robertech, Dec 22, 2012
taht may be what is causing it, it should be just recovery.img inside a tar
 
#20 Shabbypenguin, Dec 22, 2012
email? I'll send what I have and u can test it
 
#21 Robertech, Dec 22, 2012
Mine is without folders if someone wants to test.
 
#22 Tesla5, Dec 22, 2012
www.shabbypenguin.com/OUDstuff/Samsung/Boost/Rush/CWM-m580.tar.md5

cant believe i derped that bad, someone mind checking this one out? :p

edit: and no i cant test, i dont have teh phone :p
 
#23 Shabbypenguin, Dec 22, 2012
I won't have my phone till the 24th.. maybe Robertech can when he gets home. I noticed the extension changed.. is that correct?
 
#24 Tesla5, Dec 22, 2012
tar.md5 ?
 
#25 Robertech, Dec 22, 2012