LG Optimus G Forum

Support Phone won't boot, red light flashing

So, not too long after making a thread about finding new roms, I was able to find one. And, being the careful person I am, I make a backup of my current phone state. However, at some point during the backup, my phone turned off. It was charging, so I'm unsure as to why it turned off.

Now, all that it is doing is flashing it's LED red in second intervals. It does nothing if it is unplugged. If I hold Vol- and Power, sometimes the LG logo will flash, and then the screen will resume it's normal darkness, no backlight or anything. I haven't really been able to replicate it. now, sometimes the LG logo does not flash at all, but the LED will start to flicker faster, still red.

I'm assuming I've bricked my device somehow. no idea exactly how, but I must have.

After a Google or two, I found this thread on XDA:

Unbrick phone part: Rapidly Flashing Red Light. - xda-developers

It describes an issue very similar to mine, except it's for a different model of the LGOG, the E970, while mine is the LS970. It thinks my phone is confused on charge state and recommends that I unplug the battery connector from the mobo and replace it to reset the device. I, of course, do not really want to do that.

Anyone out there have any more information on this?
 

Related:

#1 Doodleschmit, Oct 24, 2013
All their telling you is to pull the battery out and put it back in.But when you pull the battery,Just leave it out a few seconds.And unplug power(charger) cord from your phone.
It won't hurt anything. :D
 
#2 AMOCO, Oct 24, 2013

I have a tendency to mess up things like this... I think I'm actually going to take it to Sprint and see if there is anything they can do before I genuinely void any warranty I might/might not have.

If they can't do anything... THEN I'll permanently break my phone :D
 
#3 Doodleschmit, Oct 24, 2013
Holy Crap, you were right. I am completely confused as to how this fixed it, but I guess all I knew about the problem is that it was confused about the state of the battery. I just did the trick in the XDA forum link, popped open the phone and disconnected the battery for about a minute. and when I put it back together, it just turned right on! I am SO happy!
 
#4 Doodleschmit, Oct 25, 2013
So what if the link/instructions provided do not solve the issue?
Prior to finding this thread I had posted one complaining of a similar issue, only mine spoke of a SECURITY ERROR when turning back on (which it still does when the aforementioned instructions come to an end). Also, there is an issue when I try to factory reset it (thinking it could solve something) saying;

-----------------------------
Secure booting Error!
Cause:boot certification verify
-----------------------------

Anything?
 
#5 SLMlge970, Oct 28, 2013
Did you attempt the fix in that thread? I never got an issue like that. My phone simply would refuse to turn on. Every now and then if I waited long enough and plugged it in, it would flash the LG logo before promptly flickering it's light at me and turning off the screen. If you can get to anything else, I don't think its the same issue I had. because my phone wouldn't let me fastboot or go into the recovery. Your bootloader might be messed up. try to go into fastboot and get the drivers to connect to fastboot with your computer. see if you can flash a different recovery, or update it.
 
#6 Doodleschmit, Oct 28, 2013
Yeah, I worked on it for awhile and got nothing. Also, please forgive me for my lack of knowledge in this subject, haha, but how do I go about getting into fastboot and connecting to it with my computer, or flashing a different recovery? I'm fairly new to all this... :eek:
 
#7 SLMlge970, Oct 28, 2013
Not a problem :).

Getting into fastboot isn't that hard. When you are powering on your device hold volume up while you are holding the power button. You should see a black screen with some simple text at the bottom. From there, you will need to get ADB, software that let's you modify your device from your computer. After installing it and the special fastboot drivers, you should be able to issue commands to your handset. Look for the latest Recovery on TWRP or CWM depending on which you use and it should explain to you what you are looking for. Hopefully this will help... Although, to be honest, I am not sure. :/ this is a guess.
 
#8 Doodleschmit, Oct 28, 2013
Well, I can at least say I have learned a lot through this whole experience. Sadly my phone won't even register that it has a USB connection to my computer which happens to be the thing that this plan hinges on.
 
#9 SLMlge970, Oct 29, 2013
fastboot and adb are two differwnt things, try to find a way to restore the phone to full stock software, the certification error seems to me like its saying you flashed something on a locked bootloader

see if there is an lg software that can return the phone to stock through some sort of download mode
 
#10 junkie2100, Oct 29, 2013
Do this. See if you can get into download mode, (Google how to do it for the LGOG) then find a stock file for your specific phones's model. (Mines the Sprint Lg Optimus G, so its called LS970). You can then a program called LGNPST from LG's site and flash a file (usually in a .kdz format) to your phone to hopefully fix it. Google is your friend. However in the past, this hasn't worked for me. It has for other people, though. Good luck!
 
#11 Doodleschmit, Nov 1, 2013