Home Forum

Play Store error: rpc:s-7:AEC-0

Hi. I'm new to the forum, so I hope this is the right place to put this thread :)

Anyways, I've been having an issue with the Play Store all day, trying to sort it out to no avail. I'm using an international Galaxy S III i9300.

Earlier, I tried to download a paid app, and I couldn't. I got an error saying something about my Visa, which is registered to my account, was invalid. I went to my Google Wallet page on my laptop, and removed my card, then tried to add it again. I couldn't. When I try to add it from my PC, I just get an error saying my card could not be validated. When I try to add it through the Play Store app, I get error rpc:s-7:AEC-0 .

Funny thing is, I tried adding my dads Visa on my account. Same error, both on phone and PC. However, when he tried to add his own card to his google account, it worked just fine. That leads me to believe that there is no problem with my card, but with my account somehow (my card has also been used on other online stores and at the local grocery store today, so I know it works.)

I've tried a lot of fixes I found online, mostly what pops up is error rpc:s-5:AEC-0 (notice the 5 instead of my error, which has a 7). The fixes involve clearing data/cache from Play Store, Google Services Framework etc, and removing and readding the google account itself on the phone. Nothing seems to be working.

I've emailed Google Wallet support earlier, but haven't got any response yet.

Apologies for a long-winded post, but I want to give you as much info as I can. Anyone experienced a similar situation before, anyone know how to fix this?

Thanks! :)


#1 JoNAsOS3, Mar 4, 2013
Moved to Android Applications Section. :) Welcome to AF! :ciao:

Seems you tried what I would suggest which is clear the data/cache on the app. Have you tried another paid app?
#2 Metroid Prime, Mar 4, 2013
Thank you! :) Yes, I have tried several paid apps. However, the problem remains trying to actually add my Visa to my google account, be it through the Play Store on my phone (or the Play Store on my laptop for that matter) when trying to purchase an app, or Google Wallet on my laptop. There-in lies the problem, basically. I cannot add my Visa, I get an error as detailed in my first post.
#3 JoNAsOS3, Mar 4, 2013
That's odd. Have you made a different account and see if it still does the same thing?
#4 Metroid Prime, Mar 4, 2013
I added a different account to my phone. Got the same errors when trying to add my own Visa, and my dad's Visa to that account, both through Play Store and Google Wallet on the PC. This really makes no sense to me, why would I be able to add his card to HIS account, but not to any other?
#5 JoNAsOS3, Mar 4, 2013
Is your credit card up to date? Might be the issue if it's not. Had an issues on my xbox try to get MS points. I'll see if there's a possible setting causing this. :)

EDIT: Can't find anything in the settings about it.
#6 Metroid Prime, Mar 4, 2013
Yes, it should be, seeing as I have used it today in different stores :) And, the card itself doesn't seem to be the problem, seeing as I can't add my dads Visa to MY account, but I can add it to HIS account. I've tried to troubleshoot all night, but I can't find a logical explaination to this :p Thanks for all your help though!
#7 JoNAsOS3, Mar 4, 2013
No problem and we'll get to the bottom of it. Is there a setting that's blocking all app purchases in your account?
#8 Metroid Prime, Mar 4, 2013
From what I understand, the names have to match exactly from the card to the google account
#9 shelliewnj, Mar 4, 2013
There's no setting I can think of, no. Also, seeing as I've tried to add my card both through Play Store and Google Wallet on my PC, I can't see such a setting being the reason. Especially since I can't add it either on my own account, or the other one I tried.

About the names having to match, I've written my name as many ways I can think of. Also, when I try and add it through Google Wallet on the PC, the name is already filled out the way I filled it out before, when I first registered my Visa on Google Wallet (months ago, and many paid apps downloaded since then). I just don't unerstand how this problem could suddenly appear.

I appreciate the help, both of you! It's a bit like shooting in the dark at the moment, I'm afraid, since I can't think of any explaination.
#10 JoNAsOS3, Mar 4, 2013
You could try the Google Play settings or your account on the PC. Don't worry about it, it sounds pretty frustrating, but we'll figure it out. :)
#11 Metroid Prime, Mar 4, 2013
Another thought, did you contact the card company? Maybe they think it's unauthorized use? Shot in the dark, but who knows?
#12 shelliewnj, Mar 4, 2013
I've thought about it, and I'll definitely contact them tomorrow (it's the middle of the night here in Norway). I'll let you guys know if I find a solution, of course :)

EDIT - Just to test, I bought a piece of DLC for Fallout: New Vegas on Steam just now, using the same Visa and information. Worked just fine. Still unable to add that same Visa to Google Wallet and the Play Store though :p
#13 JoNAsOS3, Mar 4, 2013
Frustrating for sure!
#14 shelliewnj, Mar 4, 2013
There’s a bunch of links to that error on Google.
#15 jefboyardee, Mar 4, 2013
I've been through most of those myself, but thanks :) Some say it's an issue with the bank, which seems likely to me. I'm currently in contact with customer service at the bank.

Google's customer service told me there was a problem on the banks end with trying to verify the card/payment, so I'm hoping the bank will be able to sort it out.

EDIT - Now, the bank is telling me there is no issue with my card. They can't see any attempted transactions even. Google says the bank won't allow the verification to be made, the bank says that they haven't gotten any transactions to verify. Seems a bit odd, haha. Well, hopefully this will get sorted out by itself eventually, maybe just a kink in the system.
#16 JoNAsOS3, Mar 5, 2013
Sorry you're going through so much trouble with this. :(

Only thing I can think of at the moment is to contact Google about this.
Anything else I can think of will let you know. :)
#17 Metroid Prime, Mar 5, 2013
Both Google and my banks customer service seem to be unable to find any issues on their part, and I can't seem to find any on my part :p Well, I managed to put Play Store apps on my phone bill, so I'm able to pay for apps that way :) I'll try adding my card to my Google account in a few days/weeks to see if the problem has sorted itself out.

Nice to see people being helpful though, I really appreciate it you guys :)
#18 JoNAsOS3, Mar 5, 2013
Glad you at least found a work around, and mad at myself for not thinking of it for you sooner! that's how i used to pay for my apps!
#19 shelliewnj, Mar 5, 2013

I am observing the very same issue.
When trying to add the credit card number before purchasing the first app on my mobile, an error occurs (roughly translated to English):
"Error: Error while retrieving information from server: [RPC:S-7:AEC-0]"

This is Android 4.1.2

Please, post if you find a solution.
#20 zuraff, Mar 8, 2013
The only workaround/solution I was able to find, was to put the charges on my phone-bill. I'm still unable to add my card to my account. I'm also on 4.1.2.
#21 JoNAsOS3, Mar 8, 2013
I wonder if it's specifically an issue with that version of android? I'm on 4.1.1 and haven't seen it... thinking it's a bug?
#22 shelliewnj, Mar 8, 2013
Maybe it is. Though, it seems wierd to me that I wouldn't then be able to add my card from Google Wallet on the PC, or the Play Store on the PC (even when my phone is turned off, after clearing data/cache of the Play Store app and Android Services Framework on the phone). Still, it may be a bug, something to do with 4.1.2 being the last registered version my google account was connected to. I'm not going to downgrade now test it out now, too big a hassle at the moment, but if I do I'll let you guys know :) Interesting thought though!
#23 JoNAsOS3, Mar 8, 2013
Fwiw, I'm having similar issues. I tried to buy a Tapatalk skin yesterday, got the same message but the transaction went through and I got an email advising me of my purchase. About 5 mins later, I got an email saying it had been cancelled.

Tapatalk support say it's an issue with the Play Store at the moment and have no idea if/when it will be fixed.

Android 4.2.2 btw.
#24 El Presidente, Mar 8, 2013
Thanks for posting! Good to hear more about the issue, helps to narrow it down a bit.
#25 JoNAsOS3, Mar 8, 2013