Galaxy Nexus Forum

Support Power button not working?

For some odd reason my power button is not working. The only way for me to look at things on a screen is to plug it into my charger. I took it to a local phone repair shop and they said it had something to do with the powerflex (something flex, not sure if its powerflex) connected to the motherboard?

I might be searching for the wrong name because I cant find any online stores or ebay selling them. Theres Alibaba but I don't trust that site, it has bad reviews...

any recommendations or similar experiences?

It might be cheaper to get a new phone but I like this one since its rooted to the new Jellybean and I am afraid of losing all my music, shows and stuff. Im not sure if it is on the phone or on the SD card


#1 bap1331, Mar 17, 2013
Welcome, bap.

Did the tech clean the power button? :D

Meanwhile, considering your options at this point, you might want to have a look here:

#2 Frisco, Mar 17, 2013
The video Frisco linked you to is for the nexus s, the take apart is similar, but here is the one I followed to take apart my galaxy nexus:

You can access the power button very easily :)
#3 sdrawkcab25, Mar 17, 2013
Thanks for power button is starting to misbehave.
#4 iron_city, Mar 18, 2013
If your android device power button stops working, out of nowhere, try the recovery below.

Slide the battery in while the device is connected via usb/power cable.

Here are some detailed steps to help you get it right:

1. Disconnect the usb/power cord from the device.
2. Remove back cover from the device.
3. Remove battery, and leave the back cover off. You will place the battery back-in in a second.
4. Reconnect the usb/power cord to the device and then to your PC.

#5 jabyandroid, May 4, 2013
#6 vania_anjani, Jun 19, 2013
#7 maarten_wez, Apr 12, 2014
A couple days ago the power button on my Galaxy S3 began to randomly send my phone into a restart loop from hell. I had to pull the battery and wait 5 minutes before it would stop. This happened several times. I can’t even begin to express how crazy this made me.

I tried using Gravity to fix the problem but I wasn’t able to lock the phone whenever I wanted
because Gravity uses the stock lock-screen settings. It either locked every time I turned it on or not at all. After a lot of trial and error I finally hit on a combination of apps that worked for me and
I’ve decided I’d like to share this fix here. I’ve only used this with Nova, I doubt it will work with a stock launcher.

The apps.

Nova Launcher Prime. (Y’all should have it anyway)
Smart Applock (free version)
Tasker with the Auto-Shortcut plugin.

The steps:

Set up Gravity however you want it. ( I’ve found that it’s less annoying with the proximity sensor turned off and the sensitivity set way down around 4 or 5)
Gravity has a ton of options. So it takes a while to get it dialed in.

Set Smart App-Lock to lock just Nova launcher. This lets you lock the phone from a shortcut you can create using Tasker with the Auto-Shortcut plug-in.

Here’s how I set up the shortcut. It’s extra detailed in case If you haven’t had any experience with Tasker.

1. Create a new task in Tasker. I named mine “Lock Toggle”
2. Touch the +.
3. Go to “plugin”
4. Then choose AutoShortcut.

5. Configuration. Choose “Smart App-Lock” from the list. Hit OK. *If “unlock now” pops up just hit cancel. It will still work. Press the check-mark to exit configuration.

6. Press the back arrow (next to action edit) at the top to go back to the previous screen which will now have an entry saying “Smart Applock(on/off)”

7. Repeat steps 2-6 once. This creates an automatic toggle. The toggle launches Smart App-locks pattern lock (or whatever lock method you like) when the screen is turned off by the next step.

8. Hit the + again. Go to plugin then Auto-Shortcut. Configuration – Gravity screen off.

That’s it. Hit the back arrow again. Then exit Tasker.

Gestures are one of the many great things about Nova Launcher. I have mine set-up to turn the screen off (without the screen-lock) on a double tap to the desktop. And to turn it off (with the screen-lock) when I swipe one of my icons.

To do that. Long-press the icon. Press edit. Swipe action. Shortcuts. Task shortcut, then the shortcut you just created in Tasker. Or you could just have a shortcut on the desktop if you’d prefer.

One more thing. You’ll need to assign an icon to the shortcut the first time you try and launch it. I just downloaded a pic of an ignition lock that I liked and used that.

Hope this helps. Good Luck.

#8 Tyson LeForgey, Jun 26, 2015
Had this problem with my laptop, replaced the plug, and after several months started again so checked the fuse OK, so squeezed the fuse contacts and it works now
#9 randonneur, Jun 28, 2015