HTC EVO 4G Forum

Support Problem with YouTube App

I can't get the YouTube App to work. I can open YouTube from within a browser, but it won't open from the app- it just returns me to the Home screen. The widgit on the home screen shows the following message "Connection problem. Touch to try again" I am on wi-fi when I tried to use the app.
My browser is working fine on my wi-fi, and my signal is strong.
 

Related:

#1 sono gal, Jun 7, 2010
If you fixed your problem, can you please give me some pointers?

If you are STILL having this issue
You are not alone!! I just got my Evo on Friday and this is the first issue I noticed. I've been searching the web for answers..nothing. The YT app doesn't even show up in my list of apps, but the icon is sitting there on my home screen like a ghost.

I would also like to add that when to mobile YT in my browser, an additional pop up asks me to pick between HTC flash and Youtube. If I choose Youtube nothing happens. If I pick HTC Flash I get a black screen, with a youtube icon in the corner and the spinny dot circle of doom

Can someone anyone please help us???

Thank you
 
#2 PurpleBandit, Jun 13, 2010
I'm having the same problem Purple bandit. One thing I notice is that when I launch the youtube app by itself from the app menu, it works fine. It just won't work through the browser. Anyone have any ideas about this?
 
#3 robnelle, Jun 18, 2010
Try going to the Market and installing the YouTube app, it may just install, it may tell you "this version needs to replace your installed version" or it may ask you to uninstall/reinstall. do whatever you need to. I had to do this with Maps, Qik, and YouTube to get them to work from the app menu.

Else I would get an error message with Force Close, or it would just vanish. I have learned that my Evo is a better magician than David Copperfield. It can make any app dissapear.



-----------------------------


HTC Evo 4G
naked
model: HW002
not rooted
stock 1500 mAh Li-Ion battery
light leak issue all 4 "buttons"
screen separation issue
wifi icon incorrect issue
auto reboot issue
randomly freezes issue
 
#4 finndo77, Jun 19, 2010
The Original You Tube App does not appear to be in the App Market. So, we are unable to reinstall it.
This all remains so confusing.
 
#5 tim2c4v2, Jun 21, 2010
I have the same problem. A lot of the time, the YouTube app won't load and force quitting it or restarting the phone doesn't help either.
 
#6 Braaainz, Jun 21, 2010
try using Linda Manager or another app that allows you to backup your apps, in linda go to applications, then touch and hold the youtube app and try to backup the app. it stores backups on your SD card...

Nevermind on that, preinstalled apps do not show up in the Linda Manager list... well I'll post this anyway, as maybe you'll still want it for something else.
 
#7 finndo77, Jun 22, 2010
Youtube has been very problematic for me too. I notice that sometimes it takes forever to load and when it does, it will pause over and over again to buffer. I know it takes time to buffer but it should be ahead of the video. The video should not pause everytime. I also notice that sometimes it will do what the hero used to do and say this video cannot be played.
 
#8 Droidone, Jun 23, 2010
youtube app for me will start playing (and buffer fine) but then always stop a few seconds in. i mean like 19/20 times. it's not that it needs to buffer more, it just stops playing even though much more video is downloaded. wtf? it wont resume i have to exit and try again... and again.. and again.. really frustrating not being able to use this feature on a media phone!
 
#9 JustFrozen, Jun 23, 2010
I shouldn't of used the word buffer. Mine does the same thing as yours. Stops for no reason and keeps doing it though the video. I know this is intentional because WiFi works with no problem. Can anyone say limit. The video can be buffered way ahead and it still does it. My youtube on the hero was better with 2.1. HTC is getting in my nerve with these limitations. I will be sure to at least check out the galaxy s.
 
#10 Droidone, Jun 23, 2010
My friends You Tube app quit loading on his EVO and mine does he gets this error message about you tube processcom.google.android.you tube has stopped unexpectedley please try again and it won't open anymore. Any suggestions on what to do?
 
#11 Rose4uKy, Jun 24, 2010
I'm having the same problem except it only happens when I try to upload a video to youtube. "The application media uploader (process com.google.android.apps.uploader) has stopped unexpectedly. Please try again. Force Close". I don't see any youtube uploaders in the the market, only downloaders. It WAS working just fine... Guess I'll have to transfer via USB and upload from my PC... but WTF I'm paying money for a web plan, I wanna use it!!!
 
#12 rachelm920, Jul 2, 2010
My friends all of a sudden started working again it was weird. It started working but he still got some error message then all of a sudden that went away. Maybe it was cause of the software update who knows.
 
#13 Rose4uKy, Jul 2, 2010
I have the same issue with mine. I know what you mean if Im paying for a the plan I should be able to upload it within my evo and not to transfer it to my PC to upload.



 
#14 mtrajano00, Jul 2, 2010
I'm with you. I'm about to start a new thread on this issue. The Youtube App should upload darnit! (would use stronger language, but this is respectful community).
 
#15 bexier, Jul 6, 2010
My YouTube app never really gets past the loading screen. When I hit the search button, the search box will open for about 2 seconds and then return to YouTube main screen. I'm only on 3g but I didn't figure that would make that much of a difference.
 
#16 BombaySway, Jul 13, 2010
go to settings, applications, manage applications,(you may need to select the all tab on top) select the app the is force closing, and clear cache,

hope it helps
oilrigger88
 
#17 oilrigger88, Sep 19, 2010
My YouTube app came preinstalled and it has never worked. It will load and let me select a video, but then it says loading for a few seconds, and then tells me the video cannot be played. Anyone know how to fix this?
 
#18 dulgart09, Sep 21, 2010