Home Forum

Root root cricket zte grand x max

i want to try and root a cricket zte grand x max

 

Related:

#1 leo5111, Nov 12, 2014
Try Towelroot http://towelroot.com/
 
#2 Cyberdev, Jan 4, 2015
From the title, I thought this thread was presenting a root method. :(

Try frameroot and let us know if it works. I don't have the phone yet.
 
#3 JDubTrey, Feb 11, 2015
tried it it didnt work
 
#4 leo5111, Mar 11, 2015
try this. its working ... http://vrootdownload.info/ in english kinguser instead superuser
 
#5 gaspar66mx, Mar 22, 2015
None of the one click roots work for the z987 Ive tried every one possible for this phone including Chinese, Ive tried adb push commands with Windows, and Linux and still to no avail I haven't rooted this phone, It's locked up pretty well, but I will keep at it and let everyone know as soon as I find a method, and put it in detail...
 
#6 darandnik, May 27, 2015
 
#7 Christopherco, May 28, 2015
Go to this link, follow his direction, and you will be rooted in minutes, I did this yesterday and was very skeptical but yes, it worked. English version of Kingroot is used, TWRP for recovery. Finally a legitimate root method for cricket zte grand x max +
 
#8 Christopherco, May 28, 2015
Unfortunatly it doesnt work, root failed no strategy now, tried it 5 times for the zte grand x max plus z987, maybe for the older model, but thank you for the link...
 
#9 darandnik, May 28, 2015
Sorry messed with it a little more, went into the app manager, kingroot, cleared data, and tried again, and it did root, AWESOME, THANK YOU SO MUCH!!!
 
#10 darandnik, May 28, 2015
You're welcome
 
#11 Christopherco, May 28, 2015
TWRP acts kinda weird when you need to boot into recovery. Wait until phone goes completely asleep and then hit power. Don't change screen sleep settings in TWRP. I learned the hard way, I set settings so screen would stay on. Don't. I had to uninstall and reinstall to get back into recovery. Hope this helps everyone.
 
#12 Christopherco, May 28, 2015
Yes definitely weird, but seems to work fine, still can't get w/rw permissions for file manager, going to try the SD fix for Kitkat, and as soon as I can get working on some custom roms for this device... Thanks again...
 
#13 darandnik, May 28, 2015
After a lot of time with this rooting method, I have discovered a lot of different things, Ive installed titanium backup, file manager, removed apps with TB, and they come right back, can't get permissions to write, read write, so removing apps manually doesn't work, xblast tools, exposed installer, has to be soft booted all the time, TWRP does work and you can back up. But pretty much it is only half rooted, super user works, but you still don't have full privileges of being rooted, it needs some work, but its a great start, working to make it better, again thank you
 
#14 darandnik, May 28, 2015
yes, I have noticed that very same problem with the bloatware coming back. Achieving S-off with a new kernel I believe would give full rights
 
#15 Christopherco, May 29, 2015
Working on it, building meta inf, since I got a boot.IMG now, it will take a while because its all from scratch, I'll keep everyone up to date
 
#16 darandnik, May 29, 2015
Fantastic, thank you.
 
#17 Christopherco, May 29, 2015
I have gained system r/w access through this process : open terminal and type su You should get # Then type : dd if=/dev/block/platform/msm_sdcc.1/by-name/boot of=/dev/block/platform/msm_sdcc.1/by-name/recovery Then I type : reboot recovery when my phone booted back up, I had full rights and deleted some system apps. When I rebooted again I no longer had full rights but the system apps did not come back. This is just one more step towards full rights over system. Hope this helps.
 
#18 Christopherco, Jun 5, 2015
This can be done whenever you need full rights, I have even changed my boot animation and it has replaced crickets. All my bloatware is gone for good, which is really what I wanted. However I did full TWRP backup before I did any of this.
 
#19 Christopherco, Jun 5, 2015
Screenshot_2015-06-05-16-03-17.png
 
#20 Christopherco, Jun 5, 2015
 
#21 darandnik, Jun 5, 2015
That's awesome, been working on it, have custom boot animation and sound, got rid of most of the bloat ware, still working on a ROM, and now working with Linux as well trying everything possible to get full root, thanks for everything you are doing....
 
#22 darandnik, Jun 5, 2015
Great man!! It's so nice to have complete system access. Bloatware was my major concern and now that's gone, time to construct some Roms for this phone. Android 5.0 possibly? Haha
 
#23 Christopherco, Jun 5, 2015
Thank you I can change my my font and I changed my boot screen just need to figure out how to change the boot picture where it's says ZTE grand xda Max plus
 
#24 cgrimm9, Jun 7, 2015
I have noticed that doing soft reboots through xblast will retain full root rights after making various changes. But a hard reboot will lose rights again. I have to figure out how to keep full rights. Boot image seems to keep rewriting itself after hard boot.
 
#25 Christopherco, Jun 7, 2015