ASUS ZenFone 2 Forum

Root [ROOT][GUIDE][ONE CLICK] Asus ZenFone 2E/2/Z00D/ZE500CL/550ML/551ML

I am not responsible for bricked devices, dead SD cards,
thermonuclear war, your kids, your house, your wife, or you getting fired because the alarm app failed. Please
do some research if you have any concerns about this
before using it! YOU are choosing to make these modifications, and if
you point the finger at me for messing up your device, I will laugh at you.
A lot.

This guide will show you how to root your Asus Zenfone 2E, in one click. I have tested, and confirmed working on the AT&T ASUS ZenFone 2E/Z00D/ZE500CL

1. Make sure you have ADB Drivers, FastBoot Drivers, and your devices drivers installed. If so, skip to step 3.
2. Install ADB Drivers and your device drivers by downloading this.
1. Run it (Require administrator privileges)
2. Press Y/Yes to install ADB and Fastboot or N/No to skip
3. Press Y/Yes to install ADB system-wide or N/No for current user only
4. Press Y/Yes to install Device Drivers or N/No to skip (Device must be connected via USB Debugging)
5. Continue Driver installation - DONE!​
3. Connect your device with USB Debugging enabled.
4. Download the root files HERE.
5. Unzip to dekstop.
6. Open the folder, and double click on the file labeled "Root_zenfone.bat".
7. It will open a Command Prompt window, (Check your device for a popup asking you to trust the connection, click YES/ALLOW) your phone will boot into fastboot, allow the process to finish, and you're done!
8. Phone will reboot and you have root!

update SuperSU binaries if you want to update to a future OTA update, that is if Asus releases a 5.1 update.
DO NOT uninstall bloatware, as if an update were to arrive, it will brick your device. I suggest "freezing" the apps you don't need with Titanium Backup or Disable Application.
If you want to unroot, run Xoa_root.bat in the file folder.

Coty Thomas
[​IMG] [​IMG] [​IMG]

DEVICE: Asus ZenFone 2E rooted with ZenFone O.C. Root on 5.0.1
I Pay $20 A Month, What About You...


#1 cotylee1991, Aug 13, 2015 Last edited: Aug 20, 2015
Not working for me. Never finds the device
#2 n0tall0wed, Aug 19, 2015
Did you install your devices drivers using the ADB installer above? And was USB debugging enabled?
#3 cotylee1991, Aug 19, 2015
Yes and yes
#4 n0tall0wed, Aug 19, 2015
Found out why it didn't work. I didn't accept the adb connection from the computer on the phone. Thanks for making root easy for fellow ZenFone 2 owners
#5 n0tall0wed, Aug 20, 2015
Ah yes, you must click "trust", I will add that to the guide. And you're welcome!
#6 cotylee1991, Aug 20, 2015
This definitely doesn't install some strange Chinese malware ;)

Joking aside, have you tested the system update function, and how do you know it won't brick your phone on the next update if you only don't update the binaries and remove any bloatware?
#7 Djole94hns, Aug 23, 2015
No Chinese software, I swear [emoji3] strictly SuperSU as shown in my screenshot.

And as far as the binaries and bloatware, don't uninstall the bloatware because IF an update comes out, the update will try to update with those Apps, and if they are uninstalled, it could cause a brick or bootloop. And beings there's no custom recovery for the 2E yet, there's not really a way to save yourself if you were to get stuck in a boot loop. Same goes for Xposed, I don't recommend using Xposed until we have a custom recovery. Binaries, same thing, updating the binaries could cause a brick if an update comes out. And I've seen it happen to other ZenFone 2's and 2E's.

Just to be safe, just root, freeze the Apps you don't want, and we will have to wait for a custom recovery and further development. [emoji1]
#8 cotylee1991, Aug 23, 2015
Also, system update function still works, but currently there isn't any update above the 5.0.1 that is already on the 2E yet. I've contacted Asus and Google, both refuse to release any details about a 5.1 update for the phone.
#9 cotylee1991, Aug 23, 2015
Damn, you're quick to respond! Thanks for the explanation :)

I've already rooted it with your tool, so I hope it all goes fine. I don't see the need to remove bloatware in ZenFone 2, because they don't really have much of bloatware anyway.

So, thanks again!
#10 Djole94hns, Aug 23, 2015
I'm glad I was able to help! And I'm always around my phone or iPad to reply. [emoji3]

I basically froze all of the AT&T Apps. They got annoying.
#11 cotylee1991, Aug 23, 2015
Eh, I've got the unlocked, "stock" ZenFone. It's pretty cheap!
#12 Djole94hns, Aug 23, 2015
Hi cotylee, would you mind sharing which exploit was leveraged to elevate privileges?
#13 ORnH, Aug 26, 2015
So... what if I did that? Rooted, uninstalled a bunch of the bloat, then accidentally applied the OTA update. I've since tried everything I could possibly think of to get out of the bootloop, but nothing has worked so far. Re-rooting, wiping cache, factory resetting, etc. do nothing. Trying to re-flash boot.img, droidboot.img, recovery.img, or system.img all fail due to a permissions error. Any suggestions?
#14 e996, Sep 24, 2015
So much for always being around that phone or iPad to reply. Been almost a month and no reply...
#15 ORnH, Sep 25, 2015
hello, after clicking on Root_zenfone.bat phone reboots into recoverty
in cmd i get "dang root vui cho"
then "waiting for device"
and just hangs.
but phone boots back to normal n its not rooted. do u have any idea what it could be
n yes drivers were installed.
#16 playingmax, Oct 18, 2015
Hi there, I'm trying to root my Zenfone 2e. When I run the .bat adb never finds my device. I checked my phone and it doesn't popup anything. I think what my problem is the device drivers. I ran the adb setup which says it's installing device drivers but it doesn't seem like they're working for some reason.

Edit: I figured it out. Windows 10 is weird. Lol
#17 Bigshack37, Oct 25, 2015 Last edited: Oct 26, 2015
Okay, trying to root my 2e with this method. I have installed the drivers and turned on USB debugging, but when I hit the enter key in the command prompt, the cursor moves down and nothing happens. The phone never asks anything and cmd never does anything, it just hangs after "started daemon successfully." Did you guys figure out what the problem was? I'm running Windows 7.
#18 Cliffjumper126, Oct 26, 2015 Last edited: Oct 26, 2015
my phone rooted ok, can't get cwm or twrp to install, tried unlocking bootloader with no success, seems there have been several updated versions of bootloader since the forums came out. does asus have it locked again without a trap door?. getting a download glitch that freezes phone when downloading apps or anything else with cell data and wifi that i want to fix....other than that the phone works so well being rooted!
#19 starfishlover, Oct 30, 2015
some precautions that I found:

You must sure that is not in execution any Android Emulator (like BlueStacks) during the process, otherwise "Root_zenfone.bat" don't find the device.
#20 Coolo, Nov 4, 2015
Hey Im having the same problem how did yours to root
#21 domilee13, Nov 8, 2015
I had tried the device drivers that came with the root software but even though it said it was installing "device drivers" it never did. This may have been because I was on Windows 10. I turned on debugging on my phone and I noticed in device manager that it showed up as android debug device but it didn't have a driver for it. I just allowed Windows automatic driver installer to find the driver. Ever since Windows 8 most drivers can be found automatically if you just let it try.
#22 Bigshack37, Nov 10, 2015
Hi, I tried to root my zenfone go whit your sistem, but it' s blocked in a black screen with "USB transferring... USB transition OK Time: 0ms Vel: 0kb/s" The Command Prompt is closed, what can i do?
#23 Cicciux, Nov 28, 2015
thank you for te gret guide sir, do you know any custom roms for this ZE500CL, this is the 1st reply in this forum, thanks for any help
#24 Juniedi, Jan 29, 2016
Everything runs ok but when I run Root_zenfone.bat I get :
error: cannot open 'magic'

error: cannot open 'busybox'

error: cannot open 'supersu.tgz'

error: cannot open 'installer'

I think this is ****ing me up? As I do not have root access
#25 Unremember3d, Mar 5, 2016