Home Forum

SCH-R740C Discover

So my phone wont let me get back into recovery mode after flashing CWM thru Odin. It works fine otherwise. Can I get some help on this? I want to learn. Wouldnt mind how to learn to write a proper CWM for this phone either. Maybe if I could find stock rom for samsung, flash it. I need a walk=through if someone wouldnt mind.

 

Related:

#1 Spawdiggity, Dec 5, 2013
Welcome to Android Forums.

If you tell us the what phone you are using and who your carrier is we could move this question to the appropriate all things root sub-forum dedicated to your phone.

I moved this thread to the forum for discussing phones that don't have a dedicated forum.

... Thom
 
#2 Thom, Dec 5, 2013
He listed his phone in the thread title. SCH-R740C is the samsung galaxy discover (SCH-R740) with the provider Cricket Wireless (the c at the end). Not sure what the OP is asking but figured I'd answer Thom's question.
 
#3 sniperfox47, Dec 5, 2013
Yeah, I'm sorry about that. My question is what do I need to do in order to gain access back to recovery mode? I tried flashing CWM thru Odin again a few times. Binary counter goes up. Phone turns on normally, and it works fine. I just cannot get into recovery mode.

The link for the thread where I got the download for Odin and CWM is

This Thread Is Dead!!!!!! - xda-developers

This is for Discover SGH-S730M, thought I would give it a shot since there isn't much for SCH-R740C.

There is a link also that goes directly to the downloads.

Odin+CWM.zip - Google Drive

I hope this helps. If you check out the thread I was reading, you can see there are clear instructions provided. If needed I can give you more details.

I also was hoping to start a good thread for this phone SCH-R740C because it seems a lot of people have issues with it but there are no solutions.

I am aware that this is for my exact phone. Sorry about the lack of clarity in my first post.
 
#4 Spawdiggity, Dec 5, 2013
I have the SCH-R740C and have been looking everywhere for a stock recovery.img in order to get it to boot normally. Stuck at the Cricket boot logo screen, I wasn't paying attention, got busy and Odin'd the wrong recovery.

I'm trying to get a VirtualBox set up with the Android SDK installed and will try to compile the kernel. The source is freely available at Samsung Open Source Release Center.

I'm about 20 years obsolete in my coding chops, but if I've got a decent "read me" file, I can follow directions.

Once I've hopefully got it compiled successfully, I'll try to Odin it to my device...

I don't know what else to do... have an acquaintance on another blog that's going to try to pull the recovery.img from his Discover... hope springs eternal.
 
#5 pauljulian, Dec 18, 2013
My phone is cricket muves phone ars. I can't rember screen code to unlock it
 
#6 nicolehartman, Dec 26, 2013
anyone make progress in this..? i too am stuck at the Cricket logo.. i've been searching through the opensource and working on it, but it's slow going -.-; just buying a new one tomorrow, but would like to solve this for future reference.
 
#7 factualpuddle, Jan 11, 2014
I have seen this issue on several, and by several I mean about 15 or so of these discovers. They all either will only boot to recovery or boot to a blackscreen with backlight. The ones that I have seen are not rooted or have a custom rom/recovery. Without an odin restore file, I cannot determine whether it is a software or hardware issue. My gut tells me that it is corrupted NAND memory because when they lay down like this, they seem to be done for.
 
#8 crmcsh01, Jan 15, 2014
Hello everyone! Im experiencing the same problems as most...My SCHr740c is stuck on the blackscreen when i turn it on.I am able to access recovery and download mode. My phone has never been rooted so Does this change anything as far as my ability to fix my phone or methods used? please help out if you can.This is actually my roommates phone and im on the hook for replacing it.Im clearly a noob with smart phones and technology in general.Thanks in advance
 
#9 shoester21, Jan 15, 2014
*sigh* ohh the problems with this phone. After rooting and successfully installing a custom recovery on my second Discover, this morning I just received a firmware upgrade. Now my new Discover is a brick.Had it for a month or so. Damn. @pauljulian, any luck with what you were working on?
 
#10 Spawdiggity, Jan 28, 2014
How bad of a brick? Because if it's the whole "Please plug in to a Computer with Kies" message fiasco, then you can try to use the Odin-ready Recovery Image and see if it removes your brick from here: Link
 
#11 CyberTails, Jan 31, 2014

look here. have to use odin to write software back to phone
plenty of forums out there with info on how to use odin

ODIN Files for Galaxy Discover *NEEDED*
 
#12 supreme83, Jan 31, 2014
Oh I fogot to post back. My bad. Shortly after I made my post about a few days ago, it occurred to me to use odin, flash Rom, etc. Problem solved guys. Thank you for your help though guys. I'm way new at this but I'm getting it. Trial and error.
 
#13 Spawdiggity, Jan 31, 2014
For anyone who needs help with this phone still click this link, they know whats up! SCH-R740C Cricket Samsung Galaxy Discover CWM / CyanogenMod development - xda-developers

Be sure to read the thread!
 
#14 Spawdiggity, Mar 1, 2014
SCH-R740C Cricket Samsung Galaxy Discover CWM / CyanogenMod development - xda-developers

Check this out, will help!
 
#15 Spawdiggity, Mar 1, 2014
I Forgotten My password I want to unlock without factory reset ?its a sch-r740c from cricket Can Anyone please help Meeee!!!!
 
#16 Kayte0621, Oct 5, 2014
do you have cwm??
 
#17 ferrersteve, Apr 20, 2017
the link xda wont work anymore
 
#18 ferrersteve, Apr 20, 2017