Samsung Galaxy S3 Forum

Support Screen auto-rotation is NOT working

Hi there

I have the screen auto-rotation on but for the past week, my phone has been stuck on portrait mode.

Basically my pics and Youtube vids can only be viewed in portrait mode and NOT landscape mode

I tried turning the feature on and off and restarting but nothing worked

Any suggestions?

EDIT:

Looks like other folks are having the same issue

www.google.com/url?sa=t&rct=j&q=&es...Y1hxFo5RlVbVr9evg&sig2=1URfEqPf89xHPsGrv8m3Tg

Anyone found a fix yet? Or will we have to wait for Google to release a new update? >_>
 

Related:

#1 salhalwa, Jul 29, 2012
Did you try recalibrating the gyroscope? (it's under Display in Settings, weird place for it)

Edit: you have an S3 right? The link you posted is for a different phone
 
#2 jaymf, Jul 29, 2012
I had this problem all I did to fix it was take my battery out and restarted my phone and it worked
 
#3 hemplacrosse4, Jul 29, 2012
I had the same issue! I have the samsung galaxy s5 and when it updated to the Jelly Bean OS the screen stopped rotating. I was just dealing with it until I found the post below, taking out the battery and clearing the cache didn't work for me.

http://inside-galaxy.blogspot.com/2014/10/samsung-galaxy-s5-how-to-enable-and-use_28.html

This worked!!! The trick is in Settings-Display-Screen Rotation and switch it to "on". The Jelly Bean OS calls it "Smart Rotation" instead of "Auto Rotation"
 
#4 clairebear14, Sep 22, 2015
My phone is Micromax unite2. Android version is 5.0 lollipop... Even iam having same problem... Everything is in portrait mode..even turning it on nothing is happening..
I've already tried the above mentioned solutions but nothing is working.... Pls help
 
#5 lisa mate, Aug 11, 2016
Easy fix worked for me, go to settings, display settings and g calibration settings. Leave down on flat surface and calibrate. Took 3 attempts to calibrate but works perfect now
 
#6 Keane007, Jan 3, 2017