Alcatel OneTouch Fierce 2 Forum

Root [Script] Replace KingoRoot with SuperSU

(edit)
Version 1.3a

Since KingoRoot doesn't like being replaced, I've put together a quick couple of scripts to help move to SuperSU. I banged away at my Fierce 2 manually to make sure this method works, and then condensed it to something that virtually anyone should be able to do.

Credit also goes to najoor over at XDA, for detailing the steps to removing KingoRoot on their Amazon Fire Phone. I'm thankful to KingoRoot for releasing an exploit that works on our devices, but I'm not a fan of their superuser app, and they don't make it particularly easy to switch.

Download the script at the top of the post, and make sure to read the readme. I'll sum it up here, but the readme has the full instructions with easy to follow steps.

You need to keep a shell open with root access for the entire process, don't close it as you'll probably end up needing to re-root with KingoRoot. First, step0.sh copies SuperSU's daemon to the device and starts it. Next, you use KingoRoot to remove root permissions and uninstall the 3 KingoRoot apps. Next, step1.sh removes all traces left from KingoRoot. After that, install SuperSU from the Play Store, and it should give you the option to update. Pick the normal method, not recovery, and let it finish its install. If it succeeds, great! Reboot and you're done. If SuperSU's app fails to update su, or can't find su, manualsucopy.sh will install SuperSU's binary and all accompanying files. Once it finishes, reboot and you're set!

I believe the final step may not be needed, but I've included it anyway, just in case. While experimenting, I overlooked starting daemonsu, and I believe that's the reason I needed to manually install SuperSU. This script actually starts the daemon, so the SuperSU app should be able to update itself, but if it can't for some reason, the final step will install SuperSU's binaries as long as you still have a root shell to run it from.

Feel free to post with problems, questions, or suggestions!

(edit)
Updated link to the latest version.

 

Related:

#1 bakageta, May 17, 2015 Last edited: May 25, 2015
I'm doing this as soon as I punch the clock and go home. Much appreciated. Not a huge fan of king either but still grateful for the exploit.
 
#2 atomilluminati, May 18, 2015
thank you, im getting ready to attempt ill post the results
 
#3 jdzero89, May 18, 2015
im not sure if im doing something wrong im following the instructions in the read me file but when i use the ./step0.sh command this is what i get, also i noticed it says its for kingo root does it work with king root?
 
#4 jdzero89, May 18, 2015
I'm fairly sure the entire rooting package is called Kingo Root, and it's just their su management app that's named KingRoot. Regardless, we're talking about the same app, you've got the right script.

Now, for troubleshooting. It's choking on the mount command, there could be a couple of reasons for that. First, it doesn't look like you've got a root shell going. After you su, the prompt should change to a # to indicate you're root. Did you give root permissions to your terminal app? Have you verified you're rooted with another app?

It could also be a syntax difference, I'm used to having busybox installed and it happily accepts "-o rw,remount", but some stock mount commands choke on the comma. Get a root shell going and try typing both of these commands, just to see if I need to adjust the script or if it's a root issue:

Code (Text):
  1. mount -o rw,remount /system
  2. mount -w -o remount /system
If the first one spits out the same error of "Usage: mount [-r] [-w] [-o options] [-t type] device directory" but the second one doesn't, then I'll need to edit the script. If neither do, it was a root issue. If both spit the error out, then something is horribly wrong.
 
#5 bakageta, May 18, 2015 Last edited: May 19, 2015
you can see that i did have su #
but it didnt seem to work for me and i tried like 2 or 3 times.
 
#6 Im4Android, May 19, 2015
bump
 
#7 Im4Android, May 19, 2015 Last edited: May 19, 2015
Mine is actually called "Kinguser".
 
#8 Im4Android, May 19, 2015
There's no need to do it more than once, it won't start working suddenly... :p Just an oversight on my part, I use busybox's mount, which is more tolerant than the stock one apparently. Slight change to step0.sh and it should work on both.

(edit: see first post for latest version)
 
#9 bakageta, May 19, 2015 Last edited: May 25, 2015
ok bakageta i will try this one. btw i also have busy box installed and i only tried
more than once to see if it was error on my part.
 
#10 Im4Android, May 19, 2015
Wish i had better news bakageta...:(
 
#11 Im4Android, May 19, 2015
question bakageta, did you use this app:http://www.kingoapp.com/ or this app:http://www.kingroot.net/
to root your device?? because i used the one from kingroot.net.
 
#12 Im4Android, May 19, 2015
Well, I'm completely at a loss for why something as simple as mount wouldn't work for you... I just ran the step0 script again on my device and mount doesn't choke and die. Try manually remounting system as read/write just before running step0, it will stay read/write until you put it back or reboot. A couple of example are in a post above, directed at jdzero.

I rooted with KingRoot-4.0.0.233-release-201505071219_105001.apk, from KingRoot.net, so that shouldn't be an issue.
 
#13 bakageta, May 19, 2015
Thank you for your help Bakageta unfortunately the updated files giving the same error and I tried manually mounting but nothing happened
 
#14 jdzero89, May 19, 2015
I am functionally ********. I managed to mangle the scripts to windows newlines when I pulled them off my device. Of course the scripts with unix newlines still on my device worked. Third time's the charm?

(edit: see first post for latest version)
 
#15 bakageta, May 19, 2015 Last edited: May 25, 2015
This is what I got should I go to the next step?
 
#16 jdzero89, May 19, 2015
Looks good to go. If you want to be certain, do a quick list of /system/xbin, and you should see daemonsu in there. Just type "ls /system/xbin/"
 
#17 bakageta, May 20, 2015
So I should uninstall all three apps then run ./step1.sh
 
#18 jdzero89, May 20, 2015
Yep, you're ready to move on. Make sure you follow the instructions to revoke root permissions, it'll uninstall one of the apps, then you can uninstall the other two normally.
 
#19 bakageta, May 20, 2015
It works 1000% :D !!
This shall henceforth be known as the BAKA method for removing KingUser.
 
#20 Im4Android, May 20, 2015
Thank you for all your help that last one worked and I now have supersu
 
#21 jdzero89, May 20, 2015
Bakageta sapeee thanks man

http://kn3.net/30C3407E857JPG.html
 
#22 lucianochoa, May 20, 2015
Thanks it worked
 
#23 ProSkillZ, May 20, 2015
Its not working for me. Keep getting errors on step0.sh daemonsu not found and cant mount error
 
#24 ITZMERY4N, May 21, 2015
Have you downloaded the v1.2 version? It should fix that.
 
#25 bakageta, May 22, 2015
Hi Bakageta, please help me!
First of all , sorry for my poor english, i am brazilian. haha.

In attempt to replace kingoRoot the system displays the following error : Screenshot_2015-09-11-15-57-02.png

I have installed both apps, but Kingoroot is who grants access to the root.
I use the Terminal Emulator App.

Please help, i am willing to start from zero whith the reinstall all Android...
Tanks!
 
#87 Rodbontempo, Sep 11, 2015