Sony Xperia Z Forum

Sony Xperia Z Won't charge, through USB, In Car charger or Wall Socket (not even a red light)

Hi All,

I have had the Sony Xperia Z since June this year (2013) it has been charging and running absolutely fine till last month when out of the blue one weekend it refused to charge. I happened to be away for the weekend and when I came home on the Monday it started charging again as normal and I got a full charge. It acted fine afterwards so I thought it may of been a one off however this weekend just gone I was away again when my phone refused to charge. I've tried different chargers (not all Sony) to see whether that would work, I've tried in car charger, wall charger and connected it with a USB to the computer and none will work. Annoyingly you can not take the battery out of the Xperia Z as it is in built but I downloaded Sony Update Service to see whether maybe it needs an update but you need 50% battery available and I tried connecting it but it wouldn't find my phone. I have looked on other websites and a few people have also had this problem especially when leaving the battery to completely drain which is what I probably did too. I have tried their suggestions including holding down the volume button whilst plugging in the charger to no avail. The last resort would be to send it off to a technician via O2 (my network) but that is a last resort so I wondered if anyone had any suggestions before I did that.
Any help would be appreciated
Many Thanks
TechyGirl27
 

Related:

#1 TechyGirl27, Nov 26, 2013
All I can think of is:

* Forcing a complete shutdown: generally with fixed battery phones pressing and holding the power button for 10-15 seconds does this, though I don't know the Z in particular. It's the nearest equivalent to a battery pull that you can do.

* Connecting it to a wall socket charger (higher current than usb or most car chargers) and leaving it for 8-12 hours. Though that's usually for when the phone runs completely flat and won't respond to the charger, while it sounds like yours is still running but not charging, so I suspect this isn't relevant.

Otherwise I would suggest backing up your data and sending it in for repair.
 
#2 Hadron, Nov 26, 2013
Hi Hadron,

Thank you very much for your reply. My phone won't actually turn on, it is completely flat and won't respond to anything. I have tried to charge it several times overnight with a wall charger but nothing happens. When I press the power button when the phone is on charge the charging light flashes for a few seconds but then nothing happens. When I press the power button without it being on charge the charging light doesn't even flash!

It looks like it may have to be sent to the repairers :-( Only thing is, is there a way of backing my phone up whilst it is turned off? I have tried to plug it into my computer via a usb cable and run Sony Companion which is how I usually back my phone up onto my computer but the program cant find my phone.

Any help would be appreciated.
TechyGirl27 :)
 
#3 TechyGirl27, Nov 29, 2013
I solved my problem. What I did was press the volume up button on the phone. As I was holding it I plugged in a power source and I held the volume up button untill I saw a blue light. I left it on the blue light for 5 minutes so I could charge the phone while its off force charging it. Then I unplugged the charger and booted it up like normal and plugged the charger back in once it booted up. Hope this made sense. I am new to these forums
 
#4 Dominic_Cuevas, Jul 11, 2014
Dear Sir.... i would like to xpress my utmost gratitude.....

i recently had a phone stolen and bought a new z ultra,..... it stopped charging and i got so sad ..... im really thankful of u for presenting a solution....

Godbless
 
#5 Fuad Ul Hasan Khan, Jan 30, 2015
This saved me! I spent the whole night with the Sony support and they are not going anywhere. They kept asking me to update the software while the phone could not even be turned on. I have used many Sony products and this is disappointing. Reading the web this does not look like a rare problem.
 
#6 WolverineMD, Feb 11, 2015
nothing is working for. when i connect it to my charger its flashes red light. when i caonnect to computer it connects for about 5 seconds then disappears for 5 seconds then connects again and on and on. anyone want to help please.....
 
#7 phone12, Feb 18, 2015


This worked like a charm. Power button +volume up button at the same time for 10 to 15 minutes, phone vibrated and turned on. I unplugged it and charged it with the Sony charger. Never letting my phone die like this again.
 
#8 Ritseeniyah, Aug 18, 2015
hi TechyGirl27,
i have same problem with you with my Xperia Z1. Its totally can't charge it or turn on.
had you solved it? Please tell me how you do it? send to Sony service centre? Thanks.
 
#9 Kenzofai, Oct 4, 2015
The OP hasn't returned here for almost two years, but as noted in in another post try holding the VOL_UP and POWER buttons while connecting the USB cable to boot into Fastboot Mode. This may allow it the battery to charge sufficiently so that normal charging can take place.

p.s. the Z1 (and later handsets) have a 'soft reset' button next to the SIM slot; pressing that for a few seconds may force a normal startup.
 
#10 Slug, Oct 5, 2015
yes, i had tried all steps before i posted here. the last time i charged it, i use AIDA64 monitor the charging rate- its show Charging in the status, but in the meantime showed discharging rate rather than show charging rate! i mean normally charging rate about 1k mAh, but now its become discharging rate 500 mAh, discharge 1.5k!

At 1st i can switch on it using soft reset or power + vol, then now 2nd time it totally dead. i overnight charge it with 2.1A also can wake it up.

i think i have no choice and take it to service center later.

anyhow, thanks for your advice.
 
#11 Kenzofai, Oct 5, 2015
Thanks
[guys i got the similar issue with my handset but following your post i got relaxed now my phone is getting charged

Thanks a lot to u all

Stay blessed
Regards,
Amitkumar Pipalia



UOTE="Kenzofai, post: 7101934, member: 1894108"]yes, i had tried all steps before i posted here. the last time i charged it, i use AIDA64 monitor the charging rate- its show Charging in the status, but in the meantime showed discharging rate rather than show charging rate! i mean normally charging rate about 1k mAh, but now its become discharging rate 500 mAh, discharge 1.5k!

At 1st i can switch on it using soft reset or power + vol, then now 2nd time it totally dead. i overnight charge it with 2.1A also can wake it up.

i think i have no choice and take it to service center later.

anyhow, thanks for your advice.[/


Thanks
 
#12 Amitkumar Pipalia, Dec 12, 2015
I had the same issue and resolved it.

Mine doesnt have a red light when plugged to a charger. While plugged to a wall charger I tried pressing vol up + power button. Make sure too press it too long i did mine for 5mins and suddenly i felt it vibrated 3 times then the led red light went on and the charging status. I hope it works for you too.
 
#13 Leroy_xperia, Jan 17, 2016
Good day All

I have had the same problem:
Phone (Xperia Z) reached 0% battery; and did not want to charge

Not charging through wall charger; or USB; or powerbank. I also had a docking station; and it did not want to charge there either.

Tried the power + volume up; or power + volume down; and all variables; but it still did not want to charge.

The LED light also refused to light up.

I read on one forum for a Z1 had a polarity issue with the magnetic docking station; and therefore they reversed the polarity and thereafter it charged? did not understand a word of it; but it gave me an idea to try and fix my problem:

I managed to fix it as follows:
The docking station was taken apart in order to have better access to the pins that connect with the xperia z.

I then placed the pins on my xperia z (while connected to power); and swopped them around a few times to see if it will have any effect. (there was not much hope that this would work)

Before I knew it; the LED turned red; and I was able to charge it enough to plug in the normal charger. Phone fixed :)

Before you go and buy a docking station; I also read of a few people using old usb cables; cutting them open; and placing the red and black wires on these docking pins for the xperia z.

Perhaps this fix might work for you too

Please note that I am in no way qualified as a technician of any kind; and therefore cannot take responsibility if any of the above options do not work. Just explaining how I managed to fix my issue.

All of the best fixing your Xperia Z
 
#14 Suurpruim, Jul 5, 2016
It happened to me too on my z ultra & c5 ultra. The solution for me was to press the button next to the sim. Both phones have it. On the Xperia Z ultra it's a red button and for those who have a c5 ultra it's yellow. This solved my issues with charging. Ps tried the options above but seemed not to work in my case.
 
#15 Blackpearl1477, Oct 15, 2016
I have just had this same problem AGAIN. Last year, I sent my phone off to the Sony Repair Centre, lost all my data and it was a great inconvenience. I tried the power button + volume up button advice multiple times this morning and it didn't work. After reading your note, I kept holding it much longer than the recommended 15 secs and after 3 minutes it finally vibrated and now seems to be charging. Thank you so much!!!
 
#16 Phoneuser9, Jan 13, 2017
FWIW if sending any phone to a service centre, do backup. They might factory reset and wipe every device as policy, and also if they replace rather than repair, that's your data gone.

Also if you happen to have anything illegal on it, do erase before sending it in.
 
#17 mikedt, Jan 13, 2017
I really thought I had lost my phone, I was even thinking of buying a new one. I own a Xperia M5 (not the dual version) and I used the reset button that's next to the SD module as Slug suggested. I had installed a stupid version of android that literally bricked the phone but the reset button made the trick. I connected the USB cable to the computer and put the phone in Flashing Mode: Volume down button and then connect the USB cable (it may be different for your phone but that's for mine), the computer recognized it so then I used the Xperia Companion software to restore the Android version I used to have, now the phone is back up and running. As I mentioned before I thought about giving up but I kept reading and found a solution. Thank you guys for opening these forums and keep sharing your thoughts, you never know when a few lines of text could really help someone. Hope you find a solution for any issue you're experiencing with your phone. :)
 
#18 Will2k17, Feb 10, 2017
My 4 years old Sony Xperia Z1 has served me well and recently was running out of charge rather fast and also if the phone was on the charge was struggling to keep up. I assumed it was the 4-year-old battery and changed it with myself with a £10 kit. However, the problem persisted and I thought it is either the Motherboard or software. The motherboard is not an easy one to fix so I repaired the software using the new Xperia Companion connected to PC and the problem was solved. I also deleted any APP that I was not regularly using or from a dubious source and the phone behaves like brand new.
 
#19 Salaro, Jul 11, 2017