Home Forum

Stock calendar display holidays?

How do you get the stock calendar to display the holidays? I have the US Holidays calendar and it says that it is synced and visible but the only place that the holidays show up is in the agenda, Week, or 1day views. Is there a way to get the holidays to show up on the Month view? The holidays are displayed nicely on the calendar online but not on the phone.


#1 pulgoki, Feb 23, 2011
Touch Calendar displays holidays nicely in their Monthly view. I don't use my stock calendar at all. 3rd party calendars suit my tastes better.
#2 BookLover, Feb 23, 2011
Touch Calendar looks like its some type of a better front end for google calendar? Does it sync with google calendar online?
#3 pulgoki, Feb 23, 2011
Yes it does.
#4 BookLover, Feb 23, 2011
Thanks! Im going to try it out. I tried Jorte and though it was a great application, it was a little more than I really needed.
#5 pulgoki, Feb 23, 2011
You're welcome. I tried Jorte also, but didn't really like it. I don't need its agenda widgets.

Instead I use a combination of 3 calendars to get the functionality I need. Not as much a PITA as you would think as they all sync to my Google Calendar.

1. Blik Calendar - this is my primary widget. Its icon-based agenda is perfect for me. Big Tooth image = Dentist appt.

2. Gemini Calendar - I like it's "fast-add" feature

3. Touch Calendar - for the occasional times when I need to view my monthly calendar and be able to read details off the full calendar instead of having to click into the details.
#6 BookLover, Feb 23, 2011
I have the US Holidays synced and visible, too, but I don't even get the holidays displayed in the week or 1day views; they just don't show up at all. The same for Calendar Pad and CalWidget. Any ideas?
#7 wmm, Mar 12, 2011
You need to login to your gmail account on your pc and then go into you calendar from there. Once in youre calendar you can choose to have three holidays synced to your calendar. This will then sync to your phones calendar.
#8 isaemm, Mar 12, 2011
Thanks for the reply, but I'm afraid I didn't quite follow that. I have "US Holidays" listed in the "Other calendars" section, and the dates from that calendar do appear on my calendar listing from my PC. I set that up a number of months ago, but the holidays are still not appearing on my phone view of the calendar. What else do I need to do?
#9 wmm, Mar 12, 2011
Ok, I wasnt near my pc earlier so I was trying to wing it and go off of memory. But here is how to set it up.
1. log into your gmail account on your pc.
2. choose your calendar from the upper left hand corner.
3. now on the left side of the calendar under the "other calendars" tab click add.
4. browse through the calendar you want to add and click subscribe.

Thats it. You might have to resync your phone and gmail account but after that you should have all the calendar events you subscribed to on your phone.:cool:
#10 isaemm, Mar 12, 2011
Okay, thanks; the problem is something else, then, because I've had the "US Holidays" in my "Other calendars" list for months, and the holidays are not appearing on my phone, although they do show up on the PC.
#11 wmm, Mar 12, 2011
OK, on your phone. . .

Start the calendar. Go to settings. First item is Calendars. Touch that. Are US Holidays and your google address both checked? They should be.
#12 Darkseas, Mar 12, 2011
I have a Nexus One running Gingerbread, so my menus are a little bit different. However, under "Calendars," I have both my personal calendar and "US Holidays" set as "synced, visible". I see my events in the calendar, but nothing from "US Holidays".
#13 wmm, Mar 12, 2011
I have a Moto Droid and got the update this morning....determined to add holidays to stock calendar...Google is set and synced. When I open the calendar settings and choold calendars, us holidays is there visable and synced.....but still not showing up.

On another post, it was said that a US holiday calendar needs to be installed, I've installed 2 others and removed them and now have touch installed, St Patrick's Day is a no show, nor is Easter. What up w/ this...or is it me? thanks, Cyn
#14 cyn, Mar 17, 2011