Samsung Galaxy Tab 2 Forum

Support super slow wifi

I have just got my first ever wifi device and it's crazy slow, tell me something is wrong and this is not normal. It's managed to load one web page in about 20 mins of trying, the other attempts just timed out.

The WIFI section says it's connected and gives me these readings.

status:strong

signal strength:strong

link speed:65Mbps

security:WPA/WPA2 PSK

My router also recognizes the connection.:mad:

Galaxy Tab 2 P3110.

p.s. If it helps, my Galaxy Ace phone is having the same problem.
 

Related:

#1 briansspam, Nov 15, 2013
I dont know what the problem could be but it should not be slow at all. Mine loads a page in 2 or 3 seconds.
 
#2 brosko, Nov 15, 2013
What type of system is providing your Internet? Who is the provider. Systems include DSL, Cable and FTH (fiber to the home). The provider is likely the source on the problem. Just my opinion.
 
#3 txrose72, Nov 15, 2013

But why would it say his link speed is 65 mbps
 
#4 brosko, Nov 15, 2013
It's a Virgin Media 30Mbps cable connection. Speed test gives me 33 Mbps.

 
#5 briansspam, Nov 15, 2013
Problem solved, I was using a cable from the hub to my pc, so I unplugged that and restarted the modem, now my tab and phone are super fast, even after I replugged my cable back in the pc, thanks to those that tried to help.
 
#6 briansspam, Nov 15, 2013
Hi, I have the same problem. My cable internet is currently on the lowest speed they have, but even when it wasn't, it was too slow on WiFi with my router.

So, you

Unplugged the cable from computer to router

Restarted the router

Then replugged that same cable you had unplugged earlier.?

Are those all the steps? Thanks. :thumbup::)
 
#7 mrsmumbles, Nov 16, 2013
Yes, I thought that the cable may have been giving all the power to the pc rather than to the WIFI, probably more technical than that but it worked. I did try the tablet and phone wifi connection before I plugged the ethernet cable back in, but even after I it still stayed just as fast.

 
#8 briansspam, Nov 16, 2013
Thanks! I should work up the courage to try it. My computer isn't working so I'm not sure how I'd redo the settings if it didn't connect back up. I guess I could do it from a phone but it wouldn't be as easy. :thumbup::)
 
#9 mrsmumbles, Nov 16, 2013
I HAVE FOUND A SOLUTION. Well, at least for me it worked. I was having the same issue where all the devices surfed the Internet and apps perfect minus my android phones.

-log into your modem/router and change the dhcp ip address scheme from 10.0.0.1 to 192.168.1.1
-reboot modem/router
-send me a cheer if it works for you

***don't waste money buying another router nor waste time "rooting" your phone like all these dumbies are Suggesting.
***android seriously needs to fix that in the next update
 
#10 pabloj47, May 2, 2015
You are a life saver. I was struggling with slow Wifi since I got my s6. This is the only thing that worked for me. Thanks again.
 
#11 Pittshld3113, May 11, 2015
10.0.0.1 is class A networking. The first octet (8 bits) is given over to the network address, the remaining 24 bits to station addressing.

192.168.x.x is a class C network and is the opposite. The first 24 bits are given over to the network address, the last 8 for station addresses.

The proper class A prefix is 8 bits, 24 for class C.

Android assumes the more common class C network will be in use - if not, either change the router and make it so, or go to manual, static ip setup and change the prefix size from 24 to 8.

In any case this is more likely manufacturer dependent than an Android defect - I go from class A to class C networks and back again with no trouble on another brand Android.

1431406441762.jpg

I am impressed that you found the solution.

Not impressed that you called people giving root advice dummies. It's probably somewhat likely that many custom roms know how to configure properly when detecting a class A network.

Class implies prefix size, not quality.

Going to class C addresses is fine.
 
#12 EarlyMon, May 12, 2015
I spoke too soon. It was only a temporary fix. This whole wifi thing is extremely frustrating. I've tried every solution out there with really no luck. How can the system be so screwed up to not do a basic function like connect to wifi?
 
#13 Pittshld3113, May 14, 2015
You said you have an S6, right? Seems to be a common problem if I search on Google.

You might have tried these already:
http://www.gottabemobile.com/2015/04/23/samsung-galaxy-s6-problems-fixes/
 
#14 AnciusD, May 14, 2015
Try these steps, in order, until it (hopefully) works. They are some of the most common fixes for stubborn WiFi connections and have been successful in many cases. Do 1-5 together, 6-10 one at a time:

1. Go to: Settings > WiFi > Long-press on your network > Forget network.

2. Turn off the phone.

3. Unplug the power to the router for at least 30 seconds.

4. Plug in the router and give it plenty of time to fully reboot, at least 3-4 minutes.

5. Turn on the phone and try to connect.

6. Open a browser and get into Setup in the router.

7. Set security encryption to WPA2/AES. Do not use TKIP or AES/TKIP.

8. Try setting static IP addresses.

9. Update your router firmware.

10. Try using Google's DNS servers. 8.8.8.8 for the primary, 8.8.4.4 for the secondary.

If none of these help and the problem is only with this network, it's possible you have a signal interference problem. You need to determine the best setup for your situation and configure the router and phone accordingly. To find the best setup try using WiFi Overview 360. The free version is probably all you need but the Pro version is cheap.

https://play.google.com/store/apps/details?id=de.android.wifioverviewpro

On dual band routers give the 5GHz and 2.4 GHz bands different SSID names. When setting up the 5GHz band usually it's best to set the router to use a channel well over 100. Over 150 if there's a clear channel. For both bands of course use channels with the least interference and best signal as indicated by WiFi Overview 360.
 
#15 Crashdamage, May 14, 2015 Last edited: May 14, 2015
But the network prefix size does matter and needs to match - 8 for class A, 24 for C. ;)

See also -

http://phandroid.com/2015/05/13/comcast-wireless-gateway-lollipop-bug/
 
#16 EarlyMon, May 14, 2015
Oops! You're right! I had a brain fart -dunno what I was thinking...I'll do a little edit.
 
#17 Crashdamage, May 14, 2015