Samsung Galaxy S4 Forum

Root [T-Mobile] [HOW TO] Install TWRP Recovery, Root & Install a ROM

This is for the T-Mobile Galaxy S4 SGH-M919 Only!

This will, technically, void your warranty.

TWRP is a great touch recovery. Read more about it.

This is an easy process. Please read it carefully.

If you need drivers to connect your phone to your computer, you can download the drivers here. This is official Samsung_USB_Driver_for_Mobile_Phones_v1.5.14.0

1 - Download the TWRP tar file. Do not extract the files.

2 - Download Odin 3.07 and extract the files

3 - Download CF-Auto-Root and extract the .tar file

4 - Double click the Odin3 v3.07 file to start Odin. Auto Reboot should be selected by default. If not, select it and only select Auto Reboot. Make sure re-partition is not selected.


4 - Power off your phone. Then hold the power button and volume down until you see the warning screen.


5 - Press volume up to get to download mode


6 - Now connect your phone to the computer. You will see the com port light up when Odin recognizes your phone. Press the PDA button, browse to the CF-Auto-Root .tar file and select it.


7 - Press Start. Odin will install CF-Auto-Root. When it is finished you will see a green PASS in the top left and your phone will reboot. CF-Auto-Root will then root you.


To install your TWRP custom recovery, just repeat the same process but use the TWRP tar. To get to your new recovery, Power off, hold the power button and the up volume. Let go of the buttons when you see the small blue text in the upper left of your screen. TWRP recovery will look like this.


If it still goes to the stock recovery instead of TWRP. Try installing TWRP again with Odin but this time uncheck auto-reboot. When you see the Green Pass and you're sure Odin is done, unplug the USB cable and pull out your battery. Put the battery back in and reboot. You should be able to get to TWRP now.

After you are rooted, go back to TWRP and select backup. Make a nandroid backup of your rooted stock rom. If you ever have a problem after installing a custom rom, or just don't like it, you can restore this backup, or a more recent one you may have made. Do not forget to do this! A nandroid backup may save your life someday and it makes baby kittens smile.

Be warned! Backups on this phone can be very large. Mine was 3.2 gig. Make sure you select your external sd card for the backup location.


#1 Atma, May 4, 2013
Now that you're rooted and made a backup .. you did make a backup right? .. you can try installing some roms. First, check the All Things Root Guide to see some of the roms available. Download one you like and put it on your sd card. I'm currently using DarthStalker and like it a lot.

Now boot into TWRP recovery. If you haven't made a backup before, do it now. It could save your life! Now, tap the wipe button. (Please excuse my crappy pics. :D)


Now you will see the wipe menu. Select Advanced Wipe.


Now select the first 4 options. Dalvik, System, Data & Cache. Then swipe to carry out wiping your choices.


Now back at the main wipe screen, swipe to factory reset. You have essentially already done this but I just like the extra step and it only takes a few seconds.


Now go back to the main menu and tap install. Navigate to where you put the rom zip file and select it. Also notice at the top of the menu you can select internal or external storage. After selecting the file, on the next screen 'swipe to confirm flash'.


After the rom is installed, you will see an option to wipe cache/dalvik. Select that and reboot your phone when it is finished.

The first boot may take several minutes. When it boots and gets to the first screen, just let it sit for 5-10 minutes. Then reboot and enjoy your new rom.
#2 Atma, May 4, 2013
Which root method did you use? Did it mess with your data speed?
#3 reilus, May 4, 2013
I rooted with TWRP using the method explained in the OP. No, rooting doesn't affect my data speeds.
#4 Atma, May 4, 2013
Thank you! I read the whole post now; I apologize for not reading at first as I thought it was only a recovery. Thank you for being patient and getting back to me.

I have one more question for you: how do I erase the flash count so that I don't void my warranty if I want to send the phone back?
#5 reilus, May 4, 2013

No problem. Glad to help if I can.

That's a good question I don't have an answer to. I'm sure some dev will come up with a fix for that soon. I have seen one for the I9505 but not for our Tmo phone yet.
#6 Atma, May 4, 2013
Didnt work for me, when i see the blue text all it says is reboot system now, apply update from adb, wipe data/factory reset. and apply update from cash. when i reboot system it says nothing about not having root and never asks to install superuser
#7 Gfv355, May 11, 2013

Hi Gfv. Sorry, I should have updated this. It doesn't root the same after the update came out. After you installed TWRP, when you go to recovery do you see the TWRP recovery screen?

It will look something like this.


You need to download this kernel. Put it on your sd card. Select Install in TWRP and select that file and install it. You also need to download one of the superuser files in that thread under 'Instructions' and install it the same way.

If you are still going to the stock recovery instead of TWRP. Try installing again with Odin but this time uncheck auto-reboot. When you see the Green Pass and you're sure Odin is done, unplug the USB cable and pull out your battery. Put the battery back in and reboot. You should be able to get to TWRP now.
#8 Atma, May 11, 2013
Thanks very much, the problem was the twrp recovery was'nt sticking... i got it to install successfully with the battery pull method. Then flashed the root zip from recovery and everythings great!! thanks so much
#9 Gfv355, May 12, 2013
Your links to the MDB/MDL root methods appear to be swapped. :)
#10 Kelmar, May 19, 2013
Arg :eek:

Thanks, fixed. :)
#11 Atma, May 19, 2013
I got it figured out ;)

Thanks for the How-To!
#12 Kelmar, May 19, 2013
Updated 2nd post with instructions for installing a rom for those who never have but might like to try. :)
#13 Atma, May 28, 2013
I just got my S4 yesterday and rooted using this guide then I found a rom id like to try,But when i attatch the usb cable it only charges . What am I doing wrong ?
#14 Huggie, Jun 23, 2013
Hi Huggie :ciao: Congrats on your new phone. :)

Try going to settings > more > about device, scroll down to Build number, tap it 7 times. The developer options section will appear. Select that and check the box for USB debugging. Does that help?
#15 Atma, Jun 23, 2013
Just did as you said and the developer option appeared and that option was already checked.But still a no go on my end.
#16 Huggie, Jun 23, 2013
You did install drivers didn't you? You might try device manager, find the phone, right click and select update driver. First, try unchecking usb debugging and try connecting, then check usb debugging again and try connecting. Also try rebooting your phone and computer.

You can also download and install Kies. That might help.
#17 Atma, Jun 23, 2013
Well unchecking usb debugging did the trick ,So a thank you is in order.
#18 Huggie, Jun 23, 2013

You're welcome. :) Glad something worked.

Check the all things root guide sticky. I think I have it up to date with the latest roms. Just remember to make a backup in recovery before doing anything else,
#19 Atma, Jun 23, 2013
So after you help me along the way with getting the S4 and the pc to connect and play nice,When i try and move my rom to the sd card i get this message "Cannot Copy item "The device is either stopped or has been disconnected.
#20 Huggie, Jun 23, 2013
Are you trying to copy to internal storage or external SD card? You can try checking USB debugging again or pull down your notification window and where it says connected as an mtp device, tap that and select connect as a camera, ptp device I think.
#21 Atma, Jun 23, 2013
I was trying external ,Imma give your suggestion a shot
#22 Huggie, Jun 23, 2013
giving me the same message when switched to camera
#23 Huggie, Jun 23, 2013
If my sd card is low on memory might that be the reason
#24 Huggie, Jun 23, 2013
Is possible it would if you don't have enough space to copy the file. I had that message before on my galaxy S2 but it was a bug with CM 10.1 custom ROM. I've never had a problem connecting or copying files with my S4. Have you tried a different USB port or a different cable?
#25 Atma, Jun 23, 2013