Samsung Galaxy S3 Forum

Support text message notification sound not working

all my other notification and media sounds are working. its just for text message that isn't. and its the only important sound that i actually need to work. my notification bar is on. i even went into setting on messaging and reset it to default. and it didn't work either.

it would be really great if somebody is able to help me with this problem. i dont want to reset/reboot my phone if possible. thanks

 

Related:

#1 nam_cu, Sep 4, 2012
okay so you checked all your sound setting.
Setting> Sound> Silent mode: off, Volume> Notifications: Turned up

if thats all correct try changing the notification sound under Setting> Sound> Rigntone and Notifactions.

also are u using a third party sms app? go sms, handcent, chopsms..
if so try looking into those sound settings. if the settings are correct then try uninstall and re installing the app.

if all that dont work you might have to restore your phone to factory.
 
#2 streetkilln, Sep 5, 2012
actually this just happend to my gf's S3 just now, not running any 3rd party text apps, but downloaded some ringtones from Zedge. The notification tone seems so play the first second or so and cuts off, any ideas?
 
#3 blacksmaru, Sep 5, 2012
it could be a zedge problem.. try removing zedge and rebooting your device.
 
#4 streetkilln, Sep 5, 2012
actually just figured it out, go to message>menu>settings> storage settings> make sure 'delete old messages' box is UNCHECKED .... some kind of glitch
 
#5 blacksmaru, Sep 5, 2012
oh well at least u fix it. my message box lags or freezes when i exceed 5000+ messages stored. lol
 
#6 streetkilln, Sep 5, 2012
Hello, google it, and read about, tried everyting plausible that I found. In my case the problem persistit even after unchecking "delete old messages":mad:.

On an Android 2.3.6, anyone else has the same problem or knows another solution to this apparent "bug"?

Notice that the sound of call works and sound in the selection of notifications doesn't play when selection changes.
 
#7 jpmartins, May 1, 2013
I finally got mine working again. Had to go to System Settings>Sound>Volume and change the slider for notifications. No idea how it got set low (off), or if it will happen again, but it seems to be a master sound controller that would override anything in an app.
 
#8 davidalynn, May 3, 2013
Mine have stopped too, ever since the update yesterday morning. i've tried restarting I've gone through resetting the settings nothinf works. Even notifacations for facebook dont work...I dont want to reboot at all :(

Anyone else have this issue since updating? Its bugging me now!!!!
 
#9 Shezzie, May 10, 2013
Did you manage to solve this issue?
 
#10 Shezzie, May 10, 2013
If you read the above post you would know they got it resolved. Also they tell what they had to do to get it to work.
 
#11 GTWalling, May 11, 2013
I have tried everything in this post, even the factory reset, and still do not have text notifications, LG730. I am using handsent and have had no issues with those notifications and all settings are identical for both text systems.
 
#12 kjc1234, May 29, 2013
Sound is on, all settings are where they should be... neither sound nor vibration for texts is working. I've tried unchecking delete old texts as suggested. When changing ringtones under "calls" I am able to hear the sound options, but not so when browsing the text sounds. I've had this phone a week and this just happened.
 
#13 ikoric, Jul 26, 2013
Any luck? I tried turning off delete old texts, but that didn't do squat
 
#14 ikoric, Jul 26, 2013
I have an s3 and I was using the "Blocking Mode" feature on my phone which blocks phone calls, notifications, etc.,
During specified times of the day/night or "Always". Somehow the "Always" option got checked. Once I unselected that option, my notifications started working again.
 
#15 Dh4089, Aug 19, 2013
I have the same problem with my galaxy note I called AT&T and they had me uninstall AT&T messenger and power down my phone and turn it back on .
all of this was the result of trying to update my phone. works just fine now.
hope it works for you
 
#16 buggish429, Sep 1, 2013
uninstall ATT messenger or whatever device uses as the default messenger for your type of phone mine it was AT&T messenger I uninstalled it then restarted my phone and my phone works fine now
 
#17 buggish429, Sep 1, 2013
Spent the better part of the day on this. Glad I found this site! Worked for me! Thanks!!!!
 
#18 EKinMN, Sep 3, 2013
I did this but it didn't work until I disabled AT&T Messaging through the App manager as well.
Settings/application manager/All Apps tab/AT&T Messaging/Disable
 
#19 phisco65, Nov 11, 2013
I figured out how to fix this!!

Here are the steps,

1. Goto system settings > application manager> all .

Then scroll down till you get to "messages" . Click it.

I bet you you have "show notifications" unchecked. Check that box and voila, notifications back
 
#20 Dsnotgood, Nov 20, 2013
Thank you, thank you, thank you!!!! I've had this phone for 3 days and had so many issues with it, this being the most frustrating. I'm so grateful that you solved my problem. Though I am also feeling a little sheepish for having caused it myself! :eek:
 
#21 ErikaAoi, Nov 20, 2013
thanks so much! this worked. I can hear my notification sound now!!!
 
#22 annrayannray1, Jan 29, 2014
Have read your suggestion, together with all other suggestions found, but until now, no one of all the tried solution, including yours, gave me my sound back on receiving SMS.
Any one else who have a solution will be appreciated.
 
#23 Bendt, Oct 25, 2014
That did the trick! Thank you!
 
#24 vekat1, Feb 25, 2015
David - You are AWESOME! I've been dealing with this issue for weeks now and I worked with HTC chat support and they couldn't even figure it out. They wanted me to do a hard restore! I am so glad I read this forum before doing that! Thank you SOOO much!!!!!!
 
#25 Jaime Foll, Mar 3, 2015