Samsung Galaxy Note 8 Forum

Support Thumb Drive not responding when plugged in

So last week I tried to use my thumb drive on my note 8. It wouldnt do anything when plugged in to the usb a- usb c connector. I tried 2 different thumb drives then read it had to be formatted to exfat. Both of these used to work on my galaxy s5. Anyway, I formatted to exfat then when plugged in they would pop up and I could do all the normal stuff with my drive. This week I plug it in and same thing it never pops up, never recognizes its plugged up I restarted the phone and reformatted the thumb drive. Same thing nothing happens, any advice?


#1 realitycheck, Oct 12, 2017
Have you edited/removed/added files on the thumb drive with another device, lik ea computer? If so the database on the thumb drive may be getting corrupted.

Are you using an OTG dongle? Yes i know the phone came with one of those items, but im specifically asking about a 3rd party one?
#2 marctronixx, Oct 12, 2017
I changed files on one but not the other and neither would open.
I have tried both the samsung one that came with it and a third party micro usb with the samsung converter dongle. Neither worked
#3 realitycheck, Oct 12, 2017
check your notification tray...its going have it on charge by default. you have to change it to file transfer
#4 JimKnuckles, Oct 12, 2017
exFAT could be the problem. Maybe the A5 did support it but the Note8 does not. exFAT is a proprietary patented Microsoft format, and basically manufacturers like Samsung must pay Microsoft a bunch of $$$ if they wish to use it in a device. And by the sounds of it Samsung haven't licensed exFAT for the Note8. Try reformatting the USB thumb-drive as FAT32.

I've got a couple of Android device here that don't work with micro-SDs and USB thumb-drives formatted as exFAT.
Storage media formatted as Windows NTFS may not work with Android either.
#5 mikedt, Oct 12, 2017
Same thing happened to me. I checked everything and couldn't figure it out. So I just ended up getting a usb-c one. It has to be something with the adapter IMO.
#6 jraffensberger, Oct 12, 2017