Samsung Galaxy Note 3 Forum

General Tmobile Note 3 MMS over Wifi

Switched from the note 2, to the 3 Friday. Living it so far, but just realized it won't send mms over Wifi. I have to disable wifi in order to send mms... wtf?


What songs do I need to change?

Also, the camera takes blurry pics, and is slow in the auto focus setting. What do I need to change in order to fix this?
 

Related:

#1 Big Boi, Jan 1, 2014
Mine sends MMS when I'm on the WiFi. You need to have a good T-Mobile signal for any text to send as texts don't send over WiFi at all. So if you're in the middle of an all brick building and have no T-Mobile signal but full bars on your WiFi so you can still call out, then yes you won't be able to text.

If you want to text over WiFi then I suggest you get Google Hangouts and urge your friends to do the same.
 
#2 Bodycount, Jan 1, 2014
No, I guess I didn't explain it correctly.

The problem I'm having is, whenever I'm connected to wifi, it will not send mms. It will try to send it, but after 15 sec, it says unable to send message.

If I turn wifi off, it sends the mms, no problem...
 
#3 Big Boi, Jan 2, 2014
That is odd, very odd. Mine sends texts, MMS, makes calls no problem with Wi-Fi on. If I'm on Wi-Fi when browsing and I walk out of range of the signal it switches to network (LTE, HSPDA, whatever) easily. If a page happens to be loading/rendering or I'm streaming it very briefly (half second max) stops and then restarts. If going from Network to Wi-Fi it waits until I've either finished streaming or the page I want to view renders, then switches to Wi-Fi.

There are more than a few examples of weird connectivity problems and they all appear to be non international variants, particularly US models. Correlation perhaps?
 
#4 dynomot, Jan 2, 2014
Called Tmo today, and they said it maybe do to Uverse (my cable/internet provider) not being compatible with the latest Android 4.3. That being said, I'm having one of their techs stop by, to figure out what's going on. The phone tech also noticed bad communication on the line when he did a test signal to my router.

I'll keep u guys posted
 
#5 Big Boi, Jan 2, 2014
Try going into the Wi-Fi calling menu and changing it to celular prefered. I had issues with calls and texts over Wi-Fi and that fixed it for me. The pictures I'm not sure of. I'm pretty happy with the camera. It takes pretty sweet pictures for me
 
#6 phillyundead, Jan 2, 2014
I did, but no difference
 
#7 Big Boi, Jan 3, 2014
Welp.... AT&T upgraded my entire home to their latest hardware (original setup was from the beginning of Uverse).

Still no change. The tech had an S4, and said he doesn't have any problems like this. And he has Uverse As well.

Idk
 
#8 Big Boi, Jan 4, 2014
As I said, odd. It might be worth a shot requesting the settings for mobile internet and MMS from your carrier (network). They'll send you two SMS, open them and save them when requested to, at least then you'll have their correct settings for sure.
 
#9 dynomot, Jan 5, 2014
When I had my Galaxy S2 a while back, I couldn't understand why my phone wouldn't receive MMS until I realised that mobile data had to be switched on, even though I was on Wi Fi it would have never received.
 
#10 evohicks, Jan 5, 2014