Samsung Galaxy S2 Forum

Support Trying to flash firmware with odin/cannot connect?!?!

i have downloaded the firmware for my galaxy s2 but i am having problems.
my phone will allow me to acces the odin menu on it but when i run odin my phone does not seem to connect to it what can i do ?


this is the original problem with phone

hi this was a very informative forum and taught me alot but i am stuck my galaxy s2 will not load up past the boot logo i can still get to the odin download page and the page to factory reset my phone i have done a factory reset and thought if i could connect my phone to odin i could root it as i have looked alot online and it says this will fix my phone but when i connect my phone to the pc it says that it is not a recognised device i think this is due to it not being able to load past the boot logo as it connected fine before. what can i do ????
 

Related:

#1 slevlin87, Oct 27, 2013
Welcome slevlin87!

I moved your post into your own thread here:)

So, just let me understand this correctly..you have the firmware downloaded and ready to install via ODIN, but your device is not recognized by ODIN?
Do you have the drivers installed?
 
#2 Mikestony, Oct 27, 2013
drivers? where would i get these from ??
 
#3 slevlin87, Oct 27, 2013
Oh sorry... Didn't see this till now... Stand by.. I'll be to a computer shortly

Edit: is your device the GT-I9100?
If so, you can install Kies to get the drivers, then uninstall, or disable Kies because Kies and ODIN don't work well with each other.
Let me know if that is your model number. :)
 
#4 Mikestony, Oct 27, 2013
i have installed kies but have the same problem my phone does not appear when i plug it in to kies.
and when i plug it into the computer it says unrecognised device
 
#5 slevlin87, Oct 28, 2013
What model is your device? The GT-I9100?
Perhaps try to uninstall Kies and then reinstall.
Try a different cord or usb port also:)
 
#6 Mikestony, Oct 28, 2013
yeah tried reinstalling kies no joy yeah my device is the GTi9100 could it be that the phone because it wont load past the boot up logo it does not recognise it ?
 
#7 slevlin87, Oct 28, 2013
I have never used Kies but I would assume it (Kies), nor the computer, will recognize it if it does not boot up.
Try this, disable, or uninstall Kies but leave the drivers.
Open ODIN, put the device in download mode and plug the phone into the computer.
If ODIN does not see the device, try a different cord or usb port.
Reboot the computer if no luck there.

Once we get ODIN to see your device, you are ready to flash your firmware....which, by the way, do you have the correct version of firmware?

See this guide that Ironass wrote for more info on finding your phones version and firmware for it: (perhaps you have seen it already:) )
http://androidforums.com/samsung-galaxy-s2-international/680070-jelly-bean-update-dummies-guide.html
 
#8 Mikestony, Oct 28, 2013
Slevlin, we might have a little misunderstanding here. If you phone is stuck in a bootloop then it won't be recognized as a device by your PC even if you have drivers installed. If you have followed Mike's advice and installed Kies (latest version complete) it would have installed hardware drivers for your phone. Uninstalling Kies won't remove them.

Now, to see if they were installed using a phone stuck in a bootloop, the only way will be in download mode (odin mode). Unplug the phone from the USB cable if it's plugged in. Shut the phone off. Take out the battery. Wait 30 seconds. Replace the battery. Boot into download mode by holding vol. down, home and pressing the power button until the screen flashes. You should see the download warning.

On your PC open Odin. Now you can plug the phone in. If you have the drivers installed properly, the com port assigned to your device should light up. If it does, you can go ahead and flash it making very sure it's the right firmware.
 
#9 lunatic59, Oct 28, 2013
how do i know what firmware to download i thought i was pretty good at phones untill now i cant check what firmware i have currentley on there as i cant get onto the phone only the odin menu and the reset menu my phone now connects to odin my phone is the GTi9100 its on 02 (british provider) but as its a samsung and is over 2 years old it will take any sim card as ive had a bulgarian sim and a 3 uk sim inside it and they worked fine
 
#10 slevlin87, Oct 28, 2013
Are you looking for stock or you want something custom?

Right now I''m running SuperNexus 4.3 on my SGS2 (i777) but the i9100 is compatible, too.
 
#11 lunatic59, Oct 28, 2013
tbh i dont care aslong as i can get it to work so i am probably best off going with stock
 
#12 slevlin87, Oct 28, 2013
Go to Firmwares | SamMobile | Page 2 and put in your model and carrier and it will give you the download. :)
 
#13 lunatic59, Oct 28, 2013
ok so when it downloads then what do i do after connecting my phone to odin ?
 
#14 slevlin87, Oct 28, 2013
Is it downloading a .tar file or a .zip file?

For odin you want the .tar file.

With the phone connected and in download mode and Odin running showing the phone is connected, you want to make sure re-partition is NOT checked. Then check the box next to PDA and click the PDA button to select the .tar file you just downloaded. Auto reboot, reset time and pda should be the only boxes checked, then simply press the start button and it should begin the flashing process.

Watch this to see it in action.

 
#15 lunatic59, Oct 28, 2013
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> CSC_H3G_I9100H3GLS5_1211955_REV00_user_low_ship.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/006> Odin v.3 engine (ID:6)..
<ID:0/006> File analysis..
<ID:0/006> SetupConnection..
<ID:0/006> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1


that is what i get when i try it.......the file that downloaded was a zip file and it contained these files.

CODE_I9100XWLSW_1211311_REV00_user_low_ship.tar.md5

MODEM_I9100NELS1_REV_02_CL1221298.tar.md5

CSC_H3G_I9100H3GLS5_1211955_REV00_user_low_ship.tar.md5

SS_DL.dll

i put the csc on into the pda part of odin and got that error msg which file do i use as all of the firmware to download from the website u showed were all zip files
 
#16 slevlin87, Oct 28, 2013
You put the one beginning with "CODE" in the PDA section. Put the file beginning with "MODEM" in the Phone Section and the file beginning with CSC in the CSC section like this:

[​IMG]

Give that whirl.
 
#17 lunatic59, Oct 28, 2013
tried that got this......

<ID:0/005> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> CODE_I9100XWLSW_1211311_REV00_user_low_ship.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> MODEM_I9100NELS1_REV_02_CL1221298.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> CSC_H3G_I9100H3GLS5_1211955_REV00_user_low_ship.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/005> Odin v.3 engine (ID:5)..
<ID:0/005> File analysis..
<ID:0/005> SetupConnection..
<ID:0/005> Can't open the serial(COM) port.
<OSM> All threads completed. (succeed 0 / failed 1)

where would i get the custom firmware from ? i could try that instead
 
#18 slevlin87, Oct 28, 2013
Question for both of ya'll:)
Would running ODIN as "Administrator" make a difference?
Would an older version of ODIN work?
 
#19 Mikestony, Oct 28, 2013
It couldn't hurt to try and run Odin as admin. That last error was because it count find the phone. Odin sometimes gets fussy with a failed flash. Restart your PC and power down the phone and then try again.
 
#20 lunatic59, Oct 28, 2013
The older one may be a shot to try .
 
#21 BRAINZ2013, Oct 28, 2013
it doesnt work at all i have even given it to a friend who is a wizz with things like this and he said he cant do it at all and has had the phone for 24 hours so its gone bye bye bin

thankyou all for all of your help :D
 
#22 slevlin87, Oct 30, 2013
Crap, I'm sorry it didn't work out for you:(
What are your plans for a device?
 
#23 Mikestony, Oct 30, 2013

I joined the forum just to thank you. Thank you so much!!! I was getting this "Can't open the serial(COM) port" error again and again trying to flash my device, it used to stop at that error and show "failed" all the time I started it. I followed your steps and IT'S AT A BETTER PLACE THAN BEFORE. Atleast it doesn't show fail but 'aboot' and I'm happy to see the log has more entries visible than before.

Update: It was stuck at aboot for so long and with no progress lmao I figured it wouldn't work and struggled a bit more but then I thought about using older version of odin like suggested all over internet, where 'PDA' appears instead of 'AP'. And boom it's working!! Atleast now I see a progressing green bar.

Thank you a lot!! cx
 
#24 fluffysam, May 16, 2018
https://androidforums.com/threads/have-anyone-try-either-of-these-sites.1268576/
 
#25 KBU2, May 16, 2018