Twitter (Download) Forum

Support Twitter app no longer works after update

Please help!
After I done the new Android update nougat 7.1.1 my twitter app no longer works. The error message is always "hmm something went wrong, cannot retrieve tweets at this time please try again later" this has been going on for about 3 weeks. I've deleted the app and reinstalled again, cleared cache, force stopped. I've checked all the settings to ensure it can connect to WiFi or 4G. I'm completely stuck! I work with mobile phones everyday and this really has me confused. HELP!


#1 Wkdside1ac, Jul 15, 2017
Contact Twitter and or the developer on Google play. Sounds like the update is screwed
#2 Dannydet, Jul 15, 2017
I've had no problems with Twitter. Had a few times that I encountered the message that cannot retrieve tweets at this time please try again later but that was before update as well as after.
#3 GlennT, Aug 5, 2017
I'm having exactly the same problem. I've tried all the recommended fixes, including those outlined by @Wkdside1ac above.
I have tried emailing the developer email address on Google Play (no response) and @ mentioning Twitter Support (no response).
In the meantime I'm using Plume and Hootsuite instead with no problems.
#4 WaxieBanjo, Aug 14, 2017
I'm using two phones on nougat 7.1.1 and neither of them have issues running twitter.. All apps are current.
#5 GlennT, Aug 14, 2017
Lucky you. :)
In addition to the same error message as outlined by @Wkdside1ac I also get the log in/sign up message if I momentarily switch to another app then switch back to Twitter official app. I just tried all the steps again and getting the same error message as the screenshot posted at the top of this thread.
I can get by with Plume/Hootsuite but I liked the official Twitter app.
At this point my problem is not just with the app but with Twitter support. My original email was sent on July 8th and I've tried Tweeting @ TwitterSupport several times since.
#6 WaxieBanjo, Aug 14, 2017
Try uninstalling and install a previous version from apkmirror....
#7 Dannydet, Aug 14, 2017
Thanks for the tip.:thinking:
I'm too ocd to try a workaround ;)

*can't believe I typed "ocd" in lowercase
#8 WaxieBanjo, Aug 14, 2017
I'm having this problem too, with a OnePlus 2 on Android 7.1.2 (LineageOS). I also tried the two previous versions from APKMirror, but getting the same "Cannot retrieve tweets at this time." error.
#9 Igettäjä, Aug 20, 2017
Same problem here after upgrading to 7.1.2 on a Sony Xperia X compact. Tried everything as mentioned above to no resolve. Only options remaining is reinstalling the phone which is slightly extreme. Any fixes welcome :)
#10 madlive, Aug 24, 2017
I got rid of the problem by flashing the latest CarbonROM. The Twitter app had worked for me on LineageOS previously, but didn't work at all on a newer build. I'm guessing the cause is in a specific release of AOSP, which both of these ROMs are based on.
#11 Igettäjä, Sep 1, 2017
Exactly the same problem here with Xperia Z5 Premium. Hasn't been working for weeks now. Tried everything short of phone factory reset.. (same as you)
In my experience, the only way to get support for Google Play apps is to give them a juicy 1 star review. I did and so did about a dozen of other Xperia users in past few days.. I suggest you join us ;-)
Like WaxieBanjo I won't go for a workaround, won't flash or factory reset my phone because of a lousy app..
#12 Někdo, Sep 1, 2017
Hi, I have an Xperia XZ and I have the same problem
looks like the issues are mostly on the Xperia line except for the oneplus guy
I sorta got around it by installing twitter lite, which works fine, but it's a little inconvenient as i'm new to twitter and still completing my account
#13 tetsumon, Sep 6, 2017
I have an Xperia XZ it doesn't work either. Have tried the same as above but not going to format my phone for it to work.
#14 pSychedelicRobot, Sep 29, 2017
Twitter still haven't fixed their app?
#15 mikedt, Sep 29, 2017
No unless they did it 15 minutes ago
#16 pSychedelicRobot, Sep 29, 2017
They may not fix it for just one (brand/type) phone, which seems to be the case here. Not that it matters but I've recently run into a similar issue (for a friend) with the Verizon messenger app, it doesn't work for the Moto G4 and they don't care/aren't going to fix it.

Anyway, @pSychedelicRobot, have you tried a different Twitter client/app? There are a lot out there, I use Tweetings and think it's much, much better than the official Twitter app.
#17 Clementine_3, Sep 29, 2017

I have tried a few but haven't found one 1 I like. I will try Tweetings. Thanks
#18 pSychedelicRobot, Oct 1, 2017
There are a lot of things you can do in settings, be sure to 'play' with them all. So many ways to set it up :)
#19 Clementine_3, Oct 1, 2017
I have just installed the latest update for twitter 03 October 2017 it's still broken on my HTC U11 Android 7.1.1. Seems they have hit something very wrong.
#20 Daveginorge, Oct 3, 2017
Hi, I am having this issue since July with my Xperia Z5 Premium. I did a factory reset and was abk
#21 Jazuli Ismail, Oct 8, 2017
I was able to work until I got the updates. Now back in square one. No Twitter since September 17th. I thought this was Sony Xperia specific issue. But when someone else logs in to my unit Twitter, it works fine. But when I logging, get the famous message
#22 Jazuli Ismail, Oct 8, 2017
Just received an update on my Sony.. Now Twitter is back to normal
#23 Jazuli Ismail, Oct 9, 2017
Was this a twitter update, an Android update or an update to the Sony software? I'm trying to get an idea who broke the app.
#24 Daveginorge, Oct 10, 2017
Was this a twitter update, an Android update or an update to the Sony software? I'm trying to get an idea who broke the app.
#25 Daveginorge, Oct 10, 2017