Home Forum

"Unable to save photo edits"?

I just started using my new LG Optimus G, and its definitely the best phone I've ever owned to this date. Everything works great, except the 'photos' app that came with google plus. The concept is great. I love how it backs up all my photos and saves them on my profile to review and publish, edit, or download later, from my computer. And that feature works great. But they did implement another feature that I really can't live without, now that I have grown accustomed to this feature.

I am, of course, talking about the 'edit' feature. I really use it a lot, and I really love the way that this particular app goes about this feature. But a few days ago, it just stopped working. Now, every time I try to edit a picture, whether it would be filters and frames, or just cropping an image, it just loads for a while and returns with the message 'Unable to save photo edits'. I have no idea why it's doing this. I have tons of space left, so it can't be lack of space. and O have rebooted the device tons of times, but that doesn't seem to help either..

What do I do? ):
 

Related:

#1 AkTheTimelord, Nov 20, 2013
*shameless bump*

):
 
#2 X4rr1n, Nov 21, 2013
**bump**

Got the same problem on my lg optimu 2x (running a custom 4.3 ROM)!

Help us! Lol
 
#3 caleafterearth, Nov 22, 2013
*more bumps*
Send help plaz ):

And food!
We're getting hungry down here!
 
#4 X4rr1n, Nov 24, 2013
I had the exact same "Unable to save photo edits" error on the LG Optimus G Pro also, but I think I found a solution:

The new Photos "app" is part of the Google+ app. Go to App Info for the Google+ app and "Force Stop" it, if it's running. Clear Data and Cache, then click "Uninstall Updates." This will take a few minutes, but it's rolling the app back to factory defaults. Once that is done, find Google+ on the App store and update it. Now you can edit photos again with Google+'s awesome Photos app. :D

Hope this helps!
 
#5 Zethican, Nov 29, 2013
Thank you!! <3
 
#6 X4rr1n, Dec 5, 2013
Tried that, didn't work. :(
 
#7 NealJ777, Dec 12, 2013
Does anyone know if the new Google+ update (shake to add snow) fixes this issue?
 
#8 NealJ777, Dec 13, 2013
Force Stop on Google+, removal and then getting update worked for me.

Droid MAAX RAZR HD:)

Thanks for tip.
 
#9 Al Frowiss, Mar 15, 2014