HTC Desire HD Forum

Root Using Advance Ace Hack Kit?

Noob Alert

Basically trying to root my phone, and put ARHD on it...

using the AAHK , but confused on the first like when it talks about some .zip file and a command promt? anyone tell me whats going on ? or is it possible for someone to explain the whole hing to me ?? really dont know what im doing here..:(


#1 Mehta23, Dec 1, 2011
Have you downloaded it yet, or just looked at the instructions?

Before you start, you need to remove HTC Sync, MyPhoneExplorer or any other app that's capable of talking to the phone via the PC. And connect your phone to the PC in Charge Only mode, ensuring USB Debugging is enabled (Settings -> Applications -> Development).

Once done, you download this zip file and extract all of the contents to a folder of your choosing on your PC.

Inside that folder, there's a file called hack-ace.cmd, right click that and select Run as Administrator and the tool should start itself. In the next menu, select 1 and it should do root, S-OFF and install ClockworkMod for you. Rather than give you instructions for installing ARHD now, just try the Ace Hack Kit first, then I'll try and sort you out with installing a ROM.

Is that a bit clearer?
#2 El Presidente, Dec 1, 2011
Also, be aware that it may take anything up to 30 minutes for it to root. Although mine took about 5 minutes, some people have said theirs takes a long time. Not sure exactly why it's different for everyone, but let it do it's thing and it will work eventually :)
#3 CDPlant, Dec 1, 2011
oh , the zip file was just the overall package ting , which i was in ... :)
#4 Mehta23, Dec 1, 2011
BTW, from your other thread, if the volume key is broken, you're not going to be able to install a custom ROM. You need that for navigating clockwork.
#5 El Presidente, Dec 1, 2011
the actual mechanism still works :)

erm, i ran the cmd file , but there was no option to run as administrator- and now it asks for a pass key ???
#6 Mehta23, Dec 1, 2011
I don't have the latest version (and didn't use a pass key when I did mine) but in the changelog for the hack kit says -

So it should explain in the manual what to do about it
#7 CDPlant, Dec 1, 2011
When you run it, the program generates a passkey in the "txt" folder under tools. it's a notepad file. An easier way is to open the manual and scroll to somewhere near the bottom where there is the FAQ and within that there is a link directly to the file it has generated. "CAJUN.txt" is what you are looking for. It's in the FAQ and quite easy to spot. Find it, enter it into the console to continue the root process.
#8 RED_, Dec 1, 2011

need help. i ran AAHK. it seemed to run smoothly, but when it said
S-OFF, ROOT and Clockworkmod recovery complete

it then said, Starting update process....
<waiting for device>

since then my DHD phone screen has htc logo on it and i am waiting....

is this how it is? if not, what went wrong, and what to do. help!
#9 asimshouket, Jan 25, 2012
I had this problem. I ran it again making sure that I toggled 't' so that the flash method was set to PD98IMG method.

I'm of course a little nervous offering this advice, but it worked for me.

Good luck!
#10 freestyle_gus, Jan 25, 2012
Looks like the AAHK developer has parted ways with XDA. Anybody know where he went?
#11 ral, Jul 24, 2012
He had an argument with a mod a few days ago and he has decided to leave xda and continue the AAHK from his own website.

Edit: Link is here
#12 CDPlant, Jul 24, 2012
Oh well, as a beneficiary of his work, I guess I will sit this one out.
#13 ral, Jul 24, 2012
I guess that the link in the root sticky needs updating for the AAHK then?
#14 D-U-R-X, Jul 25, 2012
Finally, I cam help out with something:

Found AAHK on this page:

Download link for AAHK (12062012).
#15 ral, Jul 25, 2012
Sorry gents. Thanks EP.
#16 ral, Jul 25, 2012