LG Optimus F7 Forum

Support What keeps turning my wifi back on?

Even though I turn wifi off in the settings, for some reason it turns itself back on at inopportune times, apparently in order to detect and nag me about nearby WiFi networks that they would rather I be using. The last time it happened it interrupted the playback a YouTube video.

Has anyone else seen this behavior? Does anyone know what may be causing it and how to make it stop?
 

Related:

#1 NumbChops, Aug 16, 2013
Hello and welcome to the forums. I see your having a problem with a android device . Well the wifi can be fixed very easy go to the settings and look for the wireless network settings you want to uncheck the notify one . But to be very truthful with u the wifi trick is the way to go . This is due to the data if your on wifi your not getting the data charges . O yes NO OVER ON DATA . But u need the wifi for YouTube cause the videos to watch. But uncheck the notify when new networks is near. And this will stop the wifi from a random cut on . This wifi can save data and battery . .post back if any problems
 
#2 BRAINZ2013, Aug 16, 2013
Sometimes it turns back on because of the connection optimizer, it should be in your mobile data settings

Sent from my C525c using Tapatalk 2
 
#3 Mikessv, Aug 16, 2013
If its available on your phone.

Sent from my C525c using Tapatalk 2
 
#4 Mikessv, Aug 16, 2013
If not you can download a wifi switch that u can control yourself and have it on the homepage of the device
 
#5 BRAINZ2013, Aug 16, 2013
I don't see a notify setting for wifi connections. I'm looking in system settings/wireless and networks. As I said, I have turned wifi off multiple times, but something is turning it back on. What is doing that?

Yes, when I'm around a wifi connection that I can use, I prefer to use wifi. I completely agree with you. But that is not the case here. These are random networks that I don't own and cannot access.

Also, I still very far from BoostMobile's throttling limit of 2.5 gigs, so I should have no problem viewing a youtube video over the mobile network.

Thanks
 
#6 NumbChops, Aug 16, 2013
Pull down the status bar and when you see the wifi button press and hold till the wifi open up . When it does you will see 2 options . One will be to turn wifi on and off the second will be wifi settings or the notify that u will need to uncheck .
 
#7 BRAINZ2013, Aug 16, 2013
Go to Settings, click Wi-Fi then the top option should be what you are looking for. Also disable Connections Optimizer, Settings/More/Mobile Networks
 
#8 rpdrizzy, Aug 16, 2013
And YouTube should view over mobile network and over wifi . I think wifi is better, safer, quicker and cheaper on your mobile data
 
#9 BRAINZ2013, Aug 16, 2013
I found and turned off the wifi notifications, so at least the nagging should stop.

Connections Optimizer has been disabled all along according to the settings. So I'm still not sure what has been turning it back on.

If it continues still looks like it's causing problems, I'll go look for another switch as suggested.

Thanks
 
#10 NumbChops, Aug 16, 2013
Hopefully that should fix your problem, I'm on Boost also and I have the Htc One and it was turning on for me too

Sent from my C525c using Tapatalk 2
 
#11 Mikessv, Aug 16, 2013
Confirming that with both wifi "Network Notification" turned off, and "Connection Optimizer" disabled, I have not seen wifi turn itself on again. Thanks :)
 
#12 NumbChops, Aug 19, 2013
I spoke too soon. Even with wifi network notification off, wifi turned off and "Connections Optimizer" disabled in the system settings, the wifi will sometimes turn itself on again if you are near a network that you have connected to in the past.

That may be useful in some situations but not all, and it's not what I need. I want to connect to my neighbors wifi only when he invites me, not spontaneously and at seemingly random times.

Is there a way to replace the connection management with a third-party manager that is configurable and more transparent in its behavior?

Thanks
 
#13 NumbChops, Aug 20, 2013
Was poking around, saw something called birdstep running, then found this http://www.fiercebroadbandwireless....technology-data-traffic-management/2012-06-20

So it looks like the phone ignores the system setting and runs "connections optimizer" even if you don't opt in.

Update:
I discovered within the f7's hidden service menu a WIFIoffloading sub menu with settings for user-notification, auto-on, auto-connect and timer control. I unchecked the auto-on and auto-connect.

Update:
even that didn't fix the problem
 
#14 NumbChops, Aug 21, 2013
I think it's solved. In all of my experiments I had never tried turning the connections optimizer on for the first time then off again. I did that and it now seems to be behaving as expected. Sounds like a software initialization bug to me.
 
#15 NumbChops, Sep 9, 2013
I have the HTC one x and the phone just had an update about a week ago. Since then my WiFi just likes to try and connect randomly and now has a red symbol over the WiFi icon when doing so. I'll turn it off and eventually will do it again. It's driving me crazy. Also when it pops up the web browser there's 2 options on the bottom that appear that can be checked. I have checked them UN checked them , gone through settings and can't figure out how to stop it. I'll be on 4g so I wont need WiFi and if playing an online game forces me to reboot game because it's trying to connect. Help!!
 
#16 jpjp, Feb 26, 2014
I noticed that my wifi comes on if I'm charging the phone and then unplug it for a second. I have all settings I can think of turned off. My phone didn't do this before. I can't find a power setting that is causing it. Help? Lol
 
#17 dsap4004, Mar 7, 2014
Okay so I have an HTC one and it happens to turn on the wifi when I unplug power and then plug it back in. Sorry I left that info out on the previous post.
 
#18 dsap4004, Mar 7, 2014
It's connection optimizer. It will automatically turn on wifi to look for connections. Had that on my one sv as well.

Nevermind thought I was on the first page still and no one had answered. Long day. Lol
 
#19 Kreatur3, Mar 14, 2014
you need to disable the setting to allow Google's location services to scan for networks even tho WiFi is turned off, it's in the WiFi settings under Advanced.
 
#20 matt_0978, Jul 31, 2014
Greetings,
I had the same issue with my device. T-Mobile doesn't seem to have a "Connection Optimizer" feature in its line of phones. In T-mo's case the feature that needs to be disabled is the "Wi-Fi Manager". To disable this feature you need to do the following:

Access your T-Mobile account (for me I just press on the "T-Mobile My Account" App).

Press the menu button on your device, then select "Options".

Under "Notifications" uncheck the box marked "Display Wi-Fi Manager notifications".

Under "Connection Assistant" select "Open Wi-Fi manager".

Uncheck the box for "Manage Wi-Fi Connections".

That's it...

I talked to T-mobile tech support about an unrelated issue and offhandedly mentioned this problem. The rep informed me that this was a known issue and stated that this issue was being addressed. In the mean time disabling the "Wi-Fi Manager" is a temporary fix to address this problem. Here is the shorthand way to disable the Wi-Fi manager:

T-Mobile My Account -> Menu -> Options -> "Display Wi-Fi Manager Notifications" (Uncheck) -> "Open Wi-Fi Manager" (under "Connection Assistant") -> (Uncheck) "Manage Wi-Fi Connections".
 
#21 themorn2112, Sep 1, 2014
My phone is a Galaxy ACE GT-S5830M (baseband S5830MWHMJ1) with Android 2.3.6 (rooted)
It's driving me crazy. As is well known, there is no way to stop some Google apps like Google plus from updating themselves when there is an Internet Connection. Unfortunately this maxes out my available Memory as this app cannot be moved to the sd. The difference between the Basic app and the all updated app is about 20 MB and when fully updated my Galaxy ACE even refuses to accept incoming Messages. So I used to Switch Wifi off when not needed, uninstall the Google+ updates and my phone worked nicely.
Today I changed the mobile Provider to Vodafone and since then WIfi turns on all the time. I switch it off and a few seconds later it is switched on again, connected to the Wifi of my router. I switched off the network notification of the phone, but it does not changed anything. I looked for the connection optimizer that has been mentioned but there is none. Seems to be special on Sprint phones. Mine is not from any provider.
I was even thinking of turning of the Wifi of my router, but there is other people connected to it. I could kill this entry in the phone's list of known wifi networks, but then using it if needed becomes cumbersome as I would have to enter the long password everytime. As an aside, it would simply connected to one of the other two Wifi channels that we have.
OTOH I never had this problem before, something appears to have changed when I put in the Vodafone simcard. I have restarted the phone but to no avail.
I hope someone can help.
 
#22 PanamaJay, Sep 1, 2014
After I submitted the post, I googled the word "Wifi switch" which I found in this thread. I found and installed "WiFi Manager" by Kostya Vasilyev , installed it and got rid of the problem. It allows to disabled a selected Wifi channel. So while "Wifi" continues to turn on after I turned it off, I can now deselect all "known" wifi channels and thus avoid that the phone can connect to it. Will try also some other app that may be less complex.

Edited a few installations later:
None of the other "wifi switches" I installed worked for me. They just do what I can do with the pull down menue, they switch of and after a short time the phone switches it on again. The one above is the only one that works, but only the app, not its widgets. Unfortunately a bit bulky but so be it.
 
#23 PanamaJay, Sep 1, 2014
I had constant Connections Optimizer (CO) alerts to connect unwanted WiFi afte S5 Lollipop update.

Settings > (under System list) Battery > Connections Optimizer > Force Stop (I did this before seeing the Disable Button -- I don't know if that would have actually worked) > (At the bottom of the screen): Stop or Uninstall Applications… Click the APP INFO button > Clear Caches and uninstall C.O. when prompted…

Shortly afterward I received a Notification/Agree To Terms page from Sprint that WiFi would connect automatically through CO! I did NOT agree, but instead clicked on More Info. At the bottom of the screen is the statement:

“To disable the C.O. simply uncheck the box above.” (But make sure to uncheck the Partner WiFi box first or it will remain checked after you uncheck the C.O.)
 
#24 brstone, Mar 2, 2015
I just root the phone then use rom toolbox or another root enabled app manager to uninstall connections optimizer (along with other bloatware)
 
#25 jfuginay, Apr 11, 2015