Home Forum

Support Wifi button greyed out!!

Hey guys,

The button to turn the wifi on/off on my phone doesn't work. Whenever i tap on it, it won't respond and when i go to the wifi setting, the slider doesn't work too. There are also no availale networks anymore.

Please help me, if you need more info just ask me

Thanks
 

Related:

#1 HotNectar, Sep 14, 2016
Have you tried to reboot the device yet?
Perhaps it will resolve that glitch:)
What device make/model/carrier is it?
 
#2 Mikestony, Sep 14, 2016
Iv'e tried rebooting my phone, wiping my chache partition, resetting my phone memory and it didn't work

I have a HuaWei P8 Lite
 
#3 HotNectar, Sep 14, 2016
Oh boy. :( You've reset ---as in, factory reset back to stock?

Based off of my device, I can still turn on wifi even without any networks available so I'm wondering if it is some sort of hardware issue.
 
#4 Mikestony, Sep 14, 2016
Yeah, but i have everything on backup.
 
#5 HotNectar, Sep 14, 2016
Has the device had a recent update and then this issue arose?
 
#6 Mikestony, Sep 14, 2016
No it hasn't, and the problem just accured this morning
 
#7 HotNectar, Sep 14, 2016
Maybe try a simulated battery pull:
(I realize yours is the P8 Lite but the same procedure should apply;) )
Source
 
#8 Mikestony, Sep 14, 2016
Nope, i tried them 2 times each and my wifi still doesn't work. :(
 
#9 HotNectar, Sep 15, 2016
bump
 
#10 HotNectar, Sep 18, 2016
Check in Settings, About Phone, and see if your baseband is correct or unknown.
Also check if your IMEI is correct or unknown.
 
#11 Jfalls63, Sep 18, 2016
There are a bunch of random numbers on the baseband and 2 sets of random numbers on IMEI.

I don't know what these are.
 
#12 HotNectar, Sep 18, 2016
There are a few things you can try.
Turn off phone and remove and replace sim reboot, check wifi.
Toggle Airplane mode on/off , check wifi
 
#13 Jfalls63, Sep 18, 2016
None of them worked. Give me more options :(
 
#14 HotNectar, Sep 18, 2016
Do you happen to have CM Security installed on your phone?
 
#15 Jfalls63, Sep 18, 2016
No, i don't know what that is
 
#16 HotNectar, Sep 21, 2016
See if any solutions here help
http://forum.xda-developers.com/p8lite/help/enable-wifi-wiping-cache-partition-t3224376
 
#17 Jfalls63, Sep 21, 2016