Samsung Galaxy S3 Forum

Support Wifi Keeps Auto Connecting

MY phone keeps connecting automatically to open wifi networks which then stops my 3G working. Is there any way to stop this?

I have read about a setting for Auto Connect on the Advanced Wifi screen, but I don't get this option on my unlocked UK phone, I've just got
Network notification
Keep Wi-Fi on during sleep
Check for Internet service.

I've tried to 'Forget' the offending networks (mostly BT Openzone), but this doesn't help. There must be some way to tell it to connect only to known networks or when I manually request it.

Thanks
 

Related:

#1 jdta09, Sep 11, 2012
just turn wifi off when not in use.
 
#2 streetkilln, Sep 11, 2012
Some of the time, I want to connect to a wifi network, just not the one it auto connects to, so I need wifi on.
 
#3 jdta09, Sep 11, 2012
Download an app called AnyCut.

This will remove that annoying little Wifi Reminder.


How to remove WIFI Popup Notification:
Open anycut.

Click 'new shortcut'

Click 'activity'

Click 'HiddenMenuWifiOffload'

use new home screen shortcut to turn it off
 
#4 bigslam123, Sep 11, 2012
Thanks, but that doesn't help. When I go to work there are multiple wifi networks and it always connects to the wrong one and I want to prevent it from doing that. Also at home it frequently connects to an open network nearby rather than my home one.

There must be some way to say 'Connect to this network, never this one'
 
#5 jdta09, Sep 12, 2012
Hold down on the particular network in Wi-Fi settings until a popup box appears. Choose "Forget Network", and should remove it from the list and no longer connect to it automatically.

If you don't want to be notified when an open network is available, you don't need a third party app; simply uncheck "Network notification" under advanced settings.
 
#6 Easilyamused, Oct 6, 2012
The problem is the stupid Sprint Connections Optimizer. You'll need to go to setting, then under Wireless and network, click More settings, then scroll down to Mobile networks, then click Automatic Connections. Now un-click Sprint automatic connection. That will stop wifi from trying to automatically connect to a wifi network. There is one more step you can take after that, which will help with battery life. Go to >settings>Application manager> choose Running, then stop Sprint Optimizer.
 
#7 gme109, Oct 6, 2012
I have heard of this problem with the Verizon GS3, due to something Verizon added to the phone and wont let you remove.
 
#8 gowcaizer1978, Oct 6, 2012
Click on Settings
Select Wi-Fi
Uncheck the Notify Me When launching apps, notify me when Wi-Fi is available
Click the button on the bottom of the phone to the left of the center push button.
Click Advanced
Uncheck the Auto-connect
Done.
 
#9 b2fast4u, Mar 11, 2013
With WI-FI turned off I keep getting notification "Connecting to Wi-Fi" what I am doing freezes till it finishes. I check Wi-Fi it's still off. Minutes later it will do it again. Drives me nuts.
 
#10 jackm1249, May 16, 2013
.

Thanks so much for answering with the info about the SPRINT CONNECTIONS OPTIMIZER!!! This stupid service has been messing with my connections since I got the phone and I finally was able to disconnect this service (which I didn't even know was on there!). Thanks so much for the help!!!!!!
 
#11 cp1105, Aug 21, 2013
Thanks, It helped me too. On Samsung s3 go to settings, connections, more networks, mobile networks, connections optimizer, then uncheck.
 
#12 dvdpal, May 19, 2014
Hi jdta09, you don't say which Android version you are on, if it is 4.3 go to "Settings", "WI-Fi", touch the menu button (on left of the home button, go to "Advanced", scroll down to "Scanning always available" and uncheck it, while there make sure "Network notification" is unchecked.
 
#13 philayl, May 20, 2014
Hi. My Huawei G750 also has the same problem. The WiFi automatically turns on even if I do not need it. How do I prevent this from happening?
 
#14 raxyyyyyyy, May 7, 2015
My xperia was also auto-connecting to a wifi hotspot called "MTS hotspot". MTS is a network carrier in my city so there would be random hotspots all over the city and it would automatically connect even though I asked to "forget network". Super annoying. If this is the case for you then go to...
System settings....
wifi...
saved networks... Find the network it keeps connecting to. In my case "MTS hotspot".
Long press on the network and uncheck "auto-connect". Hopefully that works for some of you.
 
#15 Meatball204, Feb 15, 2016
Wifi settings...
Advanced settings...
Uncheck "scanning always available"
 
#16 Meatball204, Feb 15, 2016
Hi guys. Unfortunately on my new Samsung Galaxy S6 Neo these options do either not exist or do not work !

On the Note 3 it was not a problem as the left button next to the center button provided a pop-up menu, as mentioned in some posts here. Now in their wisdom :-( Samsung provided a button that displays multiscreens in that place instead.

So I have to search myself to death for the function to 'forget' or 'do NOT autoconnect' to some networks. I haven't found it. Please help me out !!
 
#17 Dr D, Mar 1, 2016
I have an S3 mini and after manually turning off wifi, it comes back on and reconnects by itself. I tried removing recently loaded apps and adjusted the settings mentioned above. It doesn't make a difference. I can't find any consistency to the problem. This seems to have started occurring very recently. That's why I uninstalled recent apps. I've had the phone for about a year. Any suggestions?
 
#18 deluco, Mar 4, 2016
Uncheck or uninstall connections optimizer
 
#19 bcrichster, Mar 4, 2016
There isn't a connections optimizer in the phone as far as I can see...I checked under, More Networks, then Mobile Networks. No optimizer there. I tried turning off email sync; logging off Facebook, etc. It still automatically turns on WiFi and connects. It must be a setting somewhere as I'm pretty sure this only recently began happening.
 
#20 deluco, Mar 7, 2016
Hello
Have you found the solution for this auto-connecting with WIFI? I bought myself a Dupad Story F1 because they do not allow smartphones with camera at work. I always set the WIFI off when I do not use the phone but after a minute or so it automatically connects again and turns the WIFI on by itself. Does anyone know how to fix this please because my battery drains very fast like this.
Thank you
 
#21 Bartelias, May 30, 2016
Personally I did not. I gave up and gave in. I just leave the wifi (and the data) on all the time. I see no significant difference in the battery drain. I recharge every night and I have a portable battery for charging if I'm in a pinch. Fortunately I don't use my smart phone all that much.
 
#22 deluco, May 30, 2016
The last thing I have tried is looking at every installed app's specs and see what app could make its own wifi connection and I am amazed how much apps can make its own wifi connection. If it works, I keep you up to date but I have little hope because I have tried a lot. Thank you for your fast reply!
 
#23 Bartelias, May 30, 2016
update: Normally wifi starts every minute also when I turn it off manually. After reading several forums I deleted the apps that could turn on and off wifi if they want to. I didn't know if that existed untill now. Now it is almost 3 hours later after I deleted the apps I spoke about and WIFI does not turn on automatically anymore. ust wanted to let you know..
Greetings
 
#24 Bartelias, May 30, 2016