Home Forum

Support ZTE Z828, Wifi calling error w/no code

Hello,

I have a ZTE Avid Plus (Z828) with Metro PCS, running lollipop 5.1.1 (update from 5.1 came up as I left the store), and is not rooted.

I am having a Wifi calling error pop up in the top tray bar (red icon with phone and Wifi symbol), but there is no error-code. I've checked that Wifi calling is off, toggled it on/off, restarted phone to which it will disappear, and eventually reappear within hours or a day. Attempted to update the e911 address both with MetroPCS, and locally in the MyMetro app, restarted phone, and the error message still appears. Tried leaving it on with cellular network as default, but error still comes up.

I don't use Wifi calling whatsoever, nor plan too, but I'm concerned this may be part of a larger issue that's yet to rear its ugly head, such as disruption of service during an emergency.

I've been looking, but my carrier isn't helping beyond looking up the owners manual (oh dear, so shocking or something), and haven't seen much outside the e911 registration. Apparently some hit or miss lollipop 5.1.1 update issues, but again, so far nothing.

Thank you for taking the time to help!

 

Related:

#1 CoffeeNerd9000, Feb 15, 2016
Is this happening with one particular WiFi network, or different ones? If it's not an E911 error it could be due to the firewall or port blocking on certain networks. I have found this to be the case on some networks where internet access will work but the WiFi calling won't.
On your home WiFi where you have control over this, it should work.
 
#2 Fox Mulder, Feb 15, 2016
Wifi itself has been off. I've connected once and Wifi itself is fine, but this was after the error started showing up. Wifi has otherwise remained off.
 
#3 CoffeeNerd9000, Feb 15, 2016
Hm ok well that error should only appear when WiFi is on and the WiFi calling can't connect.
Maybe keep using WiFi on networks you know are open and see if it eventually connects and clears the error.
If the phone is new and you haven't saved a lot of stuff on it you could just try a factory reset and see if that fixes it.
 
#4 Fox Mulder, Feb 15, 2016
I can pull anything I put on it off to the SD card and any vital info is backed up, so factory reset isn't a problem. May end up being the lollipop 5.1.1 update.

Did what you suggested, and it cleared it. Shut Wifi and wifi calling back off and a couple hrs later the error is back. Tried it again and turned off the "allow networking searching when wifi is off" too, and the error still came back up. Kinda like the phone was meant to be predominately set to wifi calling, and will bug you until you keep it on. It hasn't effected the phone's operation at all...yet.

Sent in a support request to ZTE, so we'll see what they say when they get back to me. I'll wait to do the factory reset untill then, and I'll update when I get more info/attempt factory reset. Otherwise, if there is any more ideas, I'd appreciate it. It's a new model phone, so I'm not surprised at any quarks showing up.
 
#5 CoffeeNerd9000, Feb 15, 2016
Had this same problem yesterday. I turned on wifi calling, updated the e911 address, then made a call using wifi and the error went away and hasn't come back yet. Hopefully that helps.
 
#6 jm83, Feb 20, 2016
Same issue and not sure why but it drives me nuts not being able to clear this error even though it's not really doing anything. It just shows up out of nowhere but when I am in proximity to where I could use wifi if I wanted.
 
#7 Wyatt K, Mar 22, 2016