Samsung Galaxy S8 Forum

Apk files won't install

Hi,

I have just got a Samsung S8 phone. There are a couple of gambling apps that you can't get through the playstore so you download them from the companies website as apk files.

After I download the file I hit install and then it says "app not installed". This is happening for 3 different apk files.

When you google the problem it tells you to go to 'settings' and then 'lock screen and security' and then to check the option to 'allow downloads from unknown sources'. However this option is not there? It was on my S6.

Another article says go to 'settings' then 'apps' then push the 3 dots in top right corner, then 'special access', then 'install unknown apps'. In this section is a heap of apps. Every one I click on the button that says 'allow from this source' is greyed out and cannot be touched?

I'm lost at what to do to install these apk files?

Thanks,
Seb
 

Related:

#1 bastianell, Apr 13, 2018
Which browser are you using to install them with the Samsung browser or something else?

Also, are you using a carrier branded device or is it unlocked?
 
#2 El Presidente, Apr 13, 2018
I have tried using th Samsung internet and also chrome. Chrome prompts me that it's not allowed to install the app and takes me to the 'install unknown apps' section but the button to allow it is greyed out. Photo attached.

I'm not sure what is going on. The other thing is in settings it says there is updated firmware available and after I download it always comes up with an error.

I believe it is unlocked? How do you know.
 
#3 bastianell, Apr 13, 2018
This is the firmware install error
 
#4 bastianell, Apr 13, 2018
I don't believe that's a firmware update, rather an update for one of the apps that Samsung bundle with your device. Can you install anything? Have you tried installing new apps via the Play store, or updating existing apps.

I can't think why that option would be greyed out and it's not something I can replicate on my device either unfortunately.

It's a long shot, but have you tried clearing system cache via recovery?
 
#5 El Presidente, Apr 14, 2018
Is there a security setting in the phones settings blocking installations from unknown sources? Also check your play store settings for that
 
#6 Dannydet, Apr 14, 2018
So my phone has sophos security installed but when I go into it all the app security is turned off.
 
#7 bastianell, Apr 16, 2018
Is this a company phone @bastianell ? Sophos looks like a serious business end security system which is controlled centrally. In which case your phone is probably locked down tight much like your works PC with admin rights.

You could also just have the android app installed by default by your provider, in which case you could try and uninstall the app, restart and see if the greyed out options re-enable. A guide can be found here:

https://community.sophos.com/kb/en-us/117456

If it's a company phone I would not touch anything and leave as is tho!
 
#8 JAy3001, Apr 16, 2018
On my Pixel (Android 8) there is no system-wide "allow unknown sources" option. Instead you can give some individual applications the privilege to install such apps (in my case I granted it to the X-Plore file manager). But if I try to install using some other app it tells me clearly what the problem is - maybe the Samsung is different?
 
#9 Hadron, Apr 16, 2018
That is how the Samsung is @Hadron. Sadly the OPs phone appears to be locked down ATM.
 
#10 JAy3001, Apr 16, 2018