Kyocera Rise Forum

Support Connections Optimizer killing battery life, won't stay disabled

This is my husband's phone. He's had it since Black Friday. In general he's not a big smart phone user, but needs good battery life, which the Rise used to deliver.

Lately, though, his battery has drained very quickly, and the much-despised Connections Optimizer appears to be to blame. Even when he unchecks the box to disable it, after a while the phone will make a little chirp and re-enable it on its own.

Since it won't stay disabled, and he doesn't want me trying to root the phone, I'm looking for another way to deal with the Connections Optimizer problem. Specifically I wondered, will doing a factory reset remove it from the phone? Since it came through as an OTA update I thought it might work. Can anyone confirm if that's the case - or have another approach i can try?

If I can't fix this, he's seriously thinking about digging out his old Rumor Touch.... so please - help!


#1 aml1025, Jun 19, 2013
It comes pre-installed whit the phone. If you want to remove it you will need to root the phone and then remove it, But dont do it. You have the risk of messing up the phone completly and voiding your warranty, but if its that annoying go ahead. But you been warned.
#2 Epico, Jun 19, 2013
I'm pretty sure Connections Optimizer was added to his phone in an OTA update; that's why I wondered if doing a factory reset might take care of it. And I do realize that rooting the phone would void the warranty (even though I've seen ample proof that Virgin Mobile doesn't check/care if phones are rooted before replacing them), but since it's my husband's phone and he doesn't want me to root it, that point is moot.

As for bothering him, the fact that Connections Optimizer keeps restarting is bringing the phone's battery life to about 1/3 of what it was. It's more than a bother; it makes the phone almost useless to him due to lack of being able to charge it during the day. That's why I'm trying to figure out a solution.

Connections Optimizer may have been someone's idea of a way to reduce the data load on Sprint's network, but it's really a big pain and seems to do more harm than good. If I could even convince it to stay disabled on the phone, I'd be satisfied.
#3 aml1025, Jun 20, 2013
Factory resets only wipe your data and cache partitions, they don't effect anything an OTA would touch (the system partition)

Speaking of that system partition, that's where the connections optimizer app is located, and you don't have access to any of that without root.
#4 Rxpert83, Jun 20, 2013
That tells me what I needed to know. Thanks!
#5 aml1025, Jun 20, 2013
First try going to your wifi settings, click advanced and disbale Wifi from turning on auutomatically. After that go to settings, to "more", mobile network, the connection optimizer and uncheck the box.
If that does not work for you, the next solution is to root your device. Then you will have a few tweaks available from an app called PimpMyRom on GooglePlay. I posted a simple and very informative root procedure online. Please let me know if you have any other questions.
#6 TechDad378, Jun 24, 2013
I installed Titanium Backup Pro (paid version, rooted phones only), backed up the phone, and then simply disabled the optimizer. To save battery power, I'm using Green Power Premium. It's the only battery saving app I'd recommend to anyone using an Android phone, as the dev is great about updating it frequently.

I haven't uninstalled any system apps, because doing that has caused boot loops for some Rise users. That limits the number of apps I can install on this phone, but I'd rather have it tailored to my usage, anyway. I couldn't possibly keep up with every program out there.
#7 daffyducknj, Jun 26, 2013

I appreciate the suggestion, and he's not a big app user either, so space on the phone isn't a big concern. He just doesn't want ne "messing around with it" aka rooting it, so everyone's great solutions are unfortunately useless for me.

This weekend I'm going to try a factory reset to see if it will help get rid of whatever glitch that's causing the Connections Optimizer to re-enable itself all the time. It's not much of a solution, but seems to be what I'm left with right now. Who knows, maybe if the problem gets more aggravating, he'll eventually be willing to try other solutions. :)
#8 aml1025, Jun 27, 2013
I had this problem on a Sprint GS3, while my home broadband was down and I didn't WANT to connect to wifi, thank you.

Even when I unchecked Connections Optimizer, it persisted, turning my wifi back on in a matter of seconds when I unchecked the wifi. I tried clearing cache, force stopping the app, rechecking and unchecking the connections optimizer box, restarting the phone, and still it persisted.

What ended up working was unchecking the Connections Optimizer box, then power cycling the phone, leaving it off for at least 30 seconds to a minute beforing turning it back on. After doing this Connections Optimizer stayed off and I was able to access the wireless data signal.

To verify that I didn't just have some weird one off combination of events, I turned it back on, and it stuck again. Again, unchecking the box and power cycling worked to keep connections optimizer deselected.

I don't know if this problem and solution is unique to the GS3, or my combination of loaded apps and wireless coverage (I have a weak signal in my home) might have contributed, but if your connections optimizer is persistant in this manner, you might want to give this solution a try before resetting to factory default or rooting the device to get rid of it, which are much more onerous projects.

Post back if you've had this issue, and this solution worked, and on what device.

Rob M
#9 remurph, Apr 8, 2014
Constant Connections Optimizer (CO) alerts to connect unwanted WiFi afte S5 Lollipop update.

Settings > (under System list) Battery > Connections Optimizer > Force Stop (I did this before seeing the Disable Button -- I don't know if that would have actually worked) > (At the bottom of the screen): Stop or Uninstall Applications… Click the APP INFO button > Clear Caches and uninstall C.O. when prompted…

Shortly afterward I received a Notification/Agree To Terms page from Sprint that WiFi would connect automatically through CO! I did NOT agree, but instead clicked on More Info. At the bottom of the screen is the statement:

“To disable the C.O. simply uncheck the box above.” (But make sure to uncheck the Partner WiFi box first or it will remain checked after you uncheck the C.O.)
#10 brstone, Mar 2, 2015
I can't stand when connection optimizer turns on when I don't want it, for example, when I am driving and navigation is on, or when I am reading a Kindle book. To turn it off on Lollipop, Settings/Connection/More Networks/Mobile networks/Connection optimizer - then uncheck the checkbox
#11 vgrazi, Aug 16, 2015

#12 Alecova, Apr 11, 2016