Home Forum

General "Deep Sleep Battery Saver" .. great way to save battery on Tablets

ok... to save even more battery life. Get "Deep Sleep battery saver"

I have a smartphone connected 100% of the time to get all my notifications.
I only use my Note8 for reading and play. There is no reason it needs to be getting notifications of emails, texts, news, social media.. unless I wake it up to use.

even when sleeping.. it would drain about 1-2% battery per hr sleeping.
android and system processes! and media updates.

so I found this app called: "Deep Sleep battery saver".
when the screen is off.. it turns everything off.. all connections.
allows NO updates.
it even keeps the system processes from starting. Android is in REM sleep!!! :p
you can set it up .. to wake up for 1 minute every hr.. or 2 hrs.. or 4 hrs. l selected "no waking up".
when the screen comes back on.. it lets the tablet get updates. normally there are none, because I have already taken care of them via the smartphone.

now the Note8 sleeps .. and only uses about 1% every 3 to 4 hrs.
I estimate about 10% per day lost if left alone sleeping.
I think if I left the tablet alone for a week.. it would still have a charge!
 

Related:

#1 dan330, Jan 28, 2015
That sounds like it could be pretty useful for a tablet or other devices that doesn't need any background updates when it's not being used. I may even load it up on my N4 with a schedule for while I'm at work (can't have my phone at my desk, so it sits in my car all day).

Btw, the app can be found here: https://play.google.com/store/apps/details?id=com.rootuninstaller.batrsaver
 
#2 codesplice, Jan 28, 2015
free version.. does not let you customize the time tables.
but if you purchase the full version.. then you can do customize it.

I have Tasker... I know I can get tasker to turn off many things with screen off.
but I don't know if it will .. turn of Android services. Put the device into Deep Sleep. NOTHING is running.
 
#3 dan330, Jan 28, 2015
Get your apps under control and you won't need it.

[​IMG]

;)
 
#4 EarlyMon, Jan 28, 2015
I think I'm good with this solution - triggered by "at work", "driving profile not active", and "display off":

[​IMG]

I'll find out how it works tomorrow.
 
#5 codesplice, Jan 28, 2015 Last edited: Feb 3, 2015
turning off all connections and GPS .. is good

but android still doing stuff in the background. that was eating up my battery..
Deep Sleep stopped all activities. Great for my tablet..
I would not think it is good for an important device that needs to be "in touch" and connected at all times.
 
#6 dan330, Jan 28, 2015
If sync is fully disabled (like when the device is in Airplane Mode) there really shouldn't be a whole lot going on in the background. If there is, it's likely an app misbehaving.

I started to add a "disable background processes" action to my profile but then realized that it *shouldn't* be needed. Again, we'll see.
 
#7 codesplice, Jan 28, 2015
ok.... Codesplice..

could you try something... go 2 days.. with your phone in your car with Tasker. then 2 days with Deep Sleep.
lets compare. I am interested to see if there is a difference.
 
#8 dan330, Jan 28, 2015
I'll test with the tablet and see what happens. That should be a more predictable test (and less likely to have a configuration change).
 
#9 codesplice, Jan 28, 2015
I use DS on my tablet, mainly to keep Facebook under control, and it works really well :thumbsupdroid:
 
#10 funkylogik, Jan 29, 2015
So I've been testing that Tasker Airplane Mode profile for a few days with positive results - my phone no longer drains like a falling rock when it's idling in my car at work.

(It still takes a nosedive when I'm playing with it constantly during my lunch hour, but the idle drain is much improved.)

Not sure why it shows that my Wifi is on the whole time; it definitely isn't. Is that a Lollipop bug?
[​IMG]
[​IMG]

I've also been leaving my N7 tablet idling in Airplane Mode - it dropped to 92% over 2 days 19 hours and some minutes:
[​IMG]
[​IMG]

I'm not sure if DS Battery Saver can improve on that, but I charged to 100% last night, disabled Airplane Mode, unplugged it from the charger, and launched DS in "Slumberererer" mode. I'll check back in two days and some change to see where we're at.
 
#11 codesplice, Feb 3, 2015
Nice one mate. That's great and looking forward to your results for DS as I'm a fan of it :thumbsupdroid:
 
#12 funkylogik, Feb 3, 2015
awesome!!! cant wait
thanks!
 
#13 dan330, Feb 3, 2015
Well I'm cutting the DS test a little bit short - it hasn't run for the same 2 days 19 hours, but my tablet's battery has already dropped to 92%:
[​IMG]
[​IMG]

So while the "slumberer" setting should have essentially shut everything down while the screen was off, it looks like Wifi stayed on and stuff continued to try to sync. I don't know if it's a Lollipop limitation of DS or what, but for me the Airplane Mode approach is clearly more effective - and, clearly, background apps keeping the sucker awake isn't a problem.

Thanks for inspiring me to test though. :)

Update: the Slumberer profile doesn't actually manage Wifi, which explains why the Wifi stayed on (and DS didn't do much for my battery life). I'd need the paid version of DS to be able to control the Wifi radio, but I think I'd rather just use Tasker to accomplish the same.
 
#14 codesplice, Feb 4, 2015 Last edited: Feb 4, 2015
Nice one mate cheers for the test.
Must admit I've never tested DS properly but on kitkat my battery graph would virtually flatline while in standby.
Since flashing a lollipop rom the other day I find its discharging more in standby so you could be on to something with the LP bit.
Might mail the dev....
 
#15 funkylogik, Feb 4, 2015
Just mailed him quoting the issue (wifi still being used in standby) and asking if 5.x broke it :thumbsupdroid:
 
#16 funkylogik, Feb 4, 2015
I meant to grab the expanded chart display thinger (that actually shows how much of the time the sucker is awake / using wifi / etc) but completely forgot to do that on the way out my door this morning. I'll try to pull that chart tonight though.
 
#17 codesplice, Feb 4, 2015
Here we go...

[​IMG]
[​IMG]
[​IMG]
 
#18 codesplice, Feb 4, 2015
Under settings > wifi > advanced, do you have "scanning always available" ticked? If so, your wifi will stay on even when you are not using it, for google to use it to track location.
 
#19 GuitarG20, Feb 4, 2015
Gmail reply https://app.box.com/s/g808vphx5n809d2ia7gr7ksuat8j6ml7
 
#20 funkylogik, Feb 4, 2015
Good thinking. I'll have to double check on the tablet. I know that I had tested toggling that option on my phone when experimenting with Airplane Mode. The chart still indicated wifi on but I didn't see any actual battery drain attributed to it.
 
#21 codesplice, Feb 4, 2015
I'm an idiot. :eek:

I had been testing with the "Slumberer" profile in DS, which turns off data and "forces deep sleep" (whatever that is) the entire time the display is turned off. It doesn't seem to actually do anything for Wifi - which explains why I never saw Wifi get turned off (and the slightly increased usage compared to Airplane Mode).

Being a preset, this is a read-only profile, so I don't have any way to change that. I fired up a Custom profile in an effort to tell DS "go ahead, turn off Wifi for me" - but actually customizing the Custom profile requires the Pro version of the app (go figure). As far as I can tell, I don't have a way to test how well DS can control my Wifi without paying for it - and I don't personally feel a need to pay for it just to test. I don't seem to have any problems with apps keeping my tablet awake, and I don't think that any radio management will be better than just turning all the radios off anyway. ;)

So I'm ceasing my DS tests, which have ended up being entirely pointless anyhoo. Along the way I did, however, learn how much better my N7 does in Airplane Mode than idling with Wifi (and sync) enabled, so I think I'll whip up a Tasker profile to toggle Airplane Mode based on how long the tablet has been idle. :thumbsupdroid:

Sorry for wasting your time here! :oops:
 
#22 codesplice, Feb 4, 2015
Not at all mate I appreciate your tests.
I've never used Tasker properly before but I think it works on recipes? If so could you share yours with me and tell me how to apply it please mate?
 
#23 funkylogik, Feb 4, 2015
I'll try to work it up this weekend and share it here. I'm not allowed to have my phone at work anymore which seriously cuts in to my tinkering time.
 
#24 codesplice, Feb 4, 2015
Bummer man. Cool cool cheers mate :thumbsupdroid:
 
#25 funkylogik, Feb 5, 2015