Samsung Galaxy S4 Forum

Root How to root Verizon Galaxy S4 with Lollipop (5.0.1)

I just rooted mine we while on OF1 and Android 5.0.1 using the above XDA provided method. Worked like a charm!! I made sure I used Titanium Backup to disable software update checks.

To anyone trying to Root a Verizon Galaxy S4 on OF1, don't bother with King Root. Waste of time. Download the PC program called MobileGo (it's linked in the first post of the XDA thread) it's a 15 day free trial. Use "One Click Root" that is included in MobileGo with a tab on the right hand side within the program.

I'm loving this phone more than ever now! :)
 

Related:

#51 Brianp48093, Dec 15, 2015 Last edited: Dec 16, 2015
Okay, I did this and successfully "rooted" my Verizon Galaxy S4 i545. It was cool. When I powered on my phone, it started up with a Samsung logo with a little unlocked icon underneath it, then went into the normal boot. I was able to use lollipop and removed a handful of bloatware apps.
The real reason I wanted root, though, was because I wanted to get back to KitKat. I don't like material design. I liked the KitKat settings interface. I think my camera worked better with KitKat than it does now. I also have a bug that leaves my default messenger app stuck in conversations and unable to go back to the top level to view other conversations. Bottom line, rooted lollipop was not my end objective.
This is where things start to suck. See, I had a "rooted" phone, but the bootloader was still locked. I could boot to download mode and flash kernels, but I couldn't boot to recovery. I tried TWRP and Clockwork ROM Manager. Neither of them worked. If I selected the boot to recovery options from either of those apps, the phone would display "Could not do normal boot" in red letters above the Odin download display. The only way I could get my phone to boot after each of those attempts was to turn it off, restart it in download mode, and reflash the OC1 kernel via Odin from my PC. I was still "rooted" with lollipop, but my phone was starting to act funny. It was really slow. Google crashed and chrome didn't work. I spent hours trying to work around the locked bootloader. No matter what I tried, I couldn't load ANY OTHER ROM.
Skip to the end... I used the Verizon System Update utility to back up and "repair" my phone. It worked. I had to set up all my accounts again, but my contacts, messages and photos were all restored. Bonus, my phone is now faster than ever. I wish I had tried the Verizon System Update utility a long time ago.
I don't get to see the cool unlocked icon when I start my phone up, but I have decided that rooting this i545 with a locked bootloader is like breaking out of my jail cell... only to discover I still can't get out of the building.
My advice: Don't waste your time rooting your Verizon Galaxy S4 i545 if you've updated past KitKat. Your bootloader is locked. Root won't buy you much.

"I got this S4 on lock."
 
#52 S4 on lock, Jan 1, 2016
With the introduction of Knox it is impossible to downgrade firmware. Verizon locks the bootloader so no chance of custom recovery. You are limited to flashing modified stock Roms with Flashfire, a few can be found on XDA.
If you are looking for a phone to run custom Roms,Verizon models are a bad choice.
 
#53 Jfalls63, Jan 1, 2016
Where you ever able to root your phone? This particular phone has a locked bootloader. Work around supposedly is this kernal, SCH-I545_MD2_423399_Kernel.tar.md5 and load it with Odin_v3.07.zip. I kept getting fail and couldn't get past this step. I think all the ways to root this phone dated before September no longer work... if even then. Kingroot is not an option anymore. I have a Verizon S4 I545 running on 5.0.1. Will give phone to expert tomorrow to see if he can root it. Will keep you posted.
 
#54 joanvoo, Jan 5, 2016
Check out XDA link on top of this page. Method works.
 
#55 Jfalls63, Jan 5, 2016

I had the same problem, in fact, I just fixed it earlier today lol. I was playing around with my Rooted Lollipop S4 OF1, trying to get Xposed installed and a custom recovery. Xposed was a no go. The custom recovery CWM actually worked (well, it loaded into the recovery screen with all the red writing) but then I tried TWRP and it did the exact same thing you described. Couldn't factory reset, couldn't access recovery. I did discover, if you held -Power, Home and Volume Down then chose "restart phone" it would at least boot up and was usuable. Verizons Software Repair Assistant didn't work for me, failed THREE times with 3 different cables. I ended up using Kies and that worked...wiped it and reinstalled the Stock Rom. I used "system app remover pro" and removed all kinds of bloatware and system files...it runs great now! Fast, and only a hair over 2Gb on internal storage now. Only thing left to do is try to find a way to make an exact image of the phone so if I FUBAR it again, I can recover quick, WITHOUT having to reinstall the entire stock ROM again. I know Titanium Backup is decent for backing up, but the restore takes FOREVER! Plus, I would love to have am image so everything is identical to how I had it...settings, ringtones, etc. Here's my storage after I removed the garbage bloatware. The 2 screens hots of my apps are the only things I have on the phone :)
Screenshot_2016-01-20-20-38-35.png
Screenshot_2016-01-20-20-46-47.png Screenshot_2016-01-20-20-46-52.png
 
#56 Brianp48093, Jan 20, 2016 Last edited: Jan 20, 2016
I've tried a few ways to root my phone but haven't been successful. I'm probably doing something wrong so it would help if someone can provide a step-by-step tutorial. My Verizon I545 is running Lollipop. Plus, it would be nice if I could get an english language version of KingRoot.
 
#57 eelstrebor, Jan 22, 2016
http://forum.xda-developers.com/galaxy-s4-verizon/general/root-of1-t3249971

Only working root method I have found that works. I also liked the fact that Wondershare Mobile Go doesn't install its own Super User. Steps in guide are easy to follow and understand. I suggest you read the whole thread before you try it to see what problems others have had and solutions to them. Kingroot works with the kernel swap but it installs Kinguser and would rather avoid that if possible. Good luck.
 
#58 Jfalls63, Jan 22, 2016
TWRP would NOT work for me. Neither would Xposed (I know Xposed isn't a recovery, I'm just sayin.) CWM worked for me (at least for the 5 minutes I used it before reinstalling the Stock ROM. Haven't tried it again) Everything I've read says custom recoveries will NOT work on the I545 with Lolipop and locked bootloader
 
#59 Brianp48093, Jan 22, 2016
I second that. Wondershare mobile go worked like a charm for me.
 
#60 Brianp48093, Jan 22, 2016
wonders hare wouldn't work for me I did the kernel swap back to oc1 then used kingroot apk after that yes kingroot does install king user but you can use super sum apk and remove king user and install superuser with the click of a button worked great for me
 
#61 Brandon79, Jan 22, 2016
Ok. Trying to root a PrePaid. I545PPVRUAOH7. King Root 4.8 was a "No Go" . The pop ups here are insane bytheway. I think the I545PPVRUAOH7 build is not friendly. Don't want to trip Kies.
 
#62 bltserv, Jan 23, 2016
It's a new build. Not sure if there is a roll back I can do and Root . Phone is a new S4. Wallyworld. $200. Outright. No plan.
Great phone. Thought it was unlocked too.
 
#63 bltserv, Jan 23, 2016 Last edited: Jan 23, 2016
You had the i545pp,Verizon prepaid OH7,correct? And you flashed the OC1 kernel from the XDA link then used Kingroot? Are you still on the OC1 kernel or did you find and flash back to OH7?
 
#64 Jfalls63, Jan 23, 2016
yes correct I have i545PP on verizon prepaid and yes I flashed the OC1 kernel from XDA and rooted with kingroot beta apk it said no root availible in the app but I hit root button and it rooted took about 45 seconds and then I installed supersume apk got rid of King user you can also find a link to that on XDA I think . As far as kernel I'm still on the OC1 kernel no problems that I have noticed . Knox is still at 0x30 so I think it is not tripped but when I turn my phone on it does say custom with an unlocked padlock before verizon screen comes on in download mode it says custom system also.when I first flashed oc1 kernel it kept popping up unauthorized actions have been noticed reboot to correct this problem but I froze some stuff in titanium backup and stopped that I'll look and see what I froze and post.OK I froze SDM1.0, Security log agent ,and all the Knox stuff and that should take care of unauthorized actions I belive just SDM1.0 will take care of the unauthorized actions popup.
 
#65 Brandon79, Jan 24, 2016 Last edited: Jan 24, 2016
Thanks. That will let folks know that the prepaid version can be rooted.
 
#66 Jfalls63, Jan 24, 2016
OK going to try this on my I545PP today. Looks like the OC1 Kernel trick makes sense. And the Verizon Software Assistant should bring me back if I crash and burn. Which Kingroot ? 4.8 looks the latest. Dated 1/21/16. I have rooted another S4 with Kingroot before. My Sprint version. Its easy to get all the Kingroot SU and Chinese files out. The question I have is where can we find the OH7 original file ? And will it go back on and what gets tripped ? I would prefer to keep my KNOX as virgin as possible. Good to hear it is being done. Will update after I try it later.
 
#67 bltserv, Jan 25, 2016
as far as the OH7 original file I have no idea I couldn't find it anywhere ,what gets tripped I'm not sure either all I can tell you is my Knox counter still says 0x30.but I do have the screen that comes up when I power on the phone that says custom with an unlocked icon in settings about phone it says custom so if you want to able to return to original factory conditions it may be a problem.
 
#68 Brandon79, Jan 25, 2016
Good to hear Root can be done on this S4 Variant. Thanks much ! Which Kingroot did you use ? Did Kingroot hang or did it show success ? I looked hard for that OH7 load file too. It will turn up in time.
 
#69 bltserv, Jan 25, 2016
I don't have the pp version but I also looked for the firmware and couldn't find it either. I was curious if the Verizon Software Update and Repair Tool would work on the prepaid version. Triangle Away should take care of the Custom and open padlock and reset the flash count. It's a paid app though.
 
#70 Jfalls63, Jan 25, 2016
kingroot I used was 4.6.7 so 4.8 should work, but also when I used kingroot it said root wasn't availible but I hit the root button and it rooted it didn't hang on the OC1 kernel but did on OH7 my phone came with hope this helps
 
#71 Brandon79, Jan 25, 2016
So looks good. Kingroot 4.8 & the OC1 boot file. Same here. You had to hit the "try again" on Kingroot. Did it in a few seconds. The patch/batch file that removes KingSU and installs SuperSU works nicely. Looks like it rips all the Chinese crap files too. You need the emulator and a little command line skill. Newbies will get hung up there. Now to turn off the security notification. Other than Custom in the Status. All looks good. Knox looks fine. Testing all my functionality. Seems fine. Nice clean rooted S4. Took about 1/2 an hour of real work.
 
#72 bltserv, Jan 26, 2016
Used Titanium to freeze Security Log Agent. No more notifications. Knox looks intact. Just the boot file checksum is different. Now to find the OH7 boot file and see if it takes it back to normal and rooted? But for now it's passing all the tests with flying colors.
 
#73 bltserv, Jan 26, 2016
Kernel dates changed from 9/7/15 to 3/30/15 in "About Phone". I cant find any "Bugs" whatsoever . So looks like a Stable and "Clean Root". Just got to make sure OTA updates don't sneak up on me. I think I have them blocked good enough for now.
 
#74 bltserv, Jan 26, 2016
if security log agent fixed the unauthorized notification then I believe SDM will block OTA updates anyway in settings about phone I don't even have the option to check for updates anymore if SDM doesn't stop it then I can only suggest maybe some of the Knox stuff but I don't believe that has anything to do with OTA updates but I'm glad to hear your rooted and everything is working well . OK just checked and it is SDM 1.0 that removes the update option so I hope that will block all the future updates
 
#75 Brandon79, Jan 26, 2016