Samsung Epic 4G Touch Forum

Support How to STOP galaxy from automatically turning on and connecting to WiFi?

I think this may have started since the last system update, but my galaxy SII now auto-connects to any WiFi network in range. This is incredibly frustrating because it drains the battery like crazy.

The other night, for instance, I had a fully charged battery before I went to bed (I had the WiFi off), but the next morning the WiFi had turned on automatically and my battery was at around 50%. Very frustrating.

I read in another forum post that "forgetting" networks will stop the phone from auto-connecting, but that's not an option for me because the security keys for the networks I use sometimes are long and impossible to remember.

How can I STOP the phone from automatically turning on the WiFi?
 

Related:

#1 CellularGuy, Feb 12, 2013
My wife's S2 has the same problem, does anyone know what the fix is?
 
#2 mortalic, Feb 12, 2013
Go to Menu - Settings - More Settings - Mobile Networks - Connection Optimizer and uncheck Sprint Connection Optimizer.

I had the same problem and finally found the solution on one of the forums.
 
#3 alb, Feb 12, 2013
That worked great, thanks.
 
#4 mortalic, Feb 12, 2013
thank you!
 
#5 CellularGuy, Feb 13, 2013
I'm having the same problem but I'm not seeing the "more settings/mobile networks " etc.....how do I find this?
 
#6 slowrunner262, Feb 16, 2013
Someone really needs to make a sticky, same question seems to be asked this whole week.
 
#7 Method760, Feb 16, 2013
Menu>Settings>Under Wireless and Networks choose More>Mobile Networks>Sprint Connections Optimizer>Uncheck the box for it.
 
#8 Method760, Feb 16, 2013
I was going nuts since this recent HORRIBLE system wifi update. I want complete control. Now I have it back.

THANK YOU
 
#9 afsound, Feb 19, 2013
It could be the Connections Optimizer. Go to Settings>More>Mobile Networks>Connections Optimizer. Uncheck the box and see if that helps out.
 
#10 alanzer, Feb 23, 2013
^^^Yes that will fix it and its answer and I think the previous 3 posts...
 
#11 Method760, Feb 23, 2013
Merged into existing update thread.
 
#12 DragonSlayer95, Feb 23, 2013
Thanks so much, this was soooooo annoying. Why did Sprint need to hide this so deep?
 
#13 grcswoosh, Apr 17, 2013
My guess is that they want to make you use wireless and relieve traffic on their mobile network whenever possible. Even though they say we have unlimited data usage. They always have random 'tips' on their site saying that using wifi helps save battery.

I personally find it annoying that they want to choose when we use certain things. It should be up to the user, not them.
 
#14 alanzer, Apr 17, 2013
Using wifi does save battery compared to using 4G.
But they want people to use as little data as possible. Which is understandable, but annoying at the same time.
 
#15 iTzKPanda, Apr 17, 2013
ladies and gentleman using my gs3 and disabling the connections optimizer is not working. Wifi keeps turning on. I also suspect that providers are trying to get consumers to utilize their own wifi connection as opposed to provider data connections.

Is anybody aware of an app that takes care of this? I need to disable wifi and I don't want to turn it on. It's draining my battery.
 
#16 Zinja, May 21, 2013
I helped a friend with a S3 disable his Connections Optimizer and it worked. You might try clearing your cache prior to booting the phone, then go disable it. My S2 works great with the Optimizer disabled, so I don't know of any apps at the moment.

Did the S3 have any kind of update recently? Maybe Sprint is trying to force people to use their annoying Optimizer. Which would seal their fate upon my contract completion in a couple months.
 
#17 alanzer, May 21, 2013
I have cleared cache in internet settings. is this what you are referring to?

are there any other caches is that I can clear?

I have been processing some updates but I'm not sure when exactly I started having this problem it's been a couple months. since I am using a sprint airave to boost my connection I don't need wifi connection on. but it keeps turning on.

I will advise the thread how this fix worked.
 
#18 Zinja, May 21, 2013
Wifi turned on again.

I am also using Snapdragon battery guru. I'm wondering if it is doing this for me.
 
#19 Zinja, May 21, 2013
You can download DS Battery Saver from the play store. It turns off wi-fi for you when you turn your phone off as well as put it into deep sleep so not much battery drain should occur while the screen isn't on.
 
#20 iTzKPanda, May 22, 2013
I'm going to download DS battery saver. Will this affect my ability to make and get phone calls? Do you have any tips to get through that aspect?
 
#21 Zinja, May 22, 2013
No, you should be able to receive phone calls and texts like normal. You just might receive notifications later than you normally would.

And within the app, you can add apps to a white list that prevents the app from putting it into deep sleep. :)
 
#22 iTzKPanda, May 22, 2013
After I uninstalled SnapDragon Battery Guru, my WiFi has stayed off all morning. First time in months.

I have installed DS Battery Saver, going to give the free app a shot for a while.

Poster, you mention an ability to customize. I take it you have the paid version?:thinking:
 
#23 Zinja, May 22, 2013
I do not have Sprint. I have Credo. Will this still work?
 
#24 beledi, May 24, 2013
Oh wow !! It worked on my brand new Samsung Galaxy Victory too. Thanks for sharing the knowledge.
 
#25 dr.faramroze, Jul 25, 2013