Home Forum

Support M8 Android TV Box - Sound Gone


I have today received my Android M8 TV box and been going through the regular set upstuff. However, Ive somehow managed to loose the sound. I've been through all settings but cannot seem to get the sound back on (and I have tried the mute & volume buttons on the TV box remote).

Once I switch the TV back to TV the sound is there!

Can anybody please help, it is so frustrsting!




#1 John Irvine, Feb 4, 2015
i have the same problem. do you, in any way, found the answers already? and yes this is so frustrating. i cannot watch anything
#2 metsmdc, Mar 31, 2015
i have the same problem. do you, in any way, found the answers already? and yes this is so frustrating. i cannot watch anything
#3 metsmdc, Mar 31, 2015
Do you get the sound when going through the Kodi menu?, check to see of you have sound when going through selections in the os, also the hdmi cables that come with the box are not the greatest, try another cable.
#4 goggles, Mar 31, 2015
#5 metsmdc, Mar 31, 2015
No, there's no sound in kodi or in the web. and okay, im gonna try another cable
#6 metsmdc, Mar 31, 2015
If sound is still a no go, go into your display settings and turn off hdmi auto detect and select your setup manually
#7 goggles, Apr 1, 2015
Go to setting, wifi, advanced (tab),
Scroll down to 'digital audio auto-detection' and turn that off.
meets with the next item down...
digital audio output.

I have hdmi but sound goes through optical cable so my set choice is
'SPDIF pass though'

Oh btw last comment said turn off hdmi auto detection...don't because mine is on and it's working.

Good luck
#8 Bradford23, Apr 23, 2015

Hello I'm having the same problem with the sound it's not working at all could you help me somehow fix the problem?
#9 victoriawhite, May 3, 2015
Hi anyone having issues with no sound with m8 box. running kodi 14.0. hdmi cable. ethernet cable on virgin broadband. have i missed something on set up ?. volume up on hand set, where is the volume on the kodi setting i cant see one. any help please. cadilac69
#10 cadilac69, May 8, 2015
Same problem here. It was working fine last night and now no sound at all.
#11 Davyboysteel, May 19, 2015
Hi, I had the same issue and my supplier has informed me that it has failed a software update and requires the firmware resetting.
#12 Davyboysteel, May 19, 2015
ok, open Kodi, goto system, settings,and up to video, at the bottom of settings change to advanced settings, then go to acceleration. there change hardware acceleration to software. if that doesn't work, change back o hardware acceleration and uncheck all 3 options below it. That worked me, and utube has a vidio to show to you also. Hope this helps!
#13 roofdog, May 23, 2015 Last edited: May 23, 2015
Thanks for the advice however, I took it back to my supplier and he re flashed it for me. All working once again.
#14 Davyboysteel, May 25, 2015
Had this problem ever since 'upgrading' to the M8. I know what is happening but don't know how to correct it. It is something to do with the M8 over HDMI cable. For some reason it changes the HDMI sound setting on the TV to OFF. You can check this by simply going into sound settings on your TV and check it out.

It is usually connected to some minor channel or APP change that does not work properly resulting in a signal being sent from the M8 to the TV to set HDMI sound to OFF. If you use composite or SPDIF this problem does not happen. I'm assuming it is some software glitch on M8.
#15 pdoth, Oct 25, 2015
Same problem on new m8s/s812. Can't reach vendor. Any ideas/help would be most appreciated. kodi 15.2, android 4.4. There is no sound out of the box, it's not just kodi.
#16 LID, Nov 24, 2015
This worked for me, a pain having to do it every time though, but it worked. whilst playing a film or TV program, pull the HDMI plug out of the droid player, then plug it back in. Not saying this is the answer but worth a try. Good luck.
#17 pozzydrive, Nov 25, 2015
Ok, got it working... don't ask me how or what I did, but it is working. I believe it has something to do with a connection out of the box. I tried different connection combinations to isolate the problem, and when I connected the box back I had sound (?)... So, I don't think the settings have anything to do with anything, if you just plugged your stuff in...
But, fyi, my settings:
  • On display tab: HDMI auto-detection
  • On Advanced tab: digital audio auto-detection, digital audio output (greyed out) HDMI passthrough
  • On settings tab: Sound: set to max
Good luck.
#18 LID, Nov 25, 2015
Glad you got it working.
#19 pozzydrive, Nov 26, 2015
I have the same or simular problem.

Start watching a film then the sound goes off every 20 secs then just goes.

Any help please.

MGII box
#20 Mark Abrook, Dec 2, 2015
Arrrrggggggggggghhhhhh it's gone again. Tried all suggestions above and still not working . Help!!!
#21 Davyboysteel, Dec 10, 2015
Iv got my money back as nothing worked, going for a different box this time.
#22 Mark Abrook, Dec 10, 2015
Tried everything above, no joy. The only way around is a reset. Ensure that you have backed up and saved to an external SD card prior to resetting.
#23 Davyboysteel, Dec 15, 2015
Been having the same problems. I think pdoth's response above (#15) is on the right track as it appears to be the interface between the tv and android box over hdmi.
I dont have a long term fix but you can stop it happening by clearing the kodi cache and stopping the app in setting;advanced;apps;kodi then click clear cache and stop the app. When you restart kodi this fix works about 80% of the time.
A much simpler work around is to start your movie in kodi, pause it then switch your tv off then on. restart your movie and the sound is back!
On some tv's it must be switched off at the wall.
Hope this work around helps.
#24 Peter Gallon, Dec 15, 2015
Hey guys,

I had the same problem on my M8S. I observed that each time I fired up a 5.1 movie my sound went down on whole system, not only in Kodi. Everything was fine with 2.0 movies. What worked for me (so far) was to navigate to kodi audio settings and set Number of channels to 2.0. (that is NOT number of speakers, you still get 5.1 with this setting).

lemme know if it works for you
#25 tru21, Dec 27, 2015