HTC Droid Eris Forum

Support MMS pictures not downloading

I did a forum search and saw this question asked but didn't see any answers so I'm posting this again hoping someone can help with this most frustrating problem I'm having with MMS.

At least 60% of the time when someone sends me a picture message I will get the option to download the picture. When I click "download" the box turns to grey text that says "downloading" but it never downloads, just goes back to the download button. Sometimes I will get a message in my notifications panel saying "Message not downloaded". This happens in both the stock messages program as well as Handcent.

Does anyone else have this problem and a suggestion on how to fix it? This is a huge issue for me.

Thanks in advance.

 

Related:

#1 AmbientBlu, Nov 26, 2009
Make sure you have Mobile Network (connected to the Internet) turned on. It won't download them otherwise.
 
#2 adrenalinerush12, Nov 27, 2009
Thanks for the suggestion, but that was one of the first things I checked. I was on the phone with VZW tech support (oxymoron?) last night and not only was the tech not able to fix my problem, but the steps he had me go through (hard reset, restore to factory settings) for some unknown reason ended up rendering my phone unable to receive SMS in addition to the MMS. I told him to deactivate the phone and reactivate my old Chocolate 3.

Ten minutes later I called CS, had them reactivate it (my bill is going to be so prorated this cycle) and now it seems to be working properly.

So, while my issue seems to be solved (for now) I unfortunately cannot be of help to anyone else to may be having the same problem, because I don't know what fixed it.
 
#3 AmbientBlu, Nov 27, 2009
I noticed the same problem with downloading picture messages. My old LG Dare (dumbphone) had no problem getting picture messages, and sending them. This phone is a pain in the ass when it comes to picture messages. I usually use Handcent.
 
#4 J.R., Nov 28, 2009
I've been having the same problem - no mms - used handcent, used default app - still no mms.

This is weird - anyone have a solution?
 
#5 falltime, Dec 7, 2009
Nosing around the Handcent forums, I noticed quite a few people complaining of this. This was a suggestion offered. Turn off wi-fi. According to the forum, for some reason the phone (and I say "phone" rather than "Handcent" because it happened with the stock program too) seems unable to download pictures/video while wi-fi is enabled.

I can neither confirm nor deny this, though I admit I have Wi-Fi turned off, simply because I won't use it often. I don't want to turn it back on and risk screwing up any of my settings (if it ain't broke, don't fix it), but perhaps those of you still experiencing the issue can give it a shot.
 
#6 AmbientBlu, Dec 7, 2009
I noticed that when I can't get a picture message to download, if I move to an area with better reception, usually 3 or 4 bars, the message will download.
 
#7 J.R., Dec 7, 2009
Sometimes a MMS will not download if it is coming from a different carrier(t-mobile and at&t have been known)
 
#8 bigdroid, Dec 7, 2009
You need to download an app from the marketplace called save mms then you will be able to save pictures sent to you from anyone.
 
#9 Crobertson2345, Dec 8, 2009
I have noticed this problem starting today... The past few days I have not had ANY problem downloading MMS/Picture Messages, and all of a sudden today I can't download any multimedia/pic messages... I've tried using handcent and the stock messaging options (both of which worked fine yesterday)... I tried turning off wi-fi... I've tried every option other than calling tech support yet. I've checked my settings... All's as it should be... I didn't do anything different today than what I did yesterday. Anyone know if this is a general new issue/bug today or something? It HAD been working fine before...
 
#10 antnyp85, Dec 9, 2009
I didn't need this app and was able to download/view/save pic messages the past few days using Handcent and the Stock Messaging...
 
#11 antnyp85, Dec 9, 2009
did anyone ever get a fix for this..... i just started having the same issue..... and it dosent matter what the carrier is.... my wife has the same phone and same account and i cant receive pictures from her, i can send them to anyone, but cannot receive pictures oir audio or video
 
#12 jebar77, Jan 21, 2010
i also downloaded handcent and it didnt make any diffrence still wont download attachments
 
#13 jebar77, Jan 21, 2010
I did everything tech support wanted me to do (VZW Tech Support) and they couldn't figure out the problem, so they gave me a new phone. Now all's good :) lol
 
#14 antnyp85, Jan 22, 2010
they offered me a new phone also, but its not a new phone it's a like new phone..... and i think i m good with getting someone elses crap. ill wait for the next update to see if it fixes it.
 
#15 jebar77, Jan 22, 2010
I received a new phone after "stumping" tech support too! Two weeks later...SAME GOD FORSAKEN PROBLEM! They better fix this soon or I will just start using my dumbphone again!! Less stress!!! :mad:
 
#16 jamie311, Jan 25, 2010
I always had this problem and turning on mobile network fixed it all for me.
 
#17 smacky, Jan 25, 2010
On mine it does it with WiFi, 3g, 1x...does not matter.
 
#18 jamie311, Jan 26, 2010
This fixed it for me too.
 
#19 Peaser, Jan 26, 2010
Please explain what setting are you turning on exactly?

thanks
 
#20 joey3002, Jan 26, 2010
I've noticed this issue from day one with my sprint hero. It is really pissing me off now. Sometimes I get them sometimes it is in a slide show sometimes nothing. Very frustrating...
 
#21 PrO1210, Jan 27, 2010
do you mean "mobile network" or "always on mobile"? or both??
 
#22 MrGreen13, Jan 27, 2010
always on shouldnt matter, gotta have mobile network though
 
#23 Caddyman, Jan 27, 2010
I have both on and I still get unsuccessful downloads.
 
#24 PrO1210, Jan 27, 2010
im still having this problem also.... anyone know when the next update is comming.... seems this all happened after the last update.
 
#25 jebar77, Feb 6, 2010