Motorola Moto G with 4G LTE (1st Gen) Forum

moto G4 keeps saying I have voice mail when I do not

My Moto G4 keeps saying I have voice mail when I do not. This is irritating to say the least as I might ignore a real and important one. Any ideas?

Harry
 

Related:

#1 harryt, Dec 4, 2017
Have I done something wrong? No one is replying to my question.

Harry
 
#2 harryt, Dec 5, 2017 at 4:46 AM
Clearing the Phone app cache might help.

Clear an apps cache:
1. Go to Settings -> Apps
2. Tap the Phone app
3. Tap Storage (if Clear Cache isn't already there)
4. Tap Clear Cache

If you have a voicemail app clear its cache also.
 
#3 kate, Dec 5, 2017 at 9:43 AM
And if that doesn't do it did the sim card come from a previous phone? There is storage on sim cards try clearing it.
 
#4 today, Dec 5, 2017 at 11:20 AM
Thanks Kate and Today, I have cleared the Cache, there was no voicemail app but there was also no message when I switched on again so we shall see if one returns. If not, fantastic. I am pretty sure the sim was new (giff gaff) but I have messed around with sims and various phones (I keep spare phones in two vehicles and also a tracker in one of them) so I can not be sure. I will try looking at the storage on the sim if this fails. Thanks again,

Harry
 
#5 harryt, Dec 5, 2017 at 1:25 PM
Well, the voicemail flag came back this morning. So now, how do I clear the storage on the SIM card?

Why am I described as a "lurker" I have not lurked in years.

Harry
 
#6 harryt, Dec 6, 2017 at 6:36 AM
The description is based on post count, looks like that was your 10th post so it changed.

I don't believe any voicemail data is stored on the SIM card, only carrier account info.

Do you maybe have a saved voicemail that's causing the notification? Tried having someone leave a voicemail then listen to it? Disable then enable voicemail? (might have to redo settings for that one)

Not sure what else it could be.
 
#7 kate, Dec 6, 2017 at 9:44 AM
It gets worse! I left myself a message on voicemail (as advised) using my wife's phone. Then, when I dialled 901 to hear it on my phone there was nothing there; weird! I tried it again but still no message. I went hunting and found SIM toolkit but that showed me nothing helpful.

So; how do I disable then enable voicemail?

Now I am a newbie. I prefer that to lurker.

Harry
 
#8 harryt, Dec 6, 2017 at 3:51 PM
Depends on your carrier, they all have different systems. Some might not even have an option to disable it.

But if you also can't access messages I'd guess something bigger is wrong, might need to have their support look into it.
 
#9 kate, Dec 6, 2017 at 5:31 PM
Thanks Kate, Just to be sure, I tried leaving myself another message (longer this time) this morning with the same result. I'll see what the GiffGaff forum has to say on the subject. Thanks again.

Harry
 
#10 harryt, Dec 7, 2017 at 4:37 AM
Thanks Kate and all, Seems GiffGaff have a different voicemail number from O2 with whom I had the phone originally, it seems (I had forgotten that). That number is 443 not 901 as it is with O2. My two messages came up fine on that number but it remains to be seen if I get the other (nuisance) notification still. If it does then I shall enquire of O2, I'll keep you posted as to the eventual solution. Thanks again.

Harry
 
#11 harryt, Dec 7, 2017 at 4:58 AM