Samsung Galaxy S3 Forum

Support My devices says "modified"??

I'm on 3UK network and today I went to search for an OTA update as I've done many times before. I got the following error message; "Your device has been modified. Software updates are not available".

I've went into Settings > About device > Status > Device status says "modified".

I have not rooted this phone and it has never been out of my possession.

I'm on 4.1.2 with Baseband version I9300NELK2

Any idea why this has happened? :thinking:
 

Related:

#1 newrybhoy, Apr 26, 2013
Hello newrybhoy. I does sound like at one time your device may have had a root exploit. Is it a refurbished S3 rather than brand new? Did you acquire it from a carrier/provider retail outlet/store, or from some other source such as Amazon or Ebay, etc?

If the device was ever rooted and had any of the systems applications removed, which includes bloatware apps like Facebook that come preinstalled, you cannot get OTA updates as your phone's system won't match the update anymore and so it won't install.
 
#2 Frisco, Apr 26, 2013
The phone was got from 3UK themselves on contact last year, brand new. To my knowledge, no bloatware has ever been removed, all pre-installed apps still seem to be there.

Funny thing is, my friend's S3 was rooted, he got a firmware update this morning via Kies. After this update, his phone now says "Device status - Normal" i.e. not rooted any more and he can now search for updates OTA whereby he couldn't do this yesterday as his phone was still rooted.

I've fired off an email to 3UK to see if they can help, still awaiting their reply
 
#3 newrybhoy, Apr 26, 2013
Never installed a custom kernel or anything?
 
#4 Yatezy, Apr 26, 2013
Do you have Tasker and more to the point, Secure Settings? If you have SS installed this will cause the change. Simply uninstall, update, reinstall.
 
#5 XplosiV, Apr 26, 2013
Don't know anything about customer kernels or rooting etc

Are these 3rd party apps? If so, no

I'm lost
 
#6 newrybhoy, Apr 26, 2013
Yeah, they would be from the play store.

Have you downloaded any hardware controlling apps, like to control the LED or other hardware?
 
#7 XplosiV, Apr 26, 2013
No, definitely not :(
 
#8 newrybhoy, Apr 26, 2013
Check your flash counter. That should show if anything at all has been flashed on to your phone. Turn it off and hold Power + Volume Down + Home then when it gives you a warning screen continue (I think it's the volume up button). The counter is in the upper left corner and should read zero. If it reads 1 or higher then something has been flashed to the phone somewhere along the lines.

Personally I don't how much to read into the phone status in the options menu since I've had it read 'normal' for me even though I'm running a custom ROM and kernel!
 
#9 Yatezy, Apr 29, 2013
Lol yeah mine says normal and im on a custom rom and kernel :)
 
#10 funkylogik, Apr 29, 2013
Hi, I had this exact same problem today. I tried to search for updates on my Galaxy S3 (I am also on 3 UK network) and got the same error message"Your device has been modified. Software updates are not available" After reading this post my first thought was that I had uninstalled Play Magazines a week earlier, although it was an update to a pre-installed app. So I went onto the Play Store, updated the app again and for a second time tried to search for updates. Same result. I then however, restarted the phone and problem solved :) So perhaps you have done something similar to me and that's how you fix it. Hope this helps :D
 
#11 Jmitchell05m1, Jun 23, 2013
so is there a fix for this
 
#12 dyingjedi, Sep 30, 2013
Had the same message and after googling for a solution I tried this one.

If you have installed a memory card in the slot beside the SIM? If so, unmount and remove it.

Turn phone off, wait a few seconds then boot into safe mode by
holding down the volume key then turn on - keep the volume key held down and when phone starts it should say "Safe Mode" in the bottom left corner. Release volume key.
Then go to settings>About Device>Software Update>Check for updates.

When done, turn off and start phone as normal.

Worked for some and for me. I used wifi only to save on data plan costs although when I did it there were no updates available.

Hope it helps!
 
#13 Coliboy, Sep 30, 2013
I also has a experience that my device was did not update by ota
I suggest you a method to change the device status from custom to official
That method was to reset the android this was complete by power off your phone and just press power button volume up button and center key of any samsung device screen will start up and select wipe data by volume keys and press power key then select ' yes all delete ' automatically phone reboot and then go to setting - about phone - status in last device staus was change to custom to official

And then you update your android by ota

It is a easy step that you follow
 
#14 mayank malik, May 17, 2015