Home Forum

Support Nexus 7 Dead.....won't charge! :-(

So posted my first post on here yesterday.

Got home and was playing a bit of Dead Trigger, noticed battery low so stopped playing and was just checking some email when the battery finally died and unit powered down.

No problem just plug it in to charge......nope wont charge. Left t for several hours and no charge and wont switch on. Did you check it was plugged in i hear you say! Yes is the answer. I plugged into a different socket, switched cables, even tried with my phone charger which is rated simillar, no joy.:thinking:

Real shame as i was loving it. Unless anyone has any ideas I will be returning it tonight to my local Currys/PCWorld store?



#1 damiencannell, Aug 3, 2012
First of ALL you should never run the battery all the way down!
Second, try plugging into a different USB power source like a PC to see if is drawing power, if you check the usb device in the device manager you can see how much current the port is drawing.
Third, when plugged into a pc, see if you can access the memory in the n7.
#2 JanComputerman, Aug 3, 2012
Hi Jan

Thanks for the reply, out of interest why should you never let the battery fun flat entirely??

Already tried your suggestion with the PC, It doesn't appear to be drawing anything and also cant access it, doesn't even pick it up as an external drive.

Its been treated with loving care since purchased so i'm a bit nonplussed!

#3 damiencannell, Aug 3, 2012
Hi D

The lithium cell changes physical size as it charges and discharges and discharging it fully makes it expand and contract more which ends up physically damaging the plates of the cell. All batteries typically have something size change occur when they charge and discharge and as you can imagine the deeper you discharge the more microscopic damage you do to the plates that can shorten the life cycle of the cell.

Make sure your USB connector is clean also, even a small speck of dirt can affect the contact quality. It may be that the charge circuit has disconnected the cell due to low voltage and you may also still be powered up draining it further. You might try power button pressing while charging .... needs a reset maybe. I have a XOVision Xtab7 and had to press the reset button last week to get it running, I wonder if the N7 has a reset somewhere. When run down the charge circuit will sometimes limit how fast it will charge the cell and if it is still running it may not charge fast enough to keep up, getting it to shut off would be critical so try keeping it plugged in to the charger for several hours. Good luck, you must be having N7 withdrawal symptoms by now!
#4 JanComputerman, Aug 3, 2012
Last night I had an issue like this. The tablet turned off because low battery, and when I plugged it in, nothing happened. Then I put my ear up to the tablet and there was a slight buzzing that went for about 15 seconds. Then it stopped and the charging screen came up. The only problem was that it took HOURS to charge. Like at least 7 hours on the sock cable/charger
#5 DanielM426, Aug 4, 2012
It definitely is true that frequent top up charges are preferable for Li-Pol batteries, rather than full discharges.

Although it should be noted that there is a big difference between the N7 turning off due to low charge and actually depleting the battery. The latter is much worse for the life of the battery, but your N7 will shut off before the battery is fully depleted.

So, unless something isn't working as intended, letting your N7's charge reach 0% should not kill it. Think of it like a fuel gauge on a car, you've still got a bit of leeway even when it reads empty.
#6 Xyro, Aug 4, 2012
That would depend upon how much leeway is Designed into the circuit that charges the cell and the N7 circuitry. If the cell regulator gets down to minimum and disconnects itself from the N7 to prevent too deep a discharge then you may have problems charging it back up again because the N7 is powered down and the charge regulator often limits low voltage charging rates to a fraction of normal requiring hours of trickle charging before allowing a normal charge rate.
Sounds like you should leave it charging for several hours and it may recover.
#7 JanComputerman, Aug 4, 2012
I figured that there was some sort of circuit protection going on. The tablet took ages to charge and in the morning I unplugged it around 80%. I then plugged it in again and the last 20% charged at a normal rate. I wish that I had BMW open to see trickle vs. full rate charging.
#8 DanielM426, Aug 4, 2012
Thanks for the replies guys. I left mine plugged in all night and it charged up to 50%. I then was able to switch it on and charges the remainder.

I'm not a technical person but it seems from my experience and others that there is some sort of safety feature on the unit that only allows trickle charging if the battery is fully run down.

I'm just glad mine still works and I don't have to return it.


#9 damiencannell, Aug 5, 2012
Mine did the same, was playing Mini Motor Racing and the N7 went off with some buzzing a static like display on the screen. Started charging very slowly until I switched it on-off and back on.

No harm done I reckon. There's no way that phones and tablets wouldn't have some safety feature for batteries running down. I've lost count of the amount of times I've run batteries down.
#10 MartinS, Aug 5, 2012
Sounds like the cpu was still running at or near 100% while trying to charge. (i.e. your game was still running?)
#11 colchiro, Aug 5, 2012
This happened to me. Completely dead, would not turn on or show up on USB on my laptop. I fixed by holding the power for a long time at least 30 seconds. Eventually it come on and was charged to 44%. Just make sure to hold the power for as long as it takes. So glad thought it was done and I had to deal with shipping back. Hope this helps.
#12 shoebox07, Aug 8, 2012
Had the same issue the OP did and this was the solution to my problem. Strange that the unit took so long to power on when the battery is completely depleted versus when it has a charge.
#13 swantonbomboy, Aug 9, 2012
I too had a charging problem. After all night charging (I thought) it was about dead at 3% left. Saw a post about Non-Certified cables may not charge the Nexus 7s. So I un-wrapped my never used, SHORT stock cable and noticed the tabs on one side of the micro end seem to protrude more than my other micro cables, probably holding in better BUT the cable may be slightly different in other ways...I plugged it in and my Nexus is charging faster than it did before.

That's all I know, using the Stock Nexus 7 USB cable SOLVED my charging issues. I read about other issues as well, possible defective chargers, charging chips etc. I hope the cable issue is the main culprit here because it is easy to fix. I DO think other micro USB cables will charge, they must, I have used 4 different cables since I had my N7 for over two weeks now, but the stock ASUS USB cable shipped with the N7 is charging my N7 much faster than what I have seen before.

#14 Mr Geek, Aug 10, 2012
I had this happen to me!! My tablet hadn't been on the charging cord in a while. This morning, it wouldn't power on at all, not the normal way. Did some googling and tried the "30 second press." That worked. After it powered up, I checked the battery, which was at 46%. I am not sure what happened, but some say that this happens after intensive gameplaying.
#15 CrackBaby, Aug 12, 2012
Sounds like SOD... sleep of death. I've seen it on several CyanogenMod roms.

the fix is always to reset it by holding down the power button or power + home button for about 30 seconds until it powers off and back on.
#16 colchiro, Aug 12, 2012
Similar problem with my 7. Made a post about it....but I haven't been able to get mine back on.
#17 DerkMc, Aug 12, 2012
I'd press the power button for at LEAST 30 seconds, then throw it on the stock charger with the stock cable, assuming they are in good condition.

Soooo, what else aren't you telling us? :D
#18 colchiro, Aug 12, 2012
So, I've noticed that if I let by battery run down all the way and then plug it in to charge, it won't charge. I have to plug it in, turn it on (by pushing and holding on to the power button) before it will start to charge again.
If I don't turn it on, it doesn't seem to charge (or at least very slowly). I've charged it all night, just to wake up to a 36 percent battery.
If I don't let it run down all the way, it seems to charge fine.
Is this normal? Should I return the device?
Also, it doesn't seem to charge when I use it while it's plugged in (is this by design?)
#19 metallifan33, Aug 23, 2012
Sure sounds like a lot of other people have had the same experience. I haven't personally left mine to go down to zero yet, so can't verify.
#20 AntimonyER, Aug 23, 2012
Phew! The 30 second power button press worked for me. That's the last time I'll let it fully drain.
#21 Voynix, Aug 25, 2012
God damn this ****ing thing. Some app held a wake lock last night and killed my battery overnight. All the battery stats say is "Android OS" wake lock 14 hours. The device wouldn't power on at all. Thankfully I found this thread and the 30 second power button thing worked for me.

My only gripe with Android is this ****ing wake lock bullshit.
#22 morrty, Aug 31, 2012
I remember when I had the first original dell streak (nightmare) used to empty right down from full to beyond empty, for no reason, had to leave it on charges day or so to spur some life into it. (Soon got shut of it)
Its always butt nipping Time whenever stuff like this happens
#23 cosmicalien, Aug 31, 2012
Similar issue yesterday, except no gaming. Plugged it in with a pretty good charge left, woke up Friday and it wouldn't turn on or respond to any chargers. Finally found the ASUS support number (booklet doesn't have it, website gives you a sort of 404 page). Holding the power button for awhile worked.

Support guy said it was because the n7 got too much of a charge, which doesn't make any sense.
#24 caspian915, Sep 1, 2012
Hi guys!

I have a very similar problem: I've been playing Sims 3 free to play on my Nexus 7, when the battery had only 4% remaining, so I connected it to a Samsung Galaxy S2 stock charger and kept on playing. A while later the tablet went off with some garbled buzzing static, like MartinS described.

I couldn't turn it on for a while, then I connected it to the stock charger (which has an adaptor, as I live in the EU and it's an american socket type charger), then it turned on, but went off again after a couple of minutes with the same garbled static screen. At this point it was still connected to the stock wall charger with the stock USB cable.

I then proceeded to connect it to my laptop with the stock USB cable. Now it has been turned on for at least 10 minutes, but the lock screen still says it's charging, but it's staying at 0%. As soon as I disconnect the USB cable, the tablet powers off normally.

Is it possible that the battery died or should I just wait more for it to charge?
#25 szaszati, Sep 1, 2012