Home Forum

Support No voice navigation option on Google Maps

Hi everyone,

I have the Galaxy Note Edge, and only recently started to use google maps. On google maps, I'm unable to find any voice navigation option. All the threads and support sites I've found on the internet say to press the three dots on the bottom right. I don't see these three dots on my Google Maps, there are only three dots at the top and none of the options that shows is related to voice navigation. I have the latest version installed, and just to be on the safe side I uninstalled and reinstalled it again just now but to no avail.

If someone can help I'd be grateful.

Thank you.
 

Related:

#1 Hellokitty22, Jan 1, 2016
You have to have Voice enabled in the Settings of the phone, it is not in the maps.
right now, my phone is not with me and can't look it up for you, but you are looking in the wrong place.

Easy way to figure out if it is working, touch the Google Voice Microphone icon and see if it responds back to you in english, mine does. it talks to me, as well as displaying what it finds.
 
#2 AZgl1500, Jan 1, 2016
Hi, welcome to Android Forums.

There is a 3 dot menu button at bottom right but you have to be on the actual navigation screen to see it ie. selected your destination and hit the white navigation triangle on the blue background at bottom right. There is a Mute/Unmute tick box and also a Settings option where you can alter the voice level and get a sound test.

Screenshot_2016-01-01-21-22-11.png Screenshot_2016-01-01-21-22-20.png

What also affects the sound level on my HTC M9 is the setting of 'Music & Videos' in Settings-Sound & Notification-Volumes, I think you will have something similar on your Galaxy.
 
#3 tommo47, Jan 1, 2016 Last edited: Jan 1, 2016
Try MapFactor Navigator at the Play $tore.

Free offline voice navigation.

Great little app...
 
#4 steiny180, Jan 1, 2016
Google pay services 8.4.89,Google play store 6.0.5,Google map 9.18.2 if these are not the versions ,update. and disable play voice over Bluetooth.
 
#5 Parayilhussain, Jan 2, 2016
Hi everyone,
Many thanks for the responses.
Azgl1500, where in settings can I change the sound settings? I tried what you said (using the google voice microphone) and it did not respond in voice, so I think the issue is the sound settings. I've disabled play voice over bluetooth but it's still not working.
tommo47, I am on the actual navigation screen, but there still isn't that menu with the 3 dots at the bottom right, and there is no mute/unmute option.
Parayiihussain, I checked all my apps, they are the versions you said all of them.
steiny180, I'm in Pakistan so I don't know how well it'll work in my country. But I'll check it out, thanks. :)

Thank you everyone.
 
#6 Hellokitty22, Jan 3, 2016
Here are some screenshots of Maps on my phone Screenshot_2016-01-03-16-34-05.png
 
#7 Hellokitty22, Jan 3, 2016
I guess you got the perfect answer in above post. Map factor Navigator will surely work for that.
 
#8 EdwardSmith36, Jan 3, 2016
Where is the blue triangle icon which is moving along with you. If this is seeing you while navigation no choice to get voice navigation. and below the map no three dot menu and rout options. You have no navigation button.can you try this enable WiFi ,enable download manager ,disable Android device manager ( enable later) go to settings>>>>> uninstall update in Google play store, by finishing this play update automatically, finished update go to settings>>>>>>>> uninstall update in Google play services when finished this open chrome browser type " Google play services update " search and see in next page play services icon tap on this then shows play store icon tap on this play services will be updated. Then go to settings >>>>>> uninstall update in maps and update from Google play store. then install " GPS status & tool box " from Google play store and allow the app to access your location in settings . Before navigation always go to settings> storage>cached data and tap to clear cache. Now open the GPS app in outdoor see in the circle white dots are changing into green colour as they are fixing your location ,for this a few seconds or minutes will be taken, when your location is fixed open Google map and tap on small round button bottom right this is to fix present location in map, now tap blue round button below and search rout ,getting rout tap on navigation button.( blue triangle) ( I think there will be).and allow the GPS app to run while navigation. Before navigation clear cache.
 
#9 Parayilhussain, Jan 3, 2016
Hello EdwardSmith36, I did download Map factor, but as I mentioned in my post above, I live in Pakistan and Map factor doesn't have many locations for my country.
 
#10 Hellokitty22, Jan 3, 2016
Hello Parayilhussain, thank you for your response. I am unable to find the download manager and the device manager on my phone. Are they apps? I can't find either of them in my apps or settings.
 
#11 Hellokitty22, Jan 3, 2016
Hellokitty22,

Going back to a point raised earlier, does your phone say anything ever? I'm still wondering if you have text-to-speech enabled or if there is some problem with the text-to-speech engine.
 
#12 androidmachine, Jan 3, 2016
Hello kitty, go to settings >storage>apps select all and scroll down through the apps and see " download manager " if it is disabled then tap on this then tap on " enable " button now it is enabled if not seeing the app swipe screen from right to left and see under disabled list. Then. for device manager go to settings> scroll down for " security " tap here and scroll down for "device administrators" and tap on this next page see " Android device manager " opposite this unmark in the box.
 
#13 Parayilhussain, Jan 3, 2016
Hi Hellokitty22.

The screen shot you have posted is the 'Route preview' which is NOT the navigation screen and therefore you won't see the 3 dot menu button at bottom right.

The route preview is when you enter a location in both 'from' and 'to' boxes and use < > at bottom right to manually go through the route turn by turn - this is not GPS navigation.

You will only get the 'navigation' screen if you leave the 'from' box at 'Your location' and enter your destination address in the 'to' box and hit the white arrow.

Google Maps can only 'navigate' you, using GPS, from your current location, hence you will only get voice turn-by-turn and the menu button when on the navigation screen.

Incidentally, voice turn-by-turn has nothing to do with the microphone/voice input.
 
#14 tommo47, Jan 3, 2016 Last edited: Jan 4, 2016
Hi
Im facing the same problem. There is no voice mute or unmute button nor navigation button. Tried all the steps as you mentioned here. TTS is alsp set language is downloaded yet it doesn't show. Uploading screens for reference. .I live in oman. Earlier voice navigation was working when in dubai and India now it doesn't work even on my iPhone too nor in Note II. I guess its the problem with this country service providers.
 
#15 HelloGalax, May 21, 2016
See this may help you
tap on the link below,when the link opens,scroll
down to "what you need to use voice navigation"
tap here,see below the map,enlarge map and check for your place and see the availability of turn by turn navigation.
https://support.google.com/gmm/answer/3273406?hl=en
 
#16 Parayilhussain, May 21, 2016
Thanks for your response. Only a while a ago I realised that voice navigation doesn't work in my country Oman . Despite people complaining to google since 3 years they have not responded nor given the reason why is it banned here. Only in one forum this problem is mentioned. And I wasted my time and energy in this. Thanks once again. God bless
 
#17 HelloGalax, May 21, 2016