Samsung Galaxy S Relay 4G Forum

Support Not Registered on Network

I just got a used Samsung Galaxy S Relay (Tmobile) phone used from someone. I'm trying to get it setup with Straight Talk. I got a SIM card from ST. Activated it. When I tried to make a call, I got the msg "Not Registered on Network." After several calls to ST, they decided it was a faulty SIM card so they sent me a new one. I activated that. Same problem.

ST told me to contact Samsung. Samsung told me the phone probably needed unlocked. I bought an unlock code. However, I cannot seem to enter it. I inserted an active AT&T SIM card but it didn't ask for the code. Instead it worked and I was able to make phone calls out, no problem.

However, the ST SIM still gives me a not registered on network error when I try to call. I have full service bars in my location as well. I've tried full factory reset several times and I have tried calling in several locations.

Please help. This is getting really frustrating.



#1 starmint, Mar 15, 2013
A couple of thoughts based on my limited knowledge:

1) Go to settings -> More settings (under Wireless and network) -> Mobile networks -> Network operators and play around with some of these settings. Try restricting the phone only to T-Mobile or AT&T. Search for other network types. Stuff like that.

2) Does data work at all?

3) I don't believe you need to worry about the unlock code, as the phone shouldn't boot at all with that SIM if it needed unlocking. (Warning: I could be wrong about this.)
#2 cjablonski, Mar 15, 2013
I did adjust the APN settings if that's what you mean. I don't really know how to test the data. I have it connected to Wi-Fi. I thought that if the phone wasn't connecting for calls then it wouldn't connect for data either.
I think you're right and it's already unlocked because I put my friend's ACTIVE AT&T SIM in it and it worked fine. I made phone calls using her number and everything.
#3 starmint, Mar 17, 2013
I think CJ was suggesting you change the network settings. The phone is probably defaulted to T-Mobile's network. With your ST sim card in, go in to network settings and search for the ST network. Then do a soft reset and you should be good to go.
#4 Joe_PDA, Mar 22, 2013
Ends up it was gray listed by Tmobile however it works fine on the AT&T network.
#5 starmint, May 8, 2013
Please follow these simple steps to solve "number not registered on network issue" in SG note 3

thank you
#6 ikkudubai, Dec 22, 2013
i flashed anroid 4.3 on my s3 i9300 and after this i was unable to connect to mobile network.

the imei is fine. i tried many different modems but i never can connect.

now i am back to stock rom but still same error.

i already did a full wipe and try to restore nandroid backup. nothing is working.

when i type *#0011# i get "IMEI CERTI: FAIL"

how can i get this certificate?
#7 faridul, May 18, 2014