Samsung Galaxy Centura Forum

Root Obtaining root

Follow the following thread on XDA

http://forum.xda-developers.com/showthread.php?t=2204259

Only difference is on step 10 you'll have to do it twice and reboot to see it work.

Should also mention that SuperSU will not work. Download Superuser from the android market afterwords.
 
#2 viiron, Jun 1, 2013
Got "problem parsing package" ... has anyone tried oneclickroot?
 
#3 squirrel11, Jun 1, 2013
How are you installing the package?

Under USB settings select MTP device. Connect the phone to your computer, Place the Poot.apk in the downloads folder. You should see the device under Explorer. You'll need to enable side loading under settings (it will prompt you to do so the first time you click on it)

After that the rest of the tutorial should be pretty self explanatory. Let me know if you need any help.
 
#4 viiron, Jun 1, 2013
Looks kinda scarey to me when it's talking about Black Screen....I think I'll wait for a more device specific method.
 
#5 SteveCampsOut, Jun 2, 2013
Nothing scary about it. The Centura IS a Qualcom device. Once you have root using the method above and poke around a little bit you'll see exactly what I'm talking about.

Either way. I did this to my Centura and it worked 100%. No issues whatsoever.
 
#6 viiron, Jun 2, 2013

You should report it back to that thread at XDA so they can add the Centura to the list of phones it works on along with the extra steps you used.
 
#7 SteveCampsOut, Jun 3, 2013
Not a bad idea. Just got done posting over there as well.
 
#8 viiron, Jun 3, 2013
It works perfectly! Thanks!
 
#9 alicott, Jun 7, 2013
Can't get it to work and I think it's because of the first step I can't seem to follow / set it.
"1) Go to settings > application > preferred install location > Internal device storage."
Could someone perhaps help me out here?

Thanks!
 
#10 StixMan, Jun 10, 2013
This is where I also got confused
 
#11 squirrel11, Jun 11, 2013
Don't worry about that part. If you unmount external SD and download and open the apk file it should install perfectly. You can then follow the rest of the steps. It worked fine for me. And I got supersu working. But I had to install superuser first and open it. It will prompt you to uninstall superuser and request root permission. Just for anyone who prefers supersu
 
#12 squirrel11, Jun 11, 2013
I tried this, however I never get the black screen. Instead it sits at a white screen and tells me: :thinking:

"A demon materialized while pooting. Error Code 87 su binary was not written. You need to restart your device."

That's all it does, it will sit there till I do something with the phone. The only black screen I get is when the phone goes into standby. However it's still responsive. Any ideas?

*EDIT*
I tried doing a power off and back on and then doing step 9, it just causes my phone to reboot.

*EDIT 2*
After the last edit I went ahead and when the phone reboot done step 9 again and then got the three menu item promtps. Powered down the phone and booted it back up, installed Superuser from the market and BAM!! I am rooted!


Thanks for the help.
 
#13 StixMan, Jun 11, 2013
I think I stated earlier that I have confirmed working SuperSU. You must install it after superuser and allow it root privileges. After which SuperSU will prompt you to uninstall superuser. It will then work just fine
 
#14 squirrel11, Jun 11, 2013
We have a new more reliable root method using Odin to install Clock Work Mod and then using Clock Work Mod to root the Samsung Galaxy Centura. Thanks to the developers at Area51! They are also working on the very first ROM.

First step is to install CWM via Odin. Instructions and the download for CWM can be found in this thread.

Root Method via CWM can be found in this thread.

Cheers everyone! :smokingsomb:
 
#15 SteveCampsOut, Jul 2, 2013
Which cwm works on the centura
 
#16 borytineo, Jul 6, 2013
The CWM in that thread I linked you to at Area51. Just click the link and you'll find the thread with the download link! :smokingsomb:
 
#17 SteveCampsOut, Jul 9, 2013
A51 states they have a clean, stock rooted CWM backup, but it's not actually stock. I have a completely stock root, but I can't post the link yet as my post count isn't high enough.

That said, you can PM me and it may work. Once I'm able, I'll post a thread.
 
#18 LucasV, Jul 15, 2013
How is Area51's root not stock exactly?
 
#19 SteveCampsOut, Jul 16, 2013
They've uninstalled some preinstalled apps, and installed their own third party apps. (i.e. ES File Explorer)

Granted, they tried cleaning it up, but I wanted completely stock root.

Sent from my SCH-S738C using Tapatalk 2
 
#20 LucasV, Jul 16, 2013
If I rooted using the original "Poot" (Qualcom) method as described earlier on this board can I still obtain the Clock Work Mod recovery as they use over at area 51? They seem to "officially" be unable to recommend their method of obtaining CWM after using the Poot method to root however I would just like to know if this will cause damage or Am I simply out of luck since I have already rooted using Poot.
 
#21 Mattswad, Jul 22, 2013
I'm poot rooted and I have cwm successfully installed with odin
 
#22 squirrel11, Jul 23, 2013
I need cwm one I can flash
 
#23 borytineo, Jul 29, 2013
I think the only way to get cwm installed is through Odin v3. But I could be wrong.
 
#24 squirrel11, Aug 3, 2013
Cant we flash it with recoveryflasher I did it on my venture
 
#25 borytineo, Aug 7, 2013