Samsung Galaxy S5 Forum

Support rapid usb connecting/disconnecting problem (wtf!)

I recently got a galaxy s5. Hooray, great phone, everyone loves it, **** the iphone, all that. When I plug the phone into my pc, it installs the drivers, and as soon as I go to transfer music onto it, it starts rapidly connecting and disconnecting. It has driven me insane.

There is a weird twist to this problem. After hours of searching for a solution online, someone pointed out a firewall issue. So I disabled my firewall and it seemed to solve the problem. I could transfer files, but as soon as I would do something like browse the web during that, the rapid connecting and disconnecting would kick in. So I continued to transfer my files overnight and went to sleep, 50gb of music at that, and there were no problems. All of it was on my phone. SD card for that matter. I dont believe that effects this as I had the same issue trying to transfer music just to the phone.

Here is what I've tried and what hasn't solved my problem:

-Using a different cable

-Using my back USB ports

-Using Kies

-Factory reset

-Connecting to my laptop (XP)

-Samsung Support (which recommended I go back to best buy and have the device replaced, after he remotely connected to my PC and saw what was happening)

-Going back to best buy and having the device replaced

-Disabling firewall

-Disabling LAN adapter

-Turning on USB debugging (which installed 3/4 of drivers, USB Composite Device, USB Mass Storage Device, SAMSUNG File-Stor Gadget USB Device, and failed to download SAMSUNG_ANDROID - keep in mind original SAMSUNG_ANDROID driver installed before I turned on USB debugging)

-Reformatting my PC (Win7 Home)

There is probably more I'm forgetting. I am truly baffled, and pissed off. Everything was fine with my iphone and I have never had more problems with a phone in my life. Can't listen to music via usb in my car either. What's also very strange is the fact that my brothers have no issues! Also in device manager under system devices when I click samsung_android properties it says no drivers have been installed.. despite the fact that I downloaded them from the website..

One thing I haven't tried is connecting to my work pc. I am going to try that tomorrow. Also, if anyone knows how to do what this guy said, please let me know:

I've tried entering *#0808# but nothing happens. I am so over this I am about to go back to bestbuy and just get an iphone.... someone please stop me from doing that....

 

Related:

#1 gjdfa, Dec 4, 2014 Last edited: Dec 4, 2014
Not having that problem with mine. Maybe the phone is defective. WoulD take it back and have them look at it. Mary
 
#2 acraftylady, Dec 7, 2014
it's my pc. and for that matter my outdated laptop gives me the same issue. no other pc i've tried connecting it to does this (i tried this after my novel of a post)

i built the pc i'm using in 2009 and this is my motherboard.

there is no windows 7 usb driver download available, and i'm convinced it's a usb issue. i mean my usb ports function but there is some incompatibility issue with this phone and my motherboard.
 
#3 gjdfa, Dec 10, 2014
Hi,

did you ever solve that issue, I am currently very annoyed with my Laptop where my new Samsung Notes 4 keeps on connecting/disconnecting all the time within seconds.

I have tried different solutions (uninstalling the USB driver/installing Kies/...) to no avail.

Basically it is linked to the computer as the link works fine with the same cable on another computer.

The laptop is a recent Dell and I am using Windows 8.1.

I have been searching through the internet for hours and finally thought to post myself.

Thanks
 
#4 Ochiniwa, Jan 28, 2015
I'd like to contribute to all of the confusion, but not in the helpful way. I've been having this problem too. Seems to only be music too! I can transfer gigs of files to my external SD card and it's fine. The second I transfer music files:

"This device has either stopped responding or has been disconnected.
Would you like to: Stop Copying or Skip This File?"

I start over and over because I don't know which of my thousands of songs have transferred and which haven't, if they got cut off and aren't really there... It hasn't TECHNICALLY disconnected (no *duh-din* sound) until I physically disconnect the cable, but it's done giving me access to it. I can rip out the cable from my computer or my phone repeatedly and maybe every fifth time it connects again. And then the cycle starts again.

I guess I'm glad enough that this single thread exists in all of the Internets to know it's not just me, but JEEZ has anyone found a solution??
 
#5 hamstrman, May 30, 2015
the only solution I've found is using another computer. My Old xp laptop and custom pc gave me this issue and when I used a modern laptop and my new pc i.built a few months ago I have not encountered this issue. Samsung support even remotely connected to my pc and the technician typed in my message window "uh oh"

Lead me to believe they know of the issue and have no solution. Seems to be some kind of USB incompatibility issue with modern android software. So use a newer pc or mac post 2012 would be my answer.
 
#6 gjdfa, May 31, 2015
I have added a file manager assistant to Windows called TerraCopy...

it is a silent thing, but comes into play when you decide to copy a huge amount of files, or a folder full of files. What I like about it, if something happens to interrupt the process, TerraCopy gives you the option to "ignore duplicates" and it will continue to copy all of the remaining files.

give it a try, it has been a lifesaver for me.... as the Windows Explorer file manager is a bit weak, and makes you answer 'yes/no' for every single dupe file it comes across. a true PITA.

http://www.softpedia.com/get/System/File-Management/TeraCopy.shtml

make sure when you install it, you allow it to interface fully with all of the Windows Functions or you won't get the full benefit of it working in behind the scenes.
 
#7 AZgl1500, May 31, 2015
At the moment I have a similar issue with my SG S6 Edge while connected to my notebook "P37 X Gigabyte". When the phone is fully charged the usb connection is rapidly dropped and reestablished in a infinite loop of a second's duration. My notebook is obviously stopping to charge devices when the charging reaches 100% but my Ipad for example will still be connected coherently and I can access the files without a dropping loop. I am not sure whether my phone, notebook or cable is at fault (probably phone). I would have to test it with a desktop or other notebook still.
So far I am not amused about this issue, especially when I want usb-tethering to work :(
 
#8 chrisoutwright, Jul 11, 2015
It's a USB incompatibility issue, idk what laptop you habe but there is some android USB incompatibility issue with outdated motherboards. I don't know what else to say. Samsung support remotely connected to my pc and had no idea. I'm shocked the error isn't more widespread than it is.
 
#9 gjdfa, Jul 12, 2015
I was having this issue with my S6 Edge. I don't think it's a compatibility issue with "older" motherboards because I have a new laptop that is causing this problem. I have done the *#0808# step mentioned above, I've updated and uninstalled drivers. Reboted my device, rebooted my computer, etc. I have verified that all drivers installed are actual Samsung drivers and not Microsoft drivers. After all this, I have found what was causing the problem for my computer: I have a 4 foot USB cable and I replaced it with a small 3 inch cable. Problem stopped. If I go back to the longer cable, problem starts back up.

It appears Samsung can't quite drive the USB lines with enough current for some cables so it looks to the computer as if the device connects and then quickly disconnects. Hope this helps others with this problem. I've gone from a disconnect every 3 seconds to a stable connection by using my 3 inch USB cable.
 
#10 RustyScott, Jul 30, 2015
I finally and definitively cured the exact same problem by using an externally powered USB hub.

(While I believe there _should_ be a software solution, since the phone has only started doing this since 4.4 was pushed on to it, I tried everything in the book with no success.)
 
#11 Banaari, Aug 7, 2015
I concur to Banaari. My problems were immediately fixed with the powered USB hub. I used to have this problem all the time with the galaxy S3, it was extremely annoying, so I always ended up using Airdroid to transfer files. It was a pain because it takes a while to transfer massive amounts of data over network, it was with windows 8.0/8.1...For 2 years I lived with this...So I just got the S6 two months ago and windows 10 had not been released yet, so I still had the windows 8.0/8.1 , and guess what? Same freaking problem with the S6! NO WAY! My solution? Airdroid again... So I upgraded to windows 10 less than a month ago, guess what? SAME FREAKING PROBLEM with the S6 (s3 I do not longer have it)! So, I thought it was my computer...Until today. I never thought about going online and looking for a solution, too busy for that...But today I was decided to make it work. Just came to this post easily, external USB hub laying around my bedroom, connected it to the USB provided from Samsung, Boom!!! For the first time in YEARS the thing works like it MUST! I just transferred massive 4k videos back and forth. No problems at all. Awesome...

Definitely, big issue.

Thanks.
 
#12 quimicosoy, Aug 23, 2015
An addendum: Another solution I found (not wanting to lug the hub everywhere) was to use something marketed as a USB 3.0 cable... one with the double plug on the phone end, and about the thickness of a small anaconda.
 
#13 Banaari, Aug 23, 2015
SOLVED!!

It is a USB Power setting

1. Scroll to the right and type 'Power Options' in the search field and click on it.
2. Click 'Change plan setting' on your chosen plan.
3. Click 'Change advanced power setting' on your chosen plan.
4. Find 'USB settings' and open.
5. Find 'USB selective suspend setting' and change it to disabled.

http://www.tomshardware.com/answers/id-1783536/usb-ports-disconnecting-reconnecting.html
 
#14 Riptide9, Oct 12, 2015

never had the problem, but I JUST HAD TO bookmark that for future reference.
thanks for posting this.
 
#15 AZgl1500, Oct 12, 2015
This didn't work for me, BUT, I did the same thing in the Manufacturer's power options (I have a Lenovo, and their power app is called 'Power Manager'). Once I had changed 'USB selective suspend setting' to disabled in both the Windows and Lenovo Power options, it worked.

I think this will work for other manufacturers too (HP etc.) in their power manager app. advanced, USB, Disable.
 
#16 Tongs, Oct 20, 2015
Same problem, solved by plugging into my docking station rather than my PC.

Now, I know just enough USB to be dangerous, so somebody else should comment on this.

The selective suspend is a possibility. I don't know why a just-plugged-in device would get a selective suspend while I'm in the middle of navigating through the folders, though, so I suspect something else.

USB devices negotiate how much power they are going to require when they first connect. For example, a device can say "I'm low power and don't need more than 100mA". The USB hub can then budget for numerous devices. IF a device suddenly starts to draw more current than it requested, the USB hub MAY opt to disconnect it. Many device manufacturers don't bother to disconnect these devices, and many others don't pay careful attention to whether their devices draw a little more than they request. This leads me to wonder...is it possible that the phone is requesting a given amount, and then the hub for some reason thinks it is over drawing (never mind whether or not it actually is over-drawing), and shuts it down because of this limit?

I would guess my Samsung Galaxy S5 does not allow me to change the USB power request setting (a little too much user config). Anyone know how else to test this theory?
 
#17 js94247, Mar 31, 2016
http://www.tipandtrick.net/windows-...drop-and-not-sync-with-vista-wmdc-activesync/

I found this. My phone was connecting but dropping off just as fast. I checked the drivers and even though I installed them, there was an error code 10. Unable to open. So, I in installed the driver. Found this tips and tricks. I remember my phone flashing quickly that I needed wmp 10, windows 10 or something else installed on my pc to work properly. I'm about to do the trick with the windows media player listed in the article above. I'm on Vista 32 bit btw.. not sure if this helps...hope so. Good luck.
 
#18 Cyb2, May 25, 2016
Higha peeps.


Been having the same issue. BUT, also found a solution that fixed this issue for me, and hopefully for you and others aswell.

The issue being: USB 3.0 (the blue ones...)
Connect to a USB 2.0 port (regular black / white) and ... FIXED

I get the same connecting/disconnecting sound on my custom pc, laptop and 3 other laptops that I tried (recent models).
I have not been able to test this fix on those machines, but it does work for both my custom build computer (+5 y/o) and laptop (-1 y/o).

So I still cannot rule out faulty hardware combined with luck or any other abnormality; and this is where you good people would come in. Please test this in your desperate strugle to fix this issue, and if it did fix this for you; please reply so we can spread the word.


PS: Sorry mods if I've broken any rules by replying in an older threat. I honoustly don't feel like going thru your forum rules in order for me to share this information .
 
#19 Weedy, Nov 19, 2016
Thank you Riptide9!
 
#20 xantius, Dec 5, 2016