Samsung Galaxy S5 Forum

Support S-Health has stopped (SG S5 clean- not rooted)


Hi,
[*]I just purchased my brand new Samsung Galaxy S5. I have used the cool features of this new model and was so happy with it. After some updates, I opened (S Health) to try my blood pressure, but it says (Unfortunately, S Health has stopped) as in the attached picture).
[*]I uninstalled the updates, and the same problem still exists.
[*]The Blood Pressure is one (not all) of the main reasons made me purchase this phone and upgraded from galaxy S4. I am really disappointed, and can't find any help on the internet. Ths smart stay feature also I think it has no effect. I keep my eyes wide open looking at the sensor to keep the screen open but no avail. I came here today, as I am pretty sure that you guys here have the magic to solve any andro problem.
[*]Any help? Or advise? Or suggestions? :(
 

Related:

#1 yasomoca, Jun 25, 2014
uploadfromtaptalk1403684095495.jpg
 
#2 yasomoca, Jun 25, 2014
40 views and no single reply. :(
 
#3 yasomoca, Jun 26, 2014
Well, know that you're not alone. My S5 does this too. Additionally, it shows zero steps taken.

I *am* rooted using towelroot but other than that my S5 is stock as well.
 
#4 Mayhem, Jun 26, 2014
I dont have that cell yet but there is an on-going problem with that app...since this is an early release problem I would suggest doing a update on your new cell and see what happens. Good Luck!

S health and xposed - xda-developers

http://androidforums.com/samsung-galaxy-s5/841251-galaxy-s5-unfortunately-s-health-has-stopped.html

GS4 S Health App not working ! - Android Forums at AndroidCentral.com
 
#5 n2bowling, Jun 26, 2014
Hm. Who'da thunk that Xposed could have something to do with it? At least that's one theory. I wonder if OP is running Xposed (I am)
 
#6 Mayhem, Jun 26, 2014






Well, I think it shows that some cells are working, others not. My cell has been updated to d latest, but also the same problem still present. I am sure that I f I wiped to factory reset, it will work, but really don't have time to restore everything again. We need a developer to look after this
 
#7 yasomoca, Jun 26, 2014
Hmmm, I was thinking about getting the Samsung Galaxy S5 , however, I am actually leaning very strongly to the Samsung Galaxy S5 "Active" which is basically the same cell as the Galaxy S5 with more of a rugged type of cell :smokingsomb:
 
#8 n2bowling, Jun 26, 2014
I ve just checked one of my friend's S5 and S-Health is working like a charm. I am really jealous :( am pretty sure that there is an app conflict, but with what?
 
#9 yasomoca, Jun 26, 2014
How long ago did you get it? if recently I would go back and exchange it for one that the app in question works. There is generally a 14 day warranty to take back a cell under any circumstance...
 
#10 n2bowling, Jun 26, 2014
June 8th
 
#11 yasomoca, Jun 26, 2014
I would definitely try taking it back for an exchange...all they could do is say no. Just tell them that you just got back from a week vacation... :)
 
#12 n2bowling, Jun 27, 2014
I have reset the phone to the factory settings, and it works like it should and as I expected, but I didn't update to the latest firmware or even the s health app :)
1404159105166.jpg
 
#13 yasomoca, Jun 30, 2014
Yeah, I have the same issue with A Health. Like you, I don't want to do a factory reset for the obvious reasons. But I see that you have done so. Still working fine w/o the app update? My question is, did you have any other issues like the Samsung app update apps disappearing? Gonna wait to do a reset. I am dreading doing so.
 
#14 KrookedKricket, Dec 7, 2014
Good news for S5 users whose S Health App has stopped working after the app update. I got the s health app to work again. I went to my app screen on my phone, selected the options drop down and selected galaxy essentials. I then looked for the s health app and it either showed install or update I forget, but either way after doing so, I launched the app and it works. So far no issues. By the way, this was done without doing a factory reset. I hope this helps.
 
#15 KrookedKricket, Dec 7, 2014
Cool. Thx
 
#16 yasomoca, Dec 8, 2014
thats funny. I checked my heart rate with this ap and then I couldn't get it to turn off. I don't want it running in the background counting my steps. Every time I would wake my phone up there would be a new number for steps on the lock screen. I couldn't stop it. I eventually went to ap manager and uninstalled the updates and turned it off there. I disabled it (I think). An unexpected benefit is now my battery lasts for 2 days with normal usage. My old S3 wouldn't last 8 hours. This is great!
 
#17 sdtag, Dec 10, 2014
This resolved the issue on my phone also! Voila! I had tried everything except a factory reset which I was NOT going to do.
 
#18 ElfinGentAF, Jan 3, 2015
I have the S5 active. S health is not in the galaxy essentials for me. On galaxy apps it says it's installed. I even tried S voice to open S health. Phone said it's not installed. What other options do I have to restore S health. My Co worker has the same phone and same apps his works fine.
 
#19 killalol444, Jan 20, 2015
Hmm. I haven't had a chance to play around with the S5 active. If you haven't already, go to your app. manager and clear the cache, force stop, and try to uninstall the app or at least uninstall the updates. You can prob. only uninstall the updates. Power off your phone then power back on after 30 seconds. Try launching S health and see if it works. If not, go to your Galaxy apps and if you see S health there, install it. If it's already installed and it's working now don't install the updates for S health. Dunno if you installed the updates before or not if so, this may have caused the problem. If S health still doesn't work, you should do a factory reset. I know, that stinks, but that will fix it for sure. Just don't update s health until there's a fix for it. I hope I was able to be of some help. Good luck.
 
#20 KrookedKricket, Jan 20, 2015