Samsung Galaxy Note 2 Forum

General That WiFi problem on 4.4.2 could be...

I've just installed 4.4.2 on an International SIM free Galaxy Note 2. (Clean install by reverting to a fresh 4.3 then upgrading, then doing a clean install of 4.4.2)

I've only been using it for a couple of days but have noticed that the WiFi disconnects and I've been unable to turn it on again.

However with the WiFi icon off, I can still check emails etc.

Initially I thought this might be the "smart network switch" which I think switches between WiFi and mobile data automatically, so I disabled it.

Last night I set the WiFi timer to only work between 6am and midnight, so when I woke up this morning I expected the WiFi to be on. The icon said it was off.

To confirm that WiFi was still working (although the icon was off), I tried to browse shared folders on my home network. Bingo!

So although WiFi claims to be off, it's on. Go figure.

I have a Sonos on my home network and could turn it on and off over WiFi (using my Note 2), but when I tried to change radio streams it asked me to "enable WiFi", which it failed to do.

I'll test some more by heading to my nephew's and see if it connects to his WiFi automatically (with the icon off)...


But I'd be grateful if anyone else who has this "problem" could confirm my findings.


Thanks.
 

Related:

#1 Nobby Sheep, Jul 28, 2014
Update:

Having tried to turn on the WiFi icon earlier (even though the WiFi was on) and failed. I've now noticed the WiFi icon is on.

So not only does it randomly turn the icon off it seems to turn it back on again!
 
#2 Nobby Sheep, Jul 28, 2014
Hi all.

Further investigation here.

The WiFi icon has three states.
Green - on
Grey - off
Black - changing between on and off

The problem I had after the upgrade to 4.4.2 was that it would seemingly turn off, but actually still be on. i.e. icon was black.

After three days of testing it seems it could be a "location" problem.

Here's what I've noticed.

(By the way "smart network switch" is set to off.)

When the "location" setting was on and set to "power saving" I encountered the problem of the WiFi icon being off, but WiFi was still connected, but tapping the WiFi icon did nothing.

When the "location" was set to GPS only I did not encounter any WiFi problems.

When the "location" setting was off, I encountered no WiFi problems.



Can anyone else confirm these findings?
 
#3 Nobby Sheep, Jul 31, 2014
 
#4 sbains05, Dec 27, 2014 Last edited: Dec 28, 2014
Same here, Android KitKat 4.4.2 on ProntoTec tablet began turning off Wi-Fi as well..
  • I checked Settings, Location and found the mode as Battery Saving - "Use Wi-Fi and mobile networks to determine location". I could not turn the option off.
  • I went to Settings, Display, Sleep and chose Never Sleep. That seems to work for now. Otherwise, with sleep enabled, I have to restart the device to turn Wi-Fi on again.
  • Later: found the proper way to do it. Go to Settings, highlight Wi-Fi, tap the three spots, select Advanced, highlight Wi-Fi optimization - "Minimize batter usage when Wi-Fi is on" and tap off the check mark.
 
#5 finkey, Dec 29, 2014 Last edited: Dec 29, 2014