Samsung Galaxy S Forum

Support what will the "wipe data/factory reset" actually wipe?

Hi All toolman here

i have a galaxy s i9000 phone belonged to my sister in law. The screen has locked and she does not remember the email and password (gurr)

She needs to get the photos and videos off the internal phone memory. i tried kies but CANNOT get the usb to work no matter what i do (i don't know what mode the phone was in prior to it locking and i cant access it. I tried one of the secret codes just to check the firmware but i can only make emergency calls with the phone and It cannot use these codes so my last option is a wipe data/factory reset - or something similar

So after pressing and holding VolumeUP+Home+Power. There i found the options "reboot", "apply", "wipe data/factory reset" and "wipe cache partition".

heres my question will the "wipe data/factory reset" option delete the photos and videos that are on the INTERNAL memory storage.

I have looked around various sites for the past few days and i am getting conflicting stories - some say it will wipe the internal memory AND the photos AND the video - and some say it will only wipe the applications / settings BUT it WILL NOT wipe the photos and video stored on the internal memory.

I need an option that will leave the photos and video on the internal memory but just reset the software / apps so i can gain access to the photos / video (by entering the right usb mode on the phone.

Any help in sorting this is very much appreciate you see I need definite proof that it will either leave the photos / video alone or that it will delete them as the phones pictures and video are the last taken of her sister who passed away. So she would really not want to take the chance on loosing the photos / video if there was a chance that the wipe data/factory reset would delete the photos & video. In that case she would rather just hold onto the phone (at lease she knows in her heart that the photos / video are still on it)

anyway thanks in advance for your help.


#1 ltcartman, Mar 25, 2012
The Galaxy S has three separate inbuilt storage locations called; Internal phone storage (1.87 GB in size), Personal data (127 MB) and Internal SD card (5.64 GB). When a Wipe data/Factory restore is performed the Internal storage and personal data are wiped but the Internal SD card is untouched so the photos and videos will remain intact as that is where they are stored by default.

For future reference, either you or your sister in law should make a regular back-up (weekly) of important stuff like photos and videos to prevent losing them in the event that the phone breaks down. Believe me when I say it happens all too often.

#2 rayhipkiss, Mar 26, 2012
thanks Ray

believe me i read her the riot act about this. ;)

I performed the Wipe data/Factory restore but the "too many pattern attempts" screen still comes up and i cant get past it

any ideas as to why it didnt work

ps there is no sim in the phone if that makes a difference?

would the "wipe cache partition" help?

thanks for your reply.

#3 ltcartman, Mar 27, 2012
That's strange. The factory restore should have removed the pattern lock. And, to be certain I've just tried it on my Galaxy S which did remove the pattern lock. Wiping the cache partition won't remove the pattern lock.
Can I suggest you try performing the factory restore again from recovery mode. From past experience I've known the factory restore to fail sometimes and retrying should do the trick. When the phone reboots, the first screen should be the language selection screen. If not, there is something obviously wrong and we may have to resort to flashing a new firmware. Not as difficult as it sounds.

All the best.

#4 rayhipkiss, Mar 27, 2012
hi Ray

I did another 3 factory resets but they didn't work - btw after the first factory reset the original wallpaper (of a person) was replaced by a picture of what looks like a Spanish type villa on a street i presume this is the default background on the phone)

BTW i have no sim in the phone would that effect the factory reset ?

Won't flashing a new firmware delete the photos and video on the internal storage? if so i cant do that.

thanks for your continued help

#5 ltcartman, Mar 27, 2012
I don't understand why the factory reset isn't removing the screen lock, as it definitely should.
Flashing a new firmware will not delete the photos or videos as they are stored on the internal SD. The flashing process only affects the ROM which is separate from the SD storage.

If your not comfortable with flashing a firmware yourself you could take the phone to a Samsung service centre and ask them to do it for you.

If you don't mind doing it yourself I can guide you through the steps necessary and the whole process shouldn't take any longer than 10 minutes. I will need to know what country/region you are in and whether your phone is network locked or an unbranded model.

All the best.

#6 rayhipkiss, Mar 28, 2012
hi Ray

ill give the flashing firmware a go (no samsung service centre near me)

I'm based in the "Rep of Ireland" and the phone is locked to the following network "Meteor"

re the photos / videos on the internal memory of the phone. Really?? I got the impression if you flashed the phone that all the photos / videos would be deleted on the internal memory. - if ur 100% sure it wont then by all means lets try it.

thanks in advance once again

#7 ltcartman, Mar 28, 2012
Good evening,

I can absolutely guarantee that flashing a new firmware will not touch the photos and videos, so you've no need to worry about them disappearing.

The bad news though is that there isn't a firmware available for download for your Meteor locked handset. Now for the good news, You can flash it with the latest official Gingerbread which you can download from the link at the bottom of this post.

To flash, first extract the folder you have downloaded to reveal two more folders (Odin and the JVT firmware package). Now extract those two folders to your desktop.

First of all make sure the phone has at least 60% charge.

Now switch off your mobile and leave it until it vibrates (can take up to 10 seconds) and then put it into download mode by holding Volume DOWN + Home button + Power button. The screen will have a yellow warning triangle with the Android robot digging.

Now launch Odin and connect your phone to the PC. The box under ID.con should turn yellow with some text in it to indicate the phone has been recognised.

Now click PDA and navigate to the firmware folder you extracted earlier and select the CODE file.
Click PHONE and select the MODEM file.
Click CSC and select the CSC file.

Now click start and go and have a cup of tea while it does it's thing.
When it's done the phone will auto reboot but will take a lot longer than usual to fully reboot. Don't worry as this is normal on first boot after flashing a new firmware.

If for whatever reason the process fails, just repeat the above steps to recover. S

The very best of luck to you.

#8 rayhipkiss, Mar 28, 2012
got the gadget serial driver issue (fixed it)

here is 2 CSC files
used this one

tried it and got a fail in first box on top of odin

<ID:0/003> Added!!
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> Enter CS for MD5..
<ID:0/003> Check MD5.. Do not unplug the cable..
<ID:0/003> Please wait..
<ID:0/003> Checking MD5 finished Sucessfully..
<ID:0/003> Leave CS..
<ID:0/003> Enter CS for MD5..
<ID:0/003> Check MD5.. Do not unplug the cable..
<ID:0/003> Please wait..
<ID:0/003> Checking MD5 finished Sucessfully..
<ID:0/003> Leave CS..
<ID:0/003> Enter CS for MD5..
<ID:0/003> Check MD5.. Do not unplug the cable..
<ID:0/003> Please wait..
<ID:0/003> Checking MD5 finished Sucessfully..
<ID:0/003> Leave CS..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> boot.bin
<ID:0/003> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

so tried the home multi version

WORKED Yipee thanks a million

found drivers that actually worked in win 7 off another forum and i can now just download files like normal

thanks a million


#9 ltcartman, Mar 28, 2012
Sorry, I forgot to remark on the CSC. Nevermind though as you seem to have sorted it.

Glad to have helped and I hope your sister in law is happy now as well.

All the best.

#10 rayhipkiss, Mar 28, 2012
i am doing my second factory reset in 4 months. this sucks! my download speeds have been 2mbps. spoke with ATT and samsung and both suggested this. too much work for this phone. have to re-customize my skyrocket AGAIN. this is what i hated about my first android experience. too much work too maintain performance.

i'm hating android right now!

one hour later and factory reset did not work. i will be getting a refurbished phone. i am pretty disappointed. this is my second experience with an android phone and my second lemon. to re-customize my phone will take several hours. i will re-evaluate ever doing android after this experience. when this phone was good it was great. but 2 factory re-sets in 4 months...too much.

i had the droidX 2 years ago when it first came out and had too many issues also. returned it after 3 weeks.
#11 bk11222, Jun 21, 2012

you should use a backup app like Titanium Backup to do the work of backing up and restoring all your data and apps before using factory reset
#12 xsenman, Jun 21, 2012
I basically have the exact same problem, except I have a:

SCH-I535 Verizon Samsung Galaxy S3 4G LTE 32gb
Stock OS (not rooted)

Can I follow your steps and instead use the firmware provided by this site?

Will there have to be any modifications to the process?
#13 ricecracker96, Aug 15, 2012
Hi ricecracker96

The procedure may be slightly different if the firmware package you've downloaded contains only one file rather than the three files described in my previous post. In that case, all you need to do is click the PDA button and select your one file then click start.

Make sure to download the latest Odin from the XDA developers site you linked to.

All the best.

#14 rayhipkiss, Aug 15, 2012
thanks for the reply :D

just flashed the stock firmware with odin3 v3.04 using firmware from here:

Claims it was successful and when it rebooted it was still locked :T

The "messages"

<ID:0/007> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> HOME_I535VRALF2_I535VZWALF2_618049_REV09_user_low_ ship.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/007> Odin v.3 engine (ID:7)..
<ID:0/007> File analysis..
<ID:0/007> SetupConnection..
<ID:0/007> Initialzation..
<ID:0/007> Get PIT for mapping..
<ID:0/007> Firmware update start..
<ID:0/007> boot.img
<ID:0/007> NAND Write Start!!
<ID:0/007> recovery.img
<ID:0/007> system.img.ext4
<ID:0/007> NON-HLOS.bin
<ID:0/007> cache.img.ext4
<ID:0/007> RQT_CLOSE !!
<ID:0/007> RES OK !!
<ID:0/007> Completed..
<OSM> All threads completed. (succeed 1 / failed 0)
<ID:0/007> Removed!!
<ID:0/005> Added!!
<ID:0/005> Removed!!
<ID:0/005> Added!!

tried a second time and got the same thing :/
do you have any other ideas?
how come it worked for the op in this thread and not for my phone?
#15 ricecracker96, Aug 16, 2012
To be honest, the procedure worked for the i9000 Galaxy S because it had a couple of security flaws that bypassed the pattern lock, PIN request and any other measures in place just by flashing a new firmware.
Your S 3 has obviously addressed that flaw to prevent a stolen phone being used by the thief. If that's the case then your only option is to take the phone to a Samsung Service center with proof of ownership and they should be able to help you out.

Sorry I couldn't be of any more assistance.

#16 rayhipkiss, Aug 16, 2012
Ah, that makes sense.
Thank you so much for all your help ^^,
I was surprised you even replied; everyone on this forum's so responsive, it's nice.
#17 ricecracker96, Aug 16, 2012
I very nearly didn't reply owing to the fact I've moved away from Samsung phones for a while. I may be back sometime in the winter and get a Galaxy S 2 but I'm undecided as I have my eye on a Lumia 800.

All the best.

#18 rayhipkiss, Aug 16, 2012
I am trying to do this as I have rebooted etc numerous times and can not get passed the pattern failed on my daughters phone.

The phone is plugged in and I have opened the odin file, but no yellow writing or any writing is showing in the ID:COM box so nothing is happening.

Please help...
#19 letan, Aug 30, 2012
I am trying to do this as I have rebooted etc numerous times and can not get passed the pattern failed on my daughters phone.

The phone is plugged in and I have opened the odin file, but no yellow writing or any writing is showing in the ID:COM box so nothing is happening.

Also im not sure if this is the prob, but I am getting an error saying microsoft isn't recognising my device
#20 letan, Aug 30, 2012
hi rayhipkiss consistently you are giving awesome information/Answer here......... and i am accepting too..............

Now here is my Q....

Last night my phones hangs out after changing the font on my mobile ...... i restarted it but it keeps booting for several times....... i restarted it several times but the problem is same.....

then i start my mobile in recovery mode.....
and choose the option wipe data/factory reset....

and now my phone is not booting at all....
it shows the only screen showing my phone name....

what can i do now......?

phone model : Samsung galaxy ace duos GT S6802
country : india
#21 kedar9444, Sep 12, 2012
I've also been having the same problem.
However, in the past i've been able to restart my Galaxy S phone and it would just delete my contacts and my settings, etc but would keep my text messages. If I were to wipe data/factory reset would it delete my messages?
#22 ita101, Nov 17, 2012
i have a problem too when i do factory reset nothing deleted all programs come back after restart i tried to do them manually by uninstalling them also after restart all data came back i went to some one he did a software on my s1 and same problem after restart all data comes back ! and when i try to open any application it gives me error force to close what can i do ??
#23 josifskaf, Mar 22, 2013
Three question:
1) "Wipe data/Factory restore" return the phone to it's first configuration?
2) How to format/delete Internal SD card (5.64 GB)?
3) What the wipe cache partition do?

Sorry for the lame questions. but i would like to return my SGS to the first configuration with no data on it.
#24 dsfvsdgv, Mar 29, 2013
hi all sorry to bump this thread but I have an issue similar to the original poster's. I have a Galaxy Ace that I had unlocked to local provider, I have tried to root the phone in order to run Link2SD but it doesn't accept the rooting in the procedures that it is requiring. I was considering wipe data/factory reset but I was afraid of losing my unlock or more importantly data. Any ideas or suggestions?

thanks in advance!!!
#25 vikbz, Apr 18, 2013