Samsung Galaxy S3 Forum

Support Wifi Authentication Error Occurred - Galaxy S3 on 4.0.4

Hi all,

I have a Samsung Galaxy S3 that was originally on firmware 4.0.3 (what was shipped with the device). Everything was working fine, I was able to connect to my wifi at home no problems.

I received an OTA upgrade to 4.0.4. Ever since then, everytime I try to connect to my home wifi, I get the "Authentication Error Occurred" message. My router settings have not changed, my password has not changed - all other devices in my household are able to connect to the wifi without any issues.

I have tried rebooting my phone, rebooting my router. I have also tried factory resetting both my phone and my router - no luck. My wifi has a WPS function - I also tried using this without any success (no authentication error occurred message - just times out when trying to use the push button or pin technique).

I have disabled mac address filtering, firewalls etc. the most bizarre thing is, i turned off my router security (i.e. no security settings) and i STILL get authentication error occurred message.

The weird thing is, it seems to work on some routers and not others. I am able to connect to my parents wifi, and my friends wifi, but not my own, and not at my work (was previously able to prior to upgrading to 4.0.4).

Another weird thing - my router is dual band - 2.4GHz and 5GHz. I am able to connect to the 5Ghz band, but not the 2.4Ghz band. Using 5Ghz is not an option for me though, as the range is quite poor. I need to be able to use the 2.4Ghz band.

I'm at my wits end, I dont know what else to do. Does anyone else have this problem? Has anyone had any luck fixing it? Does anyone have any suggestions?



#1 frosty17, Sep 12, 2012
I'm having the same problem. although I can connect occasionally, but quite frequently it drops out saying "authentication error occurred"

I reentered my details. same problem.
#2 FlyinRoc, Sep 17, 2012
I'm having the exact same problem that started last week. When I try to connect, "incorrect password" flashes at the bottom of the screen for a quick second, then I get "authentication error occurred" for every WiFi network I try connecting to....even networks that aren't encrypted and don't require a password.

I've tried resetting the phone and router, performed a factory reset on the phone, WPS push button and pin connection method and nothing seems to work.

The guys at the T-mobile store couldn't fix it, T-Mobile tech support couldn't fix it. Looks like I will be doing a warranty exchange.
#3 spanson, Sep 24, 2012
OK here's something interisting for you guys:

Until 2 weeks ago, I had a motorola razr which was factory running Gingerbread. The Wifi was working flawlessly. Then, my service supplier pushed an OTA update to ICS 4.0.4 and immediately upon rebooting, I lost the connectivity to my home wifi (which uses WPA). I have tried everything, literally everything, to no avail. The only way to make it work was to reboot the access point. Then, an accident happened and I replaced the razr with the GS3 which came factory with ICS 4.0.4 as well.... Same problem. Cant connect to my wifi. I have tried again resetting the access point to factory settings, reset the phone to factory setting, etc.. nothing helps except a reboot on the wifi access point.

Using the Terminal application (for the real Linux geek ;) I could see these messages in dmesg:

1|app_166@umts_spyder:/ $ dmesg | grep wlan
<6>[ 0.340820,0] print_constraints: vwlan1: 1800 <--> 1900 mV
<6>[ 0.341644,0] print_constraints: vwlan2: 3300 mV
<6>[ 5.130767,0] regulator_init_complete: vwlan1: disabling
<6>[ 38.087188,0] ADDRCONF(NETDEV_UP): wlan0: link is not ready
<7>[ 39.915771,0] wlan0: authenticate with 1c:af:f7:dd:7b:55 (try 1)
<7>[ 39.919342,1] wlan0: 1c:af:f7:dd:7b:55 denied authentication (status 17)

Looking on Google, I am leaning toward a bug in ICS in regards to Wifi protection (WPA2).... Somehow, I think that the device is trying to send or connect to the access point with an encrypted passphrase or something else and due to encryption problems, is corrupted and therefore rejected by the access point.

Anyways, this is not acceptable for a device I am paying for. Period. I have lost wifi so no more Exchange server sync which means potential problems with business matters. Like they said in Apollo 13 "Gentlemen, this is NOT acceptable!" [​IMG]

I am blaming Android and NOT the phones. Same OS, different phones, different manufacturers. Tonight I will try to disable the wifi power saving mode and see if it helps. Have you tried it yet???
#4 lpallard, Sep 26, 2012
That was a really interesting post lpallard

Good to see that you were able to prove that it was a firmware / device issue rather than a WLAN / Router configuration issue.

I tried disabling power saving mode on wifi too, no luck.

I am wondering whether this issue only happens on routers with WPS? It seems odd that I am able to connect to some routers and not others. The only thing I have been able to narrow it down to is the routers i am able to connect to do not have WPS. Disabling WPS on my router did not work though :(
#5 frosty17, Sep 28, 2012
thanks for your comments! yes it's a very frustrating bug... and we're not the only ones.. the biggest frustration is the complete lack of support. I emailed Google several times, opened a bug report on the android bugs but they did not reply to my emails and nobody followed up with the bug report.

my service supplier has completely washed me away saying that they are not responsible for android and to contact the phone manufacturer which I did. same thing, no response from them either.

I too have tried the WiFi power saving mode to no avail.. I will try some more stuff and post back.

all I can say for now: android is broken and nobody wants to admit it.
#6 lpallard, Sep 28, 2012
has anyone found a solution to this problem yet?
#7 lpallard, Oct 7, 2012
I have no problem with our dlink DIR-628 router using WPA2 on 2.5GHz. I did read somewhere that the s3 doesn't like certain brand of routers. I'm on the latest 4.0.4. firmware.
#8 Jeepmaster, Oct 8, 2012
My service provider has not yet released a newer firmware than 4.0.4 but I cant wait because it's crippled with bugs.

What does the 4.0.4 doesn't like about certain routers?

Funny how all phones and laptops that ever got here were connecting to my router but suddenly my former Motorola Razer running 4.0.4 stopped connecting and this galaxy thing is not able to connect either..

Strange coincidence eh?? ;)
#9 lpallard, Oct 8, 2012
I don't really know what exactly ICS doesn't like about other routers. I just remembered it was ppl having problems with NETGEAR routers. Oh one more thing to check. Try not using the AUTO frequency setting and just pick 2.5GHz ONLY to see if that helps.
#10 Jeepmaster, Oct 8, 2012
All, as it was suggested on my Google bug report, please report your issues to Google in my bug report available at

Issue 36993 - android - wifi no longer working in ics 4.0.4 - Android - An Open Handset Alliance Project - Google Project Hosting

so issues with Wifi can be prioritized and fixed ASAP.
#11 lpallard, Oct 10, 2012
i think i got it i was having the same wifi issue on my new gs3 that was less than 24hrs old i changed the encryption from aes to tkip and its been working so far
#12 XI3XPLICITIX, Oct 17, 2012
Hey XI3XPLICITIX, as I suggested earlier on this thread, if you have a Google account also please post your findings or hints or any valuable info for that matter on my Google Bug Report. Google is probably (I am sure) not looking on forums like this one to see what problems people are having...

By posting on Google Android bug reports, we stand a chance for Google to see our problems.

My bug report is #36993.

#13 lpallard, Oct 17, 2012
Yup, so I, too, have same issues, same info. Random loss of wifi. I added myself to this link of victims... hopefully, it will addressed soon! Thanks.
#14 divinerebel, Nov 2, 2012
I had the same problem with my Galaxy Tab 10.1. The 4.0.4 upgrade stopped connecting with the authentication error. Nothing else changed. I noticed that on a first attempt it connected ok then tried again and failed. I checked my router and noticed i had SSID2 enabled. when I disabled this it connected ok. Hope it might help your situation.
#15 dalaoshu, Nov 3, 2012
Got this after the 4.1.1 update where I was not with 4.0.4.

I did a factory reset after the update to rule out hardware but same thing happened. Instead of using the traditional method of entering a network key I used the WPS function and my wifi works. Something is broke on our wifi, software related. i'm not rooted to do a log of the error and don't really care much as long as there was a way to get back on my home network.

Try using WPS, bottom line.

My router is ASUS ASUS RT-AC66U Dual-Band Wireless-AC1750 Gigabit Router
#16 jeffyo, Dec 15, 2012
My Note 2 loses wi-fi connection and then gives the authentication error. Then I put in the network authentication key. Even though I 'Save' the key the phone doesn't seem to remember it. Seems like that's the problem or at least one of them.
#17 Scottpush, Dec 27, 2012
I'm having the same issues - have tried all the various suggestions re Sleeping/Notifications etc. And know it's not my network as my partners Ace 2 connects easily every time.

Does anyone have a solution yet?
#18 TommyHutton, Dec 29, 2012
I have a Dual Antenna Linksys E3000 running: DD-WRT v24-sp2 (04/13/11) big, I had this problem while using the same ssid for both antennas with one of those antennas configured as Wireless N 5ghz only. I tried switching the N only ssid so that it was unique (appeared as a separate entry in available wireless aps) and connecting to it resulted in the same authentication error, while connecting to the original ssid (which was configured for NG-Mixed) worked as expected.

Essentially try removing Wireless N from the equation or at the very least ensure that it's not the only option. The devices seem to recognize N as the preferred mode, and therefore are trying to connect using it, however if it's the only option on the antenna being connected to then the connection seems to just fail.
#19 Justin Buser, Dec 29, 2012
having the same issue on my Note2 after updating the firmware last week. can connect to all wifi networks except my home network. solution pls.......
#20 shoeab, Jan 2, 2013
I only ge tthis issue when signal from the router is too weak to actually connect. Noticed it a few days ago in my office where we have a router set for low power.
#21 Szadzik, Jan 2, 2013
I had this same issue when they released the Jelly Bean update. I have cisco wireless router where I work that handle everything. I have never not had anything not connect to these bad boys. I also have an update home router that it has connection issues with as well. I mean it is kinda embaressing the only person who can't connect to wifi is the IT guy.

Any who I tried all the methods above except the linux one. I didn't want to mess with it since it is a different build but I rooted to another Jelly Bean rom and yet the same errors. I have also tried random wireless locations and to no avail. This is definitely something with the wireless buildout or I might have a broken phone. I might take it to verizon but then I have to flash back to stock.

I am going to post this on a couple of developer threads and see if they have seen it as well.
#22 TheRook, Jan 3, 2013
A solution: I encountered this same problem on my Galaxy SIII while my wife's had no problem at all connecting to our WIFI network. On another forum I read the suggestion to change my router's wireless security encryption from aes to tkip. So I changed it to aes+tkip -- and much to my very pleasant surprise, my phone connected to our WIFI network! So I'd like to suggest at least trying this change on your router to see if it might just solve the problem. Who knows?
#23 Dan_L, Jan 9, 2013

I have a Galaxy S3 with 4.1.1. Android Version and I started experienced the error issue after upgrading from the prior version.

The "connection" error showed up sporadically against my Netgear N Router with WPA2-PSK security around the house. After further testing, this is what I found out.

Without changing my phone settings or the router's, I stood up directly in front of the Wireless router to do the following:

On the phone only:
1) Forget the connection
2) Turn off WIFI
3) Turn on WIFI
4) Let the phone scan the home network
5) Reenter security password

After that, I got a valid IP address and the phone stayed connected around the whole house.

My guess is that there is a bug on the new Android version where the signal threshold gets corrupted during synch intervals. Did Google lower the standard on software reliability? I hope not and that a software fix be done soon.
#24 CharlieMX, Jan 12, 2013
I am also having the same issue. But sometimes it get connected automatically but in some cases it says Authentication Error. I also noticed this after runnig the JB update.

Anyway sometime when I tired with *#0011# and change the wifi power saving mode off, it got connected but its not working all the time.

If anybody found any solution pls share as its really irritating..
#25 wwwnalir, Jan 18, 2013
I solved the authentication problem by re-entering my Network Key (rather than my password)
#34 wvuguy, Apr 19, 2013